aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2016-10-13 09:50:31 +0800
committerzi <zi@FreeBSD.org>2016-10-13 09:50:31 +0800
commit20a72d513e487ec589bfe67fa9f9ab1e6f665b44 (patch)
treeabb11c864eaa1d142bf1ac8ce7666d0af795b4cd
parent9945563631ffbf289aa3d886b56240d05a99af11 (diff)
downloadfreebsd-ports-gnome-20a72d513e487ec589bfe67fa9f9ab1e6f665b44.tar.gz
freebsd-ports-gnome-20a72d513e487ec589bfe67fa9f9ab1e6f665b44.tar.zst
freebsd-ports-gnome-20a72d513e487ec589bfe67fa9f9ab1e6f665b44.zip
- Fix MASTER_SITES with googlecode disappearing
- Generate missing fex.1 man page - Bump PORTREVISION
-rw-r--r--textproc/fex/Makefile12
-rw-r--r--textproc/fex/distinfo5
-rw-r--r--textproc/fex/files/patch-Makefile10
3 files changed, 22 insertions, 5 deletions
diff --git a/textproc/fex/Makefile b/textproc/fex/Makefile
index a397c38cca1e..b009176002c6 100644
--- a/textproc/fex/Makefile
+++ b/textproc/fex/Makefile
@@ -3,16 +3,19 @@
PORTNAME= fex
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= textproc
-MASTER_SITES= http://semicomplete.googlecode.com/files/ \
- http://mirrors.rit.edu/zi/
MAINTAINER= zi@FreeBSD.org
COMMENT= Powerful field extraction tool
LICENSE= APACHE20
-BROKEN= Unfetchable (google code has gone away)
+USES= perl5
+USE_PERL5= build # pod2man
+USE_GITHUB= yes
+GH_ACCOUNT= jordansissel
+GH_TAGNAME= v${PORTVERSION}
MAKE_ENV+= INSTALLMAN=${PREFIX}/man
@@ -21,4 +24,7 @@ PLIST_FILES= bin/fex man/man1/fex.1.gz
post-patch:
@${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|g' ${WRKSRC}/Makefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
.include <bsd.port.mk>
diff --git a/textproc/fex/distinfo b/textproc/fex/distinfo
index 70a03096c973..07baf719e987 100644
--- a/textproc/fex/distinfo
+++ b/textproc/fex/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fex-2.0.0.tar.gz) = 03043c8eac74f43173068a2e693b6f73d5b45f453a063e6da11f34455d0e374e
-SIZE (fex-2.0.0.tar.gz) = 137198
+TIMESTAMP = 1476321695
+SHA256 (jordansissel-fex-2.0.0-v2.0.0_GH0.tar.gz) = b023711ddab9e656c077921c94d4346e21ab60d8c6d80b00191f3d581f4dfd7c
+SIZE (jordansissel-fex-2.0.0-v2.0.0_GH0.tar.gz) = 134965
diff --git a/textproc/fex/files/patch-Makefile b/textproc/fex/files/patch-Makefile
new file mode 100644
index 000000000000..6874ab045cc7
--- /dev/null
+++ b/textproc/fex/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2016-10-13 01:46:42 UTC
++++ Makefile
+@@ -36,6 +36,7 @@ install: fex
+
+ fex: fex.o
+ $(CC) $(CFLAGS) fex.o $(SNPRINTF_CC) -o $@
++ pod2man -c "" -r "" fex.pod > fex.1
+
+ fex.o: fex_version.h
+