aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-09-02 19:27:42 +0800
committerkoobs <koobs@FreeBSD.org>2013-09-02 19:27:42 +0800
commit2151fa56e0d307070e1cc014e6e54eee5ef82cec (patch)
treec6aa8b776386b05063cd57466bedc73a7f70052c
parentf679c01675caac937e366855f2ecbcb61f1f449f (diff)
downloadfreebsd-ports-gnome-2151fa56e0d307070e1cc014e6e54eee5ef82cec.tar.gz
freebsd-ports-gnome-2151fa56e0d307070e1cc014e6e54eee5ef82cec.tar.zst
freebsd-ports-gnome-2151fa56e0d307070e1cc014e6e54eee5ef82cec.zip
science/py-pupynere: Module for reading and writing NetCDF files [NEW PORT]
Pupynere is a Python module for reading and writing NetCDF files, using the same API as Scientific.IO.NetCDF and pynetcdf. It depends only on Numpy, so you don't need to have the NetCDF library installed. WWW: https://pypi.python.org/pypi/pupynere/ PR: ports/179744 Submitted by: Johannes Jost Meixner <xmj@chaot.net>
-rw-r--r--science/Makefile1
-rw-r--r--science/py-pupynere/Makefile22
-rw-r--r--science/py-pupynere/distinfo2
-rw-r--r--science/py-pupynere/files/patch-setup.py11
-rw-r--r--science/py-pupynere/pkg-descr5
-rw-r--r--science/py-pupynere/pkg-plist11
6 files changed, 52 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 16e6ed982629..a3510cf894ff 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -157,6 +157,7 @@
SUBDIR += py-netCDF4
SUBDIR += py-obspy
SUBDIR += py-paida
+ SUBDIR += py-pupynere
SUBDIR += py-pydicom
SUBDIR += py-scikit-learn
SUBDIR += py-scimath
diff --git a/science/py-pupynere/Makefile b/science/py-pupynere/Makefile
new file mode 100644
index 000000000000..004c30da06d0
--- /dev/null
+++ b/science/py-pupynere/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= pupynere
+PORTVERSION= 1.0.15
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Python module for reading and writing NetCDF files
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_NOEGGINFO= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-pupynere/distinfo b/science/py-pupynere/distinfo
new file mode 100644
index 000000000000..dd41cfacc6db
--- /dev/null
+++ b/science/py-pupynere/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pupynere-1.0.15.tar.gz) = b759b501406c950b576de1880f1dc080e05536ae42299267093e2379dac9086d
+SIZE (pupynere-1.0.15.tar.gz) = 8566
diff --git a/science/py-pupynere/files/patch-setup.py b/science/py-pupynere/files/patch-setup.py
new file mode 100644
index 000000000000..fb4fad76a2ed
--- /dev/null
+++ b/science/py-pupynere/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- ./setup.py.orig 2013-06-20 10:29:51.598889219 +0300
++++ ./setup.py 2013-06-20 10:30:03.628888237 +0300
+@@ -93,7 +93,7 @@
+ license='MIT',
+ py_modules=['pupynere'],
+ include_package_data=True,
+- zip_safe=True,
++ zip_safe=False,
+ test_suite = 'nose.collector',
+ install_requires=[
+ 'numpy',
diff --git a/science/py-pupynere/pkg-descr b/science/py-pupynere/pkg-descr
new file mode 100644
index 000000000000..d317cc77a1a5
--- /dev/null
+++ b/science/py-pupynere/pkg-descr
@@ -0,0 +1,5 @@
+Pupynere is a Python module for reading and writing NetCDF files, using the same
+API as Scientific.IO.NetCDF and pynetcdf. It depends only on Numpy, so you don't
+need to have the NetCDF library installed.
+
+WWW: http://bitbucket.org/robertodealmeida/pupynere/
diff --git a/science/py-pupynere/pkg-plist b/science/py-pupynere/pkg-plist
new file mode 100644
index 000000000000..44958d9627d9
--- /dev/null
+++ b/science/py-pupynere/pkg-plist
@@ -0,0 +1,11 @@
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/pupynere.py
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/pupynere.pyc
+%%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/pupynere.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg/EGG-INFO
+@dirrmtry %%PYTHON_SITELIBDIR%%/pupynere-1.0.15-py2.7.egg