aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-06-20 22:08:14 +0800
committerosa <osa@FreeBSD.org>2010-06-20 22:08:14 +0800
commit219e6a76757548b13d8022b35381b996269670e6 (patch)
tree7d99c6f3d893833776beba1b397f11f0e89eb3cf
parentfaab58b2ff1185f61c860214e12b1b02bfe8489f (diff)
downloadfreebsd-ports-gnome-219e6a76757548b13d8022b35381b996269670e6.tar.gz
freebsd-ports-gnome-219e6a76757548b13d8022b35381b996269670e6.tar.zst
freebsd-ports-gnome-219e6a76757548b13d8022b35381b996269670e6.zip
Fix "pkg_delete" problem after LICENSE knob issue found.
Feature safe: yes Spotted by: itetcu Approved by: rene (maintainer) via #bsdports
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile3
-rw-r--r--astro/boinc-setiathome-enhanced/pkg-plist1
2 files changed, 3 insertions, 1 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index 7293bd653ada..0dccb80786bd 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -76,7 +76,8 @@ SUB_LIST= SETI_BINARY=${SETI_BINARY} \
SETI_VERSION=${PORTVERSION:S/.//}
PLIST_SUB+= SETI_BINARY=${SETI_BINARY} \
SETI_SITE=${SETI_SITE} \
- BOINC_HOME=${BOINC_HOME}
+ BOINC_HOME=${BOINC_HOME} \
+ PREFIX=${PREFIX}
pre-configure:
(cd ${WRKSRC}; ./_autosetup ; ${REINPLACE_CMD} -E -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ./configure)
diff --git a/astro/boinc-setiathome-enhanced/pkg-plist b/astro/boinc-setiathome-enhanced/pkg-plist
index 594e6dece066..27137093ae5d 100644
--- a/astro/boinc-setiathome-enhanced/pkg-plist
+++ b/astro/boinc-setiathome-enhanced/pkg-plist
@@ -3,3 +3,4 @@
%%SETI_SITE%%/%%SETI_BINARY%%
%%X11%%%%SETI_SITE%%/seti_graphics
@dirrmtry %%SETI_SITE%%
+@cwd %%PREFIX%%