aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-22 20:40:32 +0800
committerbapt <bapt@FreeBSD.org>2013-03-22 20:40:32 +0800
commit2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d (patch)
tree2eef8dc8057844b13440984edd0115f961a53036
parenta88ef9ad052139f2fabce8ddfcba3cf5aa6f838e (diff)
downloadfreebsd-ports-gnome-2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d.tar.gz
freebsd-ports-gnome-2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d.tar.zst
freebsd-ports-gnome-2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d.zip
Convert to new options framework ports in p* catories
-rw-r--r--palm/pilot-link/Makefile28
-rw-r--r--ports-mgmt/kports-qt4/Makefile23
-rw-r--r--ports-mgmt/kports/Makefile28
-rw-r--r--ports-mgmt/portscout/Makefile19
-rw-r--r--print/cjk-lyx/Makefile21
-rw-r--r--print/foomatic-filters/Makefile71
-rw-r--r--print/latex-biblatex/Makefile17
-rw-r--r--print/latex-cjk/Makefile39
-rw-r--r--print/lyx16/Makefile12
-rw-r--r--print/pslib/Makefile37
-rw-r--r--print/py-reportlab2/Makefile21
-rw-r--r--print/teTeX/Makefile11
12 files changed, 139 insertions, 188 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 1113813382cb..58b378a1fa7c 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pilot-link
-# Date created: November, 1997
-# Whom: Paul Traina <pst@FreeBSD.org>
-#
+# Created by: Paul Traina <pst@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pilot-link
PORTVERSION= 0.12.5
@@ -17,41 +13,41 @@ COMMENT= Suite of tools used to connect and sync your Palm handled
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+USES= pathfix
USE_BZIP2= yes
USE_ICONV= yes
-USE_GNOME= gnomehack pkgconfig
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE} --with-included-popt --enable-conduits --enable-xsltproc
USE_LDCONFIG= yes
-OPTIONS= PNG "build with png support" off \
- THREADS "built-in thread safety" on \
- USB "Compile with USB via libusb support (READ MANUAL!)" off
+OPTIONS_DEFINE= PNG THREADS USB
+USB_DESC= Compile with USB via libusb support (READ MANUAL!)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+= --enable-threads
CFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
.endif
-.if defined(WITH_USB)
+.if ${PORT_OPTIONS:MUSB}
. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
. endif
CONFIGURE_ARGS+=--enable-libusb
LDFLAGS+= -L${PREFIX}/lib -lusb
-.if defined(WITHOUT_THREADS)
+.if ! ${PORT_OPTIONS:THREADS}
IGNORE= cannot be built: USB support requires THREADS turned on. Please reconfigure using 'make config'
.else
LDFLAGS+= ${PTHREAD_LIBS}
.endif
.endif
-.if defined(WITH_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-libpng=${PREFIX}
.else
@@ -67,8 +63,8 @@ post-patch:
${WRKSRC}/src/pilot-read-palmpix.c \
${WRKSRC}/src/pilot-read-screenshot.c \
${WRKSRC}/src/pilot-read-veo.c
-.if !defined(WITHOUT_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
@${REINPLACE_CMD} -e 's|Libs: |Libs: ${PTHREAD_LIBS} |' ${WRKSRC}/pilot-link.pc.in ${WRKSRC}/pilot-link-pp.pc.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ports-mgmt/kports-qt4/Makefile b/ports-mgmt/kports-qt4/Makefile
index b7514fb5873b..df1af6f7214f 100644
--- a/ports-mgmt/kports-qt4/Makefile
+++ b/ports-mgmt/kports-qt4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kports
-# Date created: Thu Jan 12 12:47:58 UTC 2006
-# Whom: Hannes Hauswedell <hannes.hauswedell@gmail.com>
-#
+# Created by: Hannes Hauswedell <hannes.hauswedell@gmail.com>
# $FreeBSD$
-#
PORTNAME= kports
PORTVERSION= 0.8.2
@@ -29,24 +25,25 @@ HAS_CONFIGURE= yes
LATEST_LINK= kports-qt4
-OPTIONS= DEBUG "Add Debugging Symbols" off \
- OXYGEN "Pull in Oxygen icons (recommended)" on \
- KDEBASE "Pull in kdebase-runtime for kdesu" on
+OPTIONS_DEFINE= DEBUG OXYGEN KDEBASE
+OPTIONS_DEFAULT= OXYGEN KDEBASE
+OXYGEN_DESC= Pull in Oxygen icons (recommended)
+KDEBASE_DESC= Pull in kdebase-runtime for kdesu
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_OXYGEN)
+.if ${PORT_OPTIONS:MOXYGEN}
USE_KDE4= oxygen
.endif
-.if !defined(WITHOUT_KDEBASE)
+.if ${PORT_OPTIONS:MKDEBASE}
USE_KDE4= runtime
.endif
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/data/kports.desktop
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
pre-configure:
@(${ECHO_CMD} "CONFIG += debug" >> ${WRKSRC}/src/src.pro)
@(${ECHO_CMD} "CONFIG -= release warn_off" >> ${WRKSRC}/src/src.pro)
@@ -59,11 +56,11 @@ do-configure:
${QMAKE} -unix ${QMAKE_ARGS} kports.pro
post-install:
-.if defined(WITHOUT_OXYGEN)
+.if ! ${PORT_OPTIONS:MOXYGEN}
@${CAT} pkg-message.nooxygen
.endif
-.if defined(WITHOUT_KDEBASE)
+.if ! ${PORT_OPTIONS:MKDEBASE}
@${CAT} pkg-message.nokdebase
.endif
diff --git a/ports-mgmt/kports/Makefile b/ports-mgmt/kports/Makefile
index d72bc66f1d8c..2b13460368b2 100644
--- a/ports-mgmt/kports/Makefile
+++ b/ports-mgmt/kports/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kports
-# Date created: Thu Jan 12 12:47:58 UTC 2006
-# Whom: Hannes Hauswedell <hannes.hauswedell@gmail.com>
-#
+# Created by: Hannes Hauswedell <hannes.hauswedell@gmail.com>
# $FreeBSD$
-#
PORTNAME= kports
PORTVERSION= 0.6.1
@@ -23,30 +19,32 @@ CONFLICTS= kports-0.[89]*
RUN_DEPENDS+= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade
RUN_DEPENDS+= kdehier>=0:${PORTSDIR}/misc/kdehier
-OPTIONS= PORTAUDIT "Require Portaudit" on \
- KDESU "With KDE3 kdesu" on \
- KDESU4 "With KDE4 kdesu" off \
- GKSU "With gksu" off
+OPTIONS_DEFINE= PORTAUDIT KDESU KDESU4 GKSU
+OPTIONS_DEFAULT= PORTAUDIT KDESU
+PORTAUDIT_DESC= Require Portaudit
+KDESU_DESC= With KDE3 kdesu
+KDESU4_DESC= With KDE4 kdesu
+GKSU_DESC= With gksu
.include <bsd.port.options.mk>
-.if defined(WITHOUT_KDESU) && defined(WITHOUT_KDESU4) && defined(WITHOUT_GKSU)
+.if ! ${PORT_OPTIONS:MKDESU} && ! ${PORT_OPTIONS:MKDESU4} && ! ${PORT_OPTIONS:MGKSU}
PKGMESSAGE= ${FILESDIR}/pkg-message.nosu
.endif
-.if !defined(WITHOUT_PORTAUDIT)
+.if ${PORT_OPTIONS:MPORTAUDIT}
RUN_DEPENDS+= portaudit:${PORTSDIR}/ports-mgmt/portaudit
.endif
-.if defined(WITH_KDESU)
+.if ${PORT_OPTIONS:MKDESU}
RUN_DEPENDS+= ${LOCALBASE}/bin/kdesu:${PORTSDIR}/x11/kdebase3
.endif
-.if defined(WITH_KDESU4)
+.if ${PORT_OPTIONS:MKDESU4}
USE_KDE4+= runtime
.endif
-.if defined(WITH_GKSU)
+.if ${PORT_OPTIONS:MGKSU}
RUN_DEPENDS+= ${LOCALBASE}/bin/gksu:${PORTSDIR}/sysutils/gksu
.endif
@@ -54,7 +52,7 @@ post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/src/kports.desktop
post-install:
-.if defined(WITHOUT_KDESU) && defined(WITHOUT_KDESU4) && defined(WITHOUT_GKSU)
+.if ! ${PORT_OPTIONS:MKDESU} && ! ${PORT_OPTIONS:MKDESU4} && ! ${PORT_OPTIONS:MGKSU}
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/ports-mgmt/portscout/Makefile b/ports-mgmt/portscout/Makefile
index 37a16e20852b..ccc4381ae7c6 100644
--- a/ports-mgmt/portscout/Makefile
+++ b/ports-mgmt/portscout/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: portscout
-# Date created: 2006-05-15
-# Whom: Shaun Amott <shaun@inerd.com>
-#
+# Created by: Shaun Amott <shaun@inerd.com>
# $FreeBSD$
-#
PORTNAME= portscout
PORTVERSION= 0.8.1
@@ -15,7 +11,8 @@ MASTER_SITES= http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/ \
MAINTAINER= shaun@FreeBSD.org
COMMENT= A tool to scan for new versions of FreeBSD ports
-OPTIONS= SQLITE3 "Use SQLite backend instead of PostgreSQL" off
+OPTIONS_DEFINE= SQLITE3 DOCS
+SQLITE3_DESC= Use SQLite backend instead of PostgreSQL
NO_BUILD= yes
USE_PERL5= yes
@@ -34,7 +31,7 @@ RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
.include <bsd.port.options.mk>
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
USE_SQLITE= 3
RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.elif !defined(WITHOUT_PGSQL)
@@ -43,7 +40,7 @@ RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
pre-everything::
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
@${ECHO_MSG} "+-------------------------------------------------------------+"
@${ECHO_MSG} "| Warning! although SQLite is supported, portscout will only |"
@${ECHO_MSG} "| operate in non-forking mode with this database backend. It |"
@@ -52,7 +49,7 @@ pre-everything::
.endif
post-patch:
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
@${REINPLACE_CMD} 's/^\([^#]*DBI:Pg.*\)$$/#\1/g' ${WRKSRC}/portscout.conf
@${REINPLACE_CMD} 's/^#\(.*DBI:SQLite.*\)$$/\1/g' ${WRKSRC}/portscout.conf
.endif
@@ -93,7 +90,7 @@ post-install:
@if [ ! -f ${PREFIX}/etc/portscout.conf ]; then \
${CP} -p ${PREFIX}/etc/portscout.conf.sample ${PREFIX}/etc/portscout.conf; \
fi
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
@@ -103,7 +100,7 @@ post-install:
test:
${PERL} ${WRKSRC}/t/00-use.t
${PERL} ${WRKSRC}/t/01-vercompare.t
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
${PERL} ${WRKSRC}/t/10-sqlite.t
#.else
# ${PERL} ${WRKSRC}/10-postgresql.t
diff --git a/print/cjk-lyx/Makefile b/print/cjk-lyx/Makefile
index 78a77d95da00..653e6eff6da0 100644
--- a/print/cjk-lyx/Makefile
+++ b/print/cjk-lyx/Makefile
@@ -26,13 +26,10 @@ LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs \
qt-mt:${PORTSDIR}/x11-toolkits/qt33
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
-OPTIONS= ASPELL "Utilize ASPELL library" on \
- ISPELL "Depend on ISPELL as well" off
-.if defined(LANG) && ${LANG:C/_.*//} == "ja"
-OPTIONS+= JATETEX "Use pLaTeX (Japanese LaTeX)" ON
-.else
-OPTIONS+= JATETEX "Use pLaTeX (Japanese LaTeX)" OFF
-.endif
+OPTIONS_DEFINE= ASPELL ISPELL JATETEX
+OPTIONS_DEFAULT= ASPELL
+OPTIONS_DEFAULT+= JATETEX
+JATETEX_DESC= pLaTeX (Japanese LaTeX)
ALL_TARGET= all check
USE_GNOME= lthack
@@ -67,23 +64,23 @@ post-install:
@${ECHO_MSG}
@${ECHO_MSG} "User setting folder will be created under ~/.${PKGNAMEPREFIX}lyx when ${PKGNAMEPREFIX}lyx is run for the first time."
@${ECHO_MSG}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
PLIST_SUB= PKGNAMEPREFIX=${PKGNAMEPREFIX}
-.if defined(WITH_ASPELL)
+.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
.endif
-.if defined(WITH_ISPELL)
+.if ${PORT_OPTIONS:MISPELL}
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
# Choose appropriate settings for each LaTeX
-.if defined(WITH_JATETEX)
+.if ${PORT_OPTIONS:MJATETEX}
BUILD_DEPENDS+= latex:${PORTSDIR}/japanese/teTeX
RUN_DEPENDS+= latex:${PORTSDIR}/japanese/teTeX
.else
@@ -91,4 +88,4 @@ BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= latex:${PORTSDIR}/print/teTeX
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/foomatic-filters/Makefile b/print/foomatic-filters/Makefile
index 6db33fdb5a1c..75a27083fd1b 100644
--- a/print/foomatic-filters/Makefile
+++ b/print/foomatic-filters/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: foomatic-rip
-# Date created: 2005-01-28
-# Whom: Michael Nottebrock <lofi@FreeBSD.org>
-#
+# Created by: Michael Nottebrock <lofi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= foomatic-filters
PORTVERSION= 4.0.7
@@ -32,76 +28,57 @@ CONFIGURE_ENV= ac_cv_path_A2PS=${LOCALBASE}/bin/a2ps \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= CUPS_IMAGE "Install cups image utilities" on \
- A2PS_A4 "Install a2ps convertor (A4)" on \
- A2PS_LETTER "Install a2ps convertor (letter)" off \
- A2PS_LETTERDJ "Install a2ps convertor (letterdj)" off \
- ENSCRIPT_A4 "Install enscript convertor (A4)" on \
- ENSCRIPT_LETTER "Install enscript convertor (letter)" off \
- ENSCRIPT_LETTERDJ "Install enscript convertor (letterdj)" off \
- MPAGE "Print multiple pages per sheet of paper" on
+OPTIONS_DEFINE= CUPS_IMAGE MPAGE
+OPTIONS_SINGLE= A2PS ENSCRIPT
+OPTIONS_SINGLE_A2PS= A2PS_A4 A2PS_LETTER A2PS_LETTERDJ
+OPTIONS_SINGLE_ENSCRIPT= ENSCRIPT_A4 ENSCRIPT_LETTER ENSCRIPT_LETTERDJ
+OPTIONS_DEFAULT= CUPS_IMAGE A2PS_A4 ENSCRIPT_A4 MPAGE
+CUPS_IMAGE_DESC= Install cups image utilities
+A2PS_A4_DESC= Install a2ps convertor (A4)
+A2PS_LETTER_DESC= Install a2ps convertor (letter)
+A2PS_LETTERDJ_DESC= Install a2ps convertor (letterdj)
+ENSCRIPT_A4_DESC= Install enscript convertor (A4)
+ENSCRIPT_LETTER_DESC= Install enscript convertor (letter)
+ENSCRIPT_LETTERDJ_DESC= Install enscript convertor (letterdj)
+MPAGE_DESC= Print multiple pages per sheet of paper
MAN1= foomatic-rip.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_CUPS_IMAGE)
+.if ${PORT_OPTIONS:MCUPS_IMAGE}
RUN_DEPENDS+= ${LOCALBASE}/lib/libcupsimage.so:${PORTSDIR}/print/cups-image
.endif
-.if defined(WITH_A2PS_A4)
-. if defined(WITH_A2PS_LETTER) || defined(WITH_A2PS_LETTERDJ)
-IGNORE= Please select only one a2ps convertor
-. else
+.if ${PORT_OPTIONS:MA2PS_A4}
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-a4
-. endif
.endif
-.if defined(WITH_A2PS_LETTER)
-. if defined(WITH_A2PS_A4) || defined(WITH_A2PS_LETTERDJ)
-IGNORE= Please select only one a2ps convertor
-. else
+.if ${PORT_OPTIONS:MA2PS_LETTER}
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter
-. endif
.endif
-.if defined(WITH_A2PS-LETTERDJ)
-. if defined(WITH_A2PS-A4) || defined(WITH_A2PS_LETTER)
-IGNORE= Please select only one a2ps convertor
-. else
+.if ${PORT_OPTIONS:MA2PS-LETTERDJ}
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letterdj
-. endif
.endif
-.if defined(WITH_ENSCRIPT_A4)
-. if defined(WITH_ENSCRIPT_LETTER) || defined(WITH_ENSCRIPT_LETTERDJ)
-IGNORE= Please select only one enscript convertor
-. else
+.if ${PORT_OPTIONS:MENSCRIPT_A4}
RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-a4
-. endif
.endif
-.if defined(WITH_ENSCRIPT_LETTER)
-. if defined(WITH_ENSCRIPT_A4) || defined(WITH_ENSCRIPT_LETTERDJ)
-IGNORE= Please select only one enscript convertor
-. else
+.if ${PORT_OPTIONS:MENSCRIPT_LETTER}
RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-letter
-. endif
.endif
-.if defined(WITH_ENSCRIPT_LETTERDJ)
-. if defined(WITH_ENSCRIPT_A4) || defined(WITH_ENSCRIPT_LETTER)
-IGNORE= Please just select only one enscript convertor
-. else
+.if ${PORT_OPTIONS:MENSCRIPT_LETTERDJ}
RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-letterdj
-. endif
.endif
-.if defined(WITH_MPAGE)
+.if ${PORT_OPTIONS:MMPAGE}
RUN_DEPENDS+= mpage:${PORTSDIR}/print/mpage
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|${SH}|g' ${WRKSRC}/foomaticrip.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/latex-biblatex/Makefile b/print/latex-biblatex/Makefile
index 9f37a2a23d01..a4b9d42de8b0 100644
--- a/print/latex-biblatex/Makefile
+++ b/print/latex-biblatex/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: latex-biblatex
-# Date created: 19 Jan 2008
-# Whom: vj562001@yahoo.de
-#
+# Created by: vj562001@yahoo.de
# $FreeBSD$
-#
PORTNAME= biblatex
PORTVERSION= 0.9e
@@ -44,7 +40,8 @@ BST_FILES= biblatex.bst
WRKSRC= ${WRKDIR}/${CLASSNAME}
-OPTIONS= BIBTEXT8_CSF "Install BibTeX8 sort definition files" OFF
+OPTIONS_DEFINE= BIBTEXT8_CSF DOCS
+BIBTEXT8_CSF_DESC= BibTeX8 sort definition files
.include <bsd.port.options.mk>
@@ -63,13 +60,13 @@ pre-install:
${ECHO_CMD} "${BSTDIR}/$${F}"; \
done;) >> ${PLIST}
${ECHO_CMD} "@dirrm ${BSTDIR}" >> ${PLIST}
-.if defined(WITH_BIBTEXT8_CSF)
+.if ${PORT_OPTIONS:MBIBTEXT8_CSF}
(for F in `${LS} -F ${WRKSRC}/bibtex/csf`; do \
${ECHO_CMD} "${CSFDIR}/$${F}"; \
done;) >> ${PLIST}
${ECHO_CMD} "@dirrm ${CSFDIR}" >> ${PLIST}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
(for F in ${DOC_FILES:S,^doc/,,}; do \
${ECHO_CMD} "${DOCSDIR:S,^${PREFIX}/,,}/$${F}"; \
done;) >> ${PLIST}
@@ -87,11 +84,11 @@ do-install:
(cd ${WRKSRC}/latex/ && ${COPYTREE_SHARE} \* ${PREFIX}/${CLASSDIR})
${MKDIR} ${PREFIX}/${BSTDIR}
${INSTALL_DATA} ${BST_FILES:S@^@${WRKSRC}/bibtex/bst/@} ${PREFIX}/${BSTDIR}
-.if defined(WITH_BIBTEXT8_CSF)
+.if ${PORT_OPTIONS:MBIBTEXT8_CSF}
${MKDIR} ${PREFIX}/${CSFDIR}
(cd ${WRKSRC}/bibtex/csf && ${COPYTREE_SHARE} \* ${PREFIX}/${CSFDIR})
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
diff --git a/print/latex-cjk/Makefile b/print/latex-cjk/Makefile
index 2367f68e8271..8c691cfbf890 100644
--- a/print/latex-cjk/Makefile
+++ b/print/latex-cjk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zh-CJK
-# Date created: 5 Sep 1999
-# Whom: Jing-Tang Keith Jang (keith@FreeBSD.org)
-#
+# Created by: Jing-Tang Keith Jang (keith@FreeBSD.org)
# $FreeBSD$
-#
PORTNAME= latex-cjk
PORTVERSION= 4.8.2
@@ -38,27 +34,28 @@ INSTALL_DIR= ${INSTALL} -d -m 0755 -o root -g wheel
WRKFONTDIR= ${WRKDIR}/fonts
-# Options: WITH_*/WITHOUT_*
-OPTIONS= CCMAP "CCT CCMap package (for PDFTeX's CID support)" on \
- DVIPDFMX "Install and configure DVIPDFMx for CJK" on \
- UTF8ARPHIC "Arphic free fonts in UTF-8 (no Type 1)" on
+OPTIONS_DEFINE= CCMAP DVIPDFMX UTF8ARPHIC DOCS NLS
+OPTIONS_DEFAULT= CCMAP DVIPDFMX UTF8ARPHIC
+CCMAP_DESC= CCT CCMap package (for PDFTeX's CID support)
+DVIPDFMX_DESC= Install and configure DVIPDFMx for CJK
+UTF8ARPHIC_DESC= Arphic free fonts in UTF-8 (no Type 1)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_CCMAP)
-PLIST_SUB+= CCMAP="@comment "
-.else
+.if ${PORT_OPTIONS:MCCMAP}
MASTER_SITES+= http://ftp.intron.ac/pub/FreeBSD/local-distfiles/:cct
DISTFILES+= cct-20060219-ccmap.tar.gz:cct
PLIST_SUB+= CCMAP=""
+.else
+PLIST_SUB+= CCMAP="@comment "
.endif
-.if !defined(WITHOUT_DVIPDFMX)
+.if ${PORT_OPTIONS:MDVIPDFMX}
RUN_DEPENDS+= dvipdfmx:${PORTSDIR}/print/dvipdfmx
# Configuration is done by "pkg-install"
.endif
-.if defined(WITH_UTF8ARPHIC)
+.if ${PORT_OPTIONS:MUTF8ARPHIC}
PLIST_SUB+= UTF8ARPHIC=""
.else
PLIST_SUB+= UTF8ARPHIC="@comment "
@@ -71,7 +68,7 @@ post-patch:
# be compatible with Debian
@${CP} -p ${WRKSRC}/texinput/Bg5/c00kai.fd ${WRKSRC}/texinput/Bg5/c00bkai.fd
@${REINPLACE_CMD} -e 's,c00kai.fd,c00bkai.fd,; s,{kai},{bkai},' ${WRKSRC}/texinput/Bg5/c00bkai.fd
-.if defined(WITH_CCMAP)
+.if ${PORT_OPTIONS:MCCMAP}
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' ${WRKDIR}/ccmap/make.sh
.endif
@${FIND} -E ${WRKSRC} ${WRKDIR}/ccmap -regex '.*.(orig|bak)' -delete
@@ -80,11 +77,11 @@ pre-su-install:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} ${EXAMPLESDIR}
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
@@ -115,14 +112,14 @@ post-install:
${SCRIPTDIR}/installt1enc.sh argbkai argbkai.ttf GB
# Install package ccmap
-.if !defined(WITHOUT_CCMAP)
+.if ${PORT_OPTIONS:MCCMAP}
@${ECHO_CMD} "Installing ccmap..."
${MKTEXLSR}
cd ${WRKDIR}/ccmap && ${SH} make.sh && ${COPYTREE_SHARE} \* ${CJKDIR}/ccmap
.endif
# Install Arphic fonts in Unicode separation for Type 3 or DVIPDFMx
-.if defined(WITH_UTF8ARPHIC)
+.if ${PORT_OPTIONS:MUTF8ARPHIC}
@${ECHO_CMD} "Generating Arphic fonts' TFM files in Unicode..."
${SETENV} LOCALBASE=${LOCALBASE} ${SH} ${SCRIPTDIR}/installtfm.sh \
arb5sungu arb5sung.ttf Unicode
@@ -145,4 +142,4 @@ post-install:
${CAT} ${PKGMESSAGE}
.include "../../print/latex-cjk/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index 3a78a9e8ddec..9ae9edcf73cb 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -41,19 +41,19 @@ MAKE_JOBS_SAFE= yes
MAN1= lyx.1 lyxclient.1 tex2lyx.1
-OPTIONS= ASPELL "Use Aspell library" on \
- AIKSAUR "Build Aiksaurus support (English thesaurus)" on \
- NLS "Native language support" on
+OPTIONS_DEFINE= ASPELL AIKSAUR NLS
+OPTIONS_DEFAULT= ASPELL AIKSAUR NLS
+AIKSAUR_DESC= Aiksaurus support (English thesaurus)
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_AIKSAUR)
+.if ${PORT_OPTIONS:MAIKSAUR}
LIB_DEPENDS+= Aiksaurus:${PORTSDIR}/textproc/aiksaurus
.else
CONFIGURE_ARGS+= --without-aiksaurus
.endif
-.if !defined(WITHOUT_ASPELL)
+.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
@@ -62,7 +62,7 @@ CONFIGURE_ARGS+= --with-pspell \
CONFIGURE_ARGS+= --without-aspell --without-pspell
.endif
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 09afe26070c7..b23d9bfdb2f2 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: pslib
-# Date created: Jul 13, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= pslib
PORTVERSION= 0.4.5
@@ -19,7 +14,9 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
-USE_GNOME= gnomehack intlhack pkgconfig
+USES= pathfix
+USE_PKGCONFIG= build
+USE_GNOME= intlhack
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
@@ -27,13 +24,13 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
USE_LDCONFIG= yes
-OPTIONS= EXAMPLES "Install additional examples" On \
- MAN "Install manual pages" On \
- NLS "Native language support" On
+OPTIONS_DEFINE= EXAMPLES MAN NLS
+OPTIONS_DEFAULT= MAN NLS
+MAN_DESC= Manual pages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
EX_NAME= pslib-examples-0.0.10
EX_WRKSRC= ${WRKDIR}/${EX_NAME}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${EX_NAME}${EXTRACT_SUFX}
@@ -42,7 +39,7 @@ PLIST_SUB+= EXAMPLES=""
PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if !defined(WITHOUT_MAN)
+.if ${PORT_OPTIONS:MMAN}
BUILD_DEPENDS+= ${LOCALBASE}/bin/docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
${LOCALBASE}/bin/docbook2man:${PORTSDIR}/textproc/docbook-utils
MAN3!= ${CAT} ${FILESDIR}/man3
@@ -51,25 +48,25 @@ MAN3!= ${CAT} ${FILESDIR}/man3
CONFIGURE_ENV+= ac_cv_prog_DOC_TO_MAN=""
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ENV+= ac_cv_header_libintl_h=no
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ENV+= ac_cv_header_libintl_h=no
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's|@USE_NLS@|no|g' ${WRKSRC}/po/Makefile.in.in
.endif
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} -m 0755 ${EXAMPLESDIR}
@${RM} -f ${EX_WRKSRC}/Makefile.unix ${EX_WRKSRC}/ChangeLog \
${EX_WRKSRC}/CMakeLists.txt
cd ${EX_WRKSRC} && ${PAX} -rw * ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/py-reportlab2/Makefile b/print/py-reportlab2/Makefile
index 404e2dac7a6d..178fa0671dd8 100644
--- a/print/py-reportlab2/Makefile
+++ b/print/py-reportlab2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-reportlab2
-# Date created: 2006-12-31
-# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
-#
+# Created by: Li-Wen Hsu <lwhsu@lwhsu.org>
# $FreeBSD$
-#
PORTNAME= reportlab2
PORTVERSION= 2.5
@@ -20,8 +16,9 @@ LICENSE= BSD
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imaging>0:${PORTSDIR}/graphics/py-imaging
-OPTIONS= CJK "Adobe CMaps" on \
- FREETYPE "FreeType" on
+OPTIONS_DEFINE= CJK FREETYPE DOCS
+OPTIONS_DEFAULT= CJK FREETYPE
+CJK_DESC= Adobe CMaps
WRKSRC= ${WRKDIR}/reportlab-${PORTVERSION}
@@ -45,22 +42,22 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/ports/distfiles|${DISTDIR}|g' ${WRKSRC}/setup.py
@${REINPLACE_CMD} -e 's|pfbfer.zip|pfbfer-${PFBFER_VERSION}.zip|g' ${WRKSRC}/setup.py
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not install on sparc64
.endif
-.if !defined(WITHOUT_CJK)
+.if ${PORT_OPTIONS:MCJK}
RUN_DEPENDS+= ${LOCALBASE}/share/fonts/adobe-cmaps/ac15/cid2code.txt:${PORTSDIR}/print/adobe-cmaps
.endif
-.if !defined(WITHOUT_FREETYPE)
+.if ${PORT_OPTIONS:MFREETYPE}
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC}/docs && ${PYTHON_CMD} genAll.py
${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
@@ -68,4 +65,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/teTeX/Makefile b/print/teTeX/Makefile
index a3387c7091fe..a6a406193802 100644
--- a/print/teTeX/Makefile
+++ b/print/teTeX/Makefile
@@ -18,11 +18,12 @@ RUN_DEPENDS= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal \
${LOCALBASE}/share/fonts/cm-super/README:${PORTSDIR}/print/cm-super \
dvips:${PORTSDIR}/print/dvipsk-tetex
-OPTIONS= LETTERSIZE "Use letter size by default" off
+OPTIONS_DEFINE= LETTERSIZE X11
+LETTERSIZE_DESC= Use letter size by default
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
.endif
@@ -35,7 +36,7 @@ CONFLICTS= latex2e-[0-9]* tex-[0-9]* dvips-[0-9]* xdvi-[0-9]* \
tex-kpathsea-[0-9]* tex-xdvik-[0-9]* \
tex-dvipsk-[0-9]* tex-dvipdfmx-[0-9]*
-.if defined(WITH_LETTERSIZE)
+.if ${PORT_OPTIONS:MLETTERSIZE}
FLAVOR+= letter
DEPENDS_ARGS+= WITH_LETTERSIZE=true
PAPERSIZE= letter
@@ -57,4 +58,4 @@ do-build:
do-install: #emtpy
@${DO_NADA}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>