aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-12-04 02:02:41 +0800
committeryuri <yuri@FreeBSD.org>2017-12-04 02:02:41 +0800
commit262ced4dc5523a2950c376abe34da4a910053202 (patch)
treec8689c1b6aa2475f608bed0a16d48af070be72b4
parent6489a034d48c1885cfa7a8d5cad6f991f7dbc7c2 (diff)
downloadfreebsd-ports-gnome-262ced4dc5523a2950c376abe34da4a910053202.tar.gz
freebsd-ports-gnome-262ced4dc5523a2950c376abe34da4a910053202.tar.zst
freebsd-ports-gnome-262ced4dc5523a2950c376abe34da4a910053202.zip
New port: devel/libtsm: Terminal-emulator state machine
PR: 219971 Submitted by: Angus Gibson <freebsd@angus.agibson.me> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13302
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libtsm/Makefile27
-rw-r--r--devel/libtsm/distinfo3
-rw-r--r--devel/libtsm/pkg-descr18
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 21cadd741742..17e08f64663d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1554,6 +1554,7 @@
SUBDIR += libtool
SUBDIR += libtpl
SUBDIR += libtrue
+ SUBDIR += libtsm
SUBDIR += libtuntap
SUBDIR += libublio
SUBDIR += libudev-devd
diff --git a/devel/libtsm/Makefile b/devel/libtsm/Makefile
new file mode 100644
index 000000000000..50f92cdaf8f1
--- /dev/null
+++ b/devel/libtsm/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= libtsm
+DISTVERSION= 3
+CATEGORIES= devel
+MASTER_SITES= http://freedesktop.org/software/kmscon/releases/
+
+MAINTAINER= angus@agibson.me
+COMMENT= Terminal-emulator state machine
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake libtool tar:xz
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-debug --disable-static
+CONFIGURE_ENV= PKG_CONFIG=/dev/null # disable tests
+INSTALL_TARGET= install-strip
+
+PLIST_FILES= include/libtsm.h \
+ lib/libtsm.so \
+ lib/libtsm.so.3 \
+ lib/libtsm.so.3.0.0 \
+ libdata/pkgconfig/libtsm.pc
+
+.include <bsd.port.mk>
diff --git a/devel/libtsm/distinfo b/devel/libtsm/distinfo
new file mode 100644
index 000000000000..d8dcf549460c
--- /dev/null
+++ b/devel/libtsm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497389678
+SHA256 (libtsm-3.tar.xz) = 114115d84a2bc1802683871ea2d70a16ddeec8d2f8cde89ebd2046d775e6cf07
+SIZE (libtsm-3.tar.xz) = 293264
diff --git a/devel/libtsm/pkg-descr b/devel/libtsm/pkg-descr
new file mode 100644
index 000000000000..ec1e2314314b
--- /dev/null
+++ b/devel/libtsm/pkg-descr
@@ -0,0 +1,18 @@
+TSM is a state machine for DEC VT100-VT520 compatible terminal emulators. It
+tries to support all common standards while keeping compatibility to existing
+emulators like xterm, gnome-terminal, konsole, etc.
+
+TSM itself does not provide any rendering nor window management. It is a simple
+plain state machine without any external dependencies. It can be used to
+implement terminal emulators, but also to implement other applications that
+need to interpret terminal escape sequences.
+
+This library is very similar to libvte of the gnome project. However, libvte is
+highly bound to GTK+, which makes it unsuitable for non-graphics projects that
+need to parse escape sequences. Instead, TSM tries to restrict its API to
+terminal emulation only. Furthermore, TSM does not try to establish a new
+terminal emulation standard, but instead keeps compatibility as close to xterm
+as possible. This is why the TERM variable can be set to xterm-color256 with
+any TSM based terminal emulator.
+
+WWW: https://www.freedesktop.org/wiki/Software/kmscon/libtsm/