aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2018-04-01 00:23:13 +0800
committermartymac <martymac@FreeBSD.org>2018-04-01 00:23:13 +0800
commit29e4854b73fd180a59c190cca0debac8932c93a5 (patch)
tree4cfb989952647186eae2a821a946bbb2fdf59fd1
parent2b26ca0f008aa7b807c45c94a3413d83b9938a9c (diff)
downloadfreebsd-ports-gnome-29e4854b73fd180a59c190cca0debac8932c93a5.tar.gz
freebsd-ports-gnome-29e4854b73fd180a59c190cca0debac8932c93a5.tar.zst
freebsd-ports-gnome-29e4854b73fd180a59c190cca0debac8932c93a5.zip
emulators/dolphin-emu: set LLD_UNSAFE
Prevent Dolphin from linking using lld as it fails with errors like: /usr/bin/ld: error: cannot preempt symbol: alcOpenDevice >>> defined in /usr/local/lib/libopenal.so >>> referenced by OpenALStream.cpp >>> OpenALStream.cpp.o:(OpenALStream::Start()) due to preemption of symbols with protected visibility in a shared object. See also PR #219089 for more details. PR: 226980 Submitted by: emaste
-rw-r--r--emulators/dolphin-emu/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 33677369b4e4..f7b718f457b1 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -31,6 +31,7 @@ LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libcurl.so:ftp/curl \
libgtest.so:devel/googletest
+LLD_UNSAFE= yes
USES= cmake compiler:c++11-lib iconv openal pkgconfig
USE_GITHUB= yes