aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2008-05-21 14:44:36 +0800
committerobrien <obrien@FreeBSD.org>2008-05-21 14:44:36 +0800
commit2d49cbe8fc1393bcc80d0e66a8da69d4665424e8 (patch)
treec882614cd2fe5cd079d5fc2286fcc66e2992b4bd
parentcfe92655166d95fc233a0d4ca141760909c7b7bc (diff)
downloadfreebsd-ports-gnome-2d49cbe8fc1393bcc80d0e66a8da69d4665424e8.tar.gz
freebsd-ports-gnome-2d49cbe8fc1393bcc80d0e66a8da69d4665424e8.tar.zst
freebsd-ports-gnome-2d49cbe8fc1393bcc80d0e66a8da69d4665424e8.zip
Add a debugging knob (WITH_RDESKTOP_DEBUG) to help folks figure out any
problems they may have. [parts derived from the PR] PR: 123720 Submitted-by: Alexander Logvinov <ports@logvinov.com>
-rw-r--r--net/rdesktop/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 5be8cf1cfbc7..9c272c1a5f5c 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -22,10 +22,23 @@ GNU_CONFIGURE= yes
DOCS= doc/AUTHORS doc/TODO doc/*.txt
MAN1= rdesktop.1
-.if !defined(WITHOUT_IPV6)
+.if !defined(WITHOUT_RDESKTOP_IPV6) && !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --with-ipv6
.endif
+.if defined(WITH_RDESKTOP_DEBUG)
+CONFIGURE_ARGS+= --with-debug\
+ --with-debug-kbd\
+ --with-debug-rdp5\
+ --with-debug-clipboard\
+ --with-debug-sound\
+ --with-debug-channel\
+ --with-debug-seamless
+
+post-configure:
+ ${ECHO} "#define WITH_DEBUG_SERIAL 1" >> ${WRKSRC}/rdesktop.h
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rdesktop ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/rdesktop.1 ${MAN1PREFIX}/man/man1