aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2017-08-03 17:48:16 +0800
committerjhale <jhale@FreeBSD.org>2017-08-03 17:48:16 +0800
commit2e3262ad99b90710d91f129309c6c04a63b086f1 (patch)
treef442cbe243302af46b81134516d297a1332cdef2
parent5ec29bd5bc414d559dd4be2a8941e11ccebf493f (diff)
downloadfreebsd-ports-gnome-2e3262ad99b90710d91f129309c6c04a63b086f1.tar.gz
freebsd-ports-gnome-2e3262ad99b90710d91f129309c6c04a63b086f1.tar.zst
freebsd-ports-gnome-2e3262ad99b90710d91f129309c6c04a63b086f1.zip
Update to 4.18.0
Fix overlinking in devel/gwenhywfar-qt5
-rw-r--r--devel/gwenhywfar/Makefile8
-rw-r--r--devel/gwenhywfar/distinfo6
-rw-r--r--devel/gwenhywfar/files/patch-configure59
-rw-r--r--devel/gwenhywfar/pkg-plist3
4 files changed, 58 insertions, 18 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index a9bce2ba6053..2a28c2eac587 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= gwenhywfar
-PORTVERSION= 4.15.3
-PORTREVISION?= 1
+PORTVERSION= 4.18.0
+PORTREVISION?= 0
CATEGORIES= devel net security
-MASTER_SITES= http://www.aquamaniac.de/sites/download/download.php?package=01&release=201&file=01&dummy=/
+MASTER_SITES= http://www.aquamaniac.de/sites/download/download.php?package=01&release=206&file=01&dummy=/
MAINTAINER?= jhale@FreeBSD.org
COMMENT?= Multi-platform helper library for networking and security applications
@@ -65,7 +65,7 @@ CONFIGURE_ARGS+=--with-qt4-includes=${QT_INCDIR} \
--with-qt4-uic=${UIC}
. elif ${SLAVEPORT}=="qt5"
USE_GL= gl
-USE_QT5= core dbus gui network printsupport qml testlib widgets xml \
+USE_QT5= core gui widgets \
buildtools_build linguisttools_build qmake_build
QT_NONSTANDARD= yes
CONFIGURE_ARGS+=--with-qt5-qmake=${QMAKE} \
diff --git a/devel/gwenhywfar/distinfo b/devel/gwenhywfar/distinfo
index c637d12c38d5..97495607420d 100644
--- a/devel/gwenhywfar/distinfo
+++ b/devel/gwenhywfar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1474457855
-SHA256 (gwenhywfar-4.15.3.tar.gz) = 6a0e8787c99620414da6140e567c616b55856c5edf8825a9ebc67431923ee63a
-SIZE (gwenhywfar-4.15.3.tar.gz) = 2249350
+TIMESTAMP = 1501744741
+SHA256 (gwenhywfar-4.18.0.tar.gz) = 6915bba42d8b7f0213cee186a944296e5e5e97cdbde5b539a924261af03086ca
+SIZE (gwenhywfar-4.18.0.tar.gz) = 2333059
diff --git a/devel/gwenhywfar/files/patch-configure b/devel/gwenhywfar/files/patch-configure
index 4efed9c9ba3e..d5a002651914 100644
--- a/devel/gwenhywfar/files/patch-configure
+++ b/devel/gwenhywfar/files/patch-configure
@@ -1,6 +1,10 @@
---- configure.orig 2016-04-23 16:22:43 UTC
+Fix dectection of fox libs
+Allow configuring the locations of lrelease and lupdate
+Prevent linking to unneeded Qt5 libraries
+
+--- configure.orig 2017-07-30 14:20:32 UTC
+++ configure
-@@ -948,6 +948,8 @@ with_x
+@@ -951,6 +951,8 @@ with_x
with_qt5_qmake
with_qt5_moc
with_qt5_uic
@@ -9,7 +13,7 @@
with_docpath
enable_release
enable_memtrace
-@@ -1668,6 +1670,8 @@ Optional Packages:
+@@ -1672,6 +1674,8 @@ Optional Packages:
--with-qt5-qmake=FILE uses given qmake
--with-qt5-moc=FILE uses given qt moc
--with-qt5-uic=FILE uses given qt uic
@@ -18,7 +22,7 @@
--with-docpath=DIR where to store the apidoc
--with-buffer-hardlimit=VALUE new default buffer hard limit
--with-plugins-ct=LIST list of CT plugins to build
-@@ -21079,7 +21083,7 @@ $as_echo_n "checking for fox libraries..
+@@ -21084,7 +21088,7 @@ $as_echo_n "checking for fox libraries..
# Check whether --with-fox-libs was given.
if test "${with_fox_libs+set}" = set; then :
@@ -27,18 +31,53 @@
else
ac_ext=cpp
-@@ -22445,8 +22449,8 @@ percent.commands = @echo -n "\$(\$(@))\
+@@ -22415,43 +22419,16 @@ $as_echo_n "checking for Qt... " >&6; }
+ am_have_qt_makefile=`mktemp`
+ # http://qt-project.org/doc/qt-5/qmake-variable-reference.html#qt
+ cat > $am_have_qt_pro << EOF
+-qtHaveModule(axcontainer): QT += axcontainer
+-qtHaveModule(axserver): QT += axserver
+-qtHaveModule(concurrent): QT += concurrent
+ qtHaveModule(core): QT += core
+-qtHaveModule(dbus): QT += dbus
+-qtHaveModule(declarative): QT += declarative
+-qtHaveModule(designer): QT += designer
+ qtHaveModule(gui): QT += gui
+-qtHaveModule(help): QT += help
+-qtHaveModule(multimedia): QT += multimedia
+-qtHaveModule(multimediawidgets): QT += multimediawidgets
+-qtHaveModule(network): QT += network
+-qtHaveModule(opengl): QT += opengl
+-qtHaveModule(printsupport): QT += printsupport
+-qtHaveModule(qml): QT += qml
+-qtHaveModule(qmltest): QT += qmltest
+-qtHaveModule(x11extras): QT += x11extras
+-qtHaveModule(script): QT += script
+-qtHaveModule(scripttools): QT += scripttools
+-qtHaveModule(sensors): QT += sensors
+-qtHaveModule(serialport): QT += serialport
+-qtHaveModule(sql): QT += sql
+-qtHaveModule(svg): QT += svg
+-qtHaveModule(testlib): QT += testlib
+-qtHaveModule(uitools): QT += uitools
+-qtHaveModule(webkit): QT += webkit
+-qtHaveModule(webkitwidgets): QT += webkitwidgets
+-qtHaveModule(xml): QT += xml
+-qtHaveModule(xmlpatterns): QT += xmlpatterns
+ qtHaveModule(widgets): QT += widgets
+ percent.target = %
+ percent.commands = @echo -n "\$(\$(@))\ "
QMAKE_EXTRA_TARGETS += percent
EOF
$QT_QMAKE $am_have_qt_pro -o $am_have_qt_makefile
-- QT_CXXFLAGS=`make -f $am_have_qt_makefile CXXFLAGS INCPATH`
-- QT_LIBS=`make -f $am_have_qt_makefile LIBS`
-+ QT_CXXFLAGS=`make -f $am_have_qt_makefile -VCXXFLAGS -VINCPATH | tr '\n' ' '`
-+ QT_LIBS=`make -f $am_have_qt_makefile -VLIBS | tr '\n' ' '`
+- QT_CXXFLAGS=`make -s -f $am_have_qt_makefile CXXFLAGS INCPATH`
+- QT_LIBS=`make -s -f $am_have_qt_makefile LIBS`
++ QT_CXXFLAGS=`make -s -f $am_have_qt_makefile -VCXXFLAGS -VINCPATH | tr '\n' ' '`
++ QT_LIBS=`make -s -f $am_have_qt_makefile -VLIBS | tr '\n' ' '`
rm $am_have_qt_pro $am_have_qt_makefile
# Look for specific tools in $PATH
-@@ -22469,9 +22473,21 @@ else
+@@ -22474,9 +22451,21 @@ else
fi
diff --git a/devel/gwenhywfar/pkg-plist b/devel/gwenhywfar/pkg-plist
index 66d4a3367754..84db1c87f7a6 100644
--- a/devel/gwenhywfar/pkg-plist
+++ b/devel/gwenhywfar/pkg-plist
@@ -41,6 +41,7 @@ include/gwenhywfar4/gwenhywfar/debug.h
include/gwenhywfar4/gwenhywfar/dialog.h
include/gwenhywfar4/gwenhywfar/dialog_be.h
include/gwenhywfar4/gwenhywfar/directory.h
+include/gwenhywfar4/gwenhywfar/endianfns.h
include/gwenhywfar4/gwenhywfar/error.h
include/gwenhywfar4/gwenhywfar/fastbuffer.h
include/gwenhywfar4/gwenhywfar/fslock.h
@@ -150,7 +151,7 @@ lib/libgwengui-cpp.so.0
lib/libgwengui-cpp.so.0.0.0
lib/libgwenhywfar.so
lib/libgwenhywfar.so.%%GWEN_SHLIB_VER%%
-lib/libgwenhywfar.so.%%GWEN_SHLIB_VER%%.15.3
+lib/libgwenhywfar.so.%%GWEN_SHLIB_VER%%.18.0
libdata/pkgconfig/gwenhywfar.pc
share/aclocal/gwenhywfar.m4
%%DATADIR%%/ca-bundle.crt