aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2007-04-06 16:23:48 +0800
committerlbr <lbr@FreeBSD.org>2007-04-06 16:23:48 +0800
commit2f5cb28f6e7e96166471ff0713375559da6ec684 (patch)
treea7de5092a9f0f012fd72594ef7b1795647b2c3ab
parenta0a9d2315f049c6627a027c3fa7be04b9fd51375 (diff)
downloadfreebsd-ports-gnome-2f5cb28f6e7e96166471ff0713375559da6ec684.tar.gz
freebsd-ports-gnome-2f5cb28f6e7e96166471ff0713375559da6ec684.tar.zst
freebsd-ports-gnome-2f5cb28f6e7e96166471ff0713375559da6ec684.zip
New port: www/p5-Catalyst-Plugin-ConfigLoader-Environment, Configure your application with environment variables
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile29
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader-Environment/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-descr5
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-plist9
5 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0842cc0264be..2cb7d7cfd4d6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -595,6 +595,7 @@
SUBDIR += p5-Catalyst-Plugin-Cache-Memcached
SUBDIR += p5-Catalyst-Plugin-Cache-Store-FastMmap
SUBDIR += p5-Catalyst-Plugin-ConfigLoader
+ SUBDIR += p5-Catalyst-Plugin-ConfigLoader-Environment
SUBDIR += p5-Catalyst-Plugin-DefaultEnd
SUBDIR += p5-Catalyst-Plugin-FillInForm
SUBDIR += p5-Catalyst-Plugin-FormBuilder
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile
new file mode 100644
index 000000000000..785d7ca3d0f3
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-ConfigLoader-Environment
+# Date created: Apr 6, 2007
+# Whom: lbr@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-ConfigLoader-Environment
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Configure your application with environment variables
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::ConfigLoader::Environment.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader-Environment/distinfo b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/distinfo
new file mode 100644
index 000000000000..060df60410a3
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-ConfigLoader-Environment-0.01.tar.gz) = 1a1d876a6bd751b46622634f8d63934c
+SHA256 (Catalyst-Plugin-ConfigLoader-Environment-0.01.tar.gz) = 919dc056e1058967067e1bf7f1597e6cf48f7c281a6854b8e6636dc6e97cbeb1
+SIZE (Catalyst-Plugin-ConfigLoader-Environment-0.01.tar.gz) = 25593
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-descr b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-descr
new file mode 100644
index 000000000000..8a28bd69217a
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-descr
@@ -0,0 +1,5 @@
+Catalyst::Plugin::ConfigLoader::Environment reads environment
+variables and sets up the configuration in your application
+accordingly.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-ConfigLoader-Environment/
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-plist b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-plist
new file mode 100644
index 000000000000..bc3f26abbb19
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader/Environment.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/ConfigLoader/Environment/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/ConfigLoader/Environment
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/ConfigLoader
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/ConfigLoader
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst