aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-30 21:45:14 +0800
committermiwi <miwi@FreeBSD.org>2007-10-30 21:45:14 +0800
commit3180027523e08d049d2daa29046b9996a35a6685 (patch)
tree7e2ec9da85a8f433699002e374e68197f8322326
parentc6031f0e329cd2bcafebac07efc9b107fb1e7c54 (diff)
downloadfreebsd-ports-gnome-3180027523e08d049d2daa29046b9996a35a6685.tar.gz
freebsd-ports-gnome-3180027523e08d049d2daa29046b9996a35a6685.tar.zst
freebsd-ports-gnome-3180027523e08d049d2daa29046b9996a35a6685.zip
- Fix build on amd64/gcc42
PR: 117651 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer) Approved by: portmgr (pav)
-rw-r--r--games/ivan/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/games/ivan/Makefile b/games/ivan/Makefile
index de2e5a36549b..466cc4e6721a 100644
--- a/games/ivan/Makefile
+++ b/games/ivan/Makefile
@@ -9,8 +9,7 @@ PORTNAME= ivan
PORTVERSION= 0.50
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ivan
+MASTER_SITES= SF
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= A graphical roguelike game
@@ -30,6 +29,12 @@ post-patch:
${WRKSRC}/FeLib/Include/fearray.h
@${REINPLACE_CMD} -Ee 's|([a-z]+<[a-z ,]+>::~?[a-z]+)<[a-z ,]+>|\1|' \
${WRKSRC}/Main/Source/script.cpp
+ @${REINPLACE_CMD} -e 's|truth(|bool(|' ${WRKSRC}/Main/Source/fluid.cpp \
+ ${WRKSRC}/Main/Include/char.h ${WRKSRC}/Main/Include/lsquare.h \
+ ${WRKSRC}/FeLib/Include/save.h ${WRKSRC}/Main/Include/lsquare.h \
+ ${WRKSRC}/Main/Include/human.h ${WRKSRC}/Main/Source/command.cpp \
+ ${WRKSRC}/Main/Include/stack.h ${WRKSRC}/Main/Source/lsquare.cpp \
+ ${WRKSRC}/Main/Source/lterras.cpp
post-install:
${CHGRP} games ${PREFIX}/bin/ivan
@@ -42,12 +47,4 @@ post-install:
${CHMOD} -R g+w ${STATEDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>