aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-18 22:55:59 +0800
committermakc <makc@FreeBSD.org>2013-11-18 22:55:59 +0800
commit32ce20b82e39bfd18c63426156591df7e61494c8 (patch)
treee640ebb2686136e9c2316151865bafb3025258d2
parent65d1bd3f450a5c3e102f3d943200a42a767769d8 (diff)
downloadfreebsd-ports-gnome-32ce20b82e39bfd18c63426156591df7e61494c8.tar.gz
freebsd-ports-gnome-32ce20b82e39bfd18c63426156591df7e61494c8.tar.zst
freebsd-ports-gnome-32ce20b82e39bfd18c63426156591df7e61494c8.zip
- Update to 3.6
- Add options to build with aalib support - Use option helpers - Remove stale patch
-rw-r--r--graphics/xaos/Makefile68
-rw-r--r--graphics/xaos/distinfo4
-rw-r--r--graphics/xaos/files/patch-png.c20
-rw-r--r--graphics/xaos/pkg-plist4
4 files changed, 41 insertions, 55 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 3090c3015633..0e532eb7af5c 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -2,62 +2,64 @@
# $FreeBSD$
PORTNAME= xaos
-PORTVERSION= 3.5
-PORTREVISION= 4
+PORTVERSION= 3.6
CATEGORIES= graphics math
MASTER_SITES= SF/${PORTNAME}/XaoS/${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Real-time fractal browser
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libgsl.so:${PORTSDIR}/math/gsl
USES= gmake
-USE_XORG= x11 xext
GNU_CONFIGURE= yes
-OPTIONS_DEFINE= GTK2 PTHREAD NLS
+OPTIONS_DEFINE= PTHREAD NLS
+OPTIONS_MULTI= DRIVER
+OPTIONS_MULTI_DRIVER= AALIB GTK2 X11
+DRIVER_DESC= User Interface
+OPTIONS_DEFAULT= X11
+OPTIONS_SUB= yes
+
+AALIB_LIB_DEPENDS= libaa.so:${PORTSDIR}/graphics/aalib
+AALIB_CONFIGURE_WITH= aa-driver
+AALIB_CONFIGURE_ON= ac_cv_aalib_ver_ok=yes
+
GTK2_DESC= GTK+ User Interface (experimental)
+GTK2_USE= GNOME=gtk20
+GTK2_USES= pkgconfig
+GTK2_CONFIGURE_WITH= gtk-driver
+
+X11_USE= XORG=x11,xext
+X11_CONFIGURE_WITH= x11-driver x
+
+NLS_USES= gettext iconv
+NLS_CONFIGURE_ENABLE= nls
+
PTHREAD_DESC= Enable SMP support (experimental)
+PTHREAD_CONFIGURE_WITH= pthread
+PTHREAD_CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-aa-driver=no --with-dga-driver=no \
- --with-ggi-driver=no --with-svga-driver=no \
- --with-sffe=no
INFO= xaos
PLIST_SUB+= XAOSDIR="share/XaoS"
-DESKTOP_ENTRIES= "XaoS" "${COMMENT}" "" "xaos" "" false
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPTHREAD}
-CONFIGURE_ARGS+= --with-pthread=yes
-CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
-CFLAGS+= ${PTHREAD_CFLAGS}
-.else
-CONFIGURE_ARGS+= --with-pthread=no
-.endif
-
-.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME= gtk20
-CONFIGURE_ARGS+= --with-gtk-driver=yes --with-x11-driver=no
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+DESKTOP_ENTRIES= "XaoS" "" "${PREFIX}/share/pixmaps/xaos.png" \
+ "xaos" "" false
pre-configure:
${REINPLACE_CMD} -e 's,/usr\(/share/locale\),${PREFIX}\1,g' \
${WRKSRC}/configure \
${WRKSRC}/src/ui/ui.c
+ ${REINPLACE_CMD} 's,malloc.h,stdlib.h,' \
+ ${WRKSRC}/src/ui/ui-drv/aa/ui_aa.c
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/ui/ui-drv/qt/images/xaosbig.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/xaos.png
.include <bsd.port.mk>
diff --git a/graphics/xaos/distinfo b/graphics/xaos/distinfo
index 708d8919727a..d5c6a3fb0711 100644
--- a/graphics/xaos/distinfo
+++ b/graphics/xaos/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xaos-3.5.tar.gz) = 471fa752154a8e4c4687797fe1241df1b3f82400b2ef4e6a603969a27cd74842
-SIZE (xaos-3.5.tar.gz) = 2930590
+SHA256 (xaos-3.6.tar.gz) = 989f3e38f7793810cbb1496d5291d44836a7d7c058422b9ee1cffb163a0b8d95
+SIZE (xaos-3.6.tar.gz) = 2040707
diff --git a/graphics/xaos/files/patch-png.c b/graphics/xaos/files/patch-png.c
deleted file mode 100644
index 17ec32ea93ab..000000000000
--- a/graphics/xaos/files/patch-png.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/util/png.c.orig 2009-07-18 01:50:39.000000000 +0200
-+++ src/util/png.c 2012-05-05 08:36:16.000000000 +0200
-@@ -3,6 +3,8 @@
- #include <aconfig.h>
- #ifdef USE_PNG
- #include <png.h>
-+#include <zlib.h>
-+#include <pngpriv.h>
- #endif
- #include <stdlib.h>
- #include <stdio.h>
-@@ -59,7 +61,7 @@
- png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
- return "No memory to create png info structure";
- }
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_write_struct(&png_ptr, &info_ptr);
- fclose(file);
- return strerror(errno);
diff --git a/graphics/xaos/pkg-plist b/graphics/xaos/pkg-plist
index 71fb9f2c884c..a397a5afa09e 100644
--- a/graphics/xaos/pkg-plist
+++ b/graphics/xaos/pkg-plist
@@ -47,6 +47,7 @@ man/man6/xaos.6.gz
%%XAOSDIR%%/examples/bolygo.xpf
%%XAOSDIR%%/examples/brown.xpf
%%XAOSDIR%%/examples/burnship.xpf
+%%XAOSDIR%%/examples/butterfly-langston.xpf
%%XAOSDIR%%/examples/butterfly.xpf
%%XAOSDIR%%/examples/checker.xpf
%%XAOSDIR%%/examples/circle.xpf
@@ -55,6 +56,7 @@ man/man6/xaos.6.gz
%%XAOSDIR%%/examples/csiga3.xpf
%%XAOSDIR%%/examples/csiga4.xpf
%%XAOSDIR%%/examples/csiga5.xpf
+%%XAOSDIR%%/examples/dark.xpf
%%XAOSDIR%%/examples/dblspira.xpf
%%XAOSDIR%%/examples/dragons.xpf
%%XAOSDIR%%/examples/dragons2.xpf
@@ -112,6 +114,7 @@ man/man6/xaos.6.gz
%%XAOSDIR%%/examples/kovzsi9.2.xpf
%%XAOSDIR%%/examples/kovzsi9.xpf
%%XAOSDIR%%/examples/lemon.xpf
+%%XAOSDIR%%/examples/light-kovzsi.xpf
%%XAOSDIR%%/examples/light.xpf
%%XAOSDIR%%/examples/lighting.xpf
%%XAOSDIR%%/examples/magnet.xpf
@@ -248,6 +251,7 @@ man/man6/xaos.6.gz
%%NLS%%share/locale/it/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/pt/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/ro/LC_MESSAGES/xaos.mo
+share/pixmaps/xaos.png
@dirrm %%XAOSDIR%%/tutorial
@dirrm %%XAOSDIR%%/help
@dirrm %%XAOSDIR%%/examples