aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-08-07 04:44:55 +0800
committerpawel <pawel@FreeBSD.org>2014-08-07 04:44:55 +0800
commit37da7f4cd6e74a794e421863162763eb62d55135 (patch)
tree77cbd0da594324c75b849a7388257ddc5e07be40
parent7b03ef4c9635b6224b049877baae5ab6815a0250 (diff)
downloadfreebsd-ports-gnome-37da7f4cd6e74a794e421863162763eb62d55135.tar.gz
freebsd-ports-gnome-37da7f4cd6e74a794e421863162763eb62d55135.tar.zst
freebsd-ports-gnome-37da7f4cd6e74a794e421863162763eb62d55135.zip
- Fix build with clang (hardcoded linking with libstdc++)
- Respect CXXFLAGS during build - Add staging support - Convert to USES=libtool, new options framework MFH: 2014Q3
-rw-r--r--textproc/yamcha/Makefile21
-rw-r--r--textproc/yamcha/files/patch-configure22
-rw-r--r--textproc/yamcha/pkg-plist23
3 files changed, 40 insertions, 26 deletions
diff --git a/textproc/yamcha/Makefile b/textproc/yamcha/Makefile
index dbdea6a8bbd5..d67a17a784a1 100644
--- a/textproc/yamcha/Makefile
+++ b/textproc/yamcha/Makefile
@@ -3,6 +3,7 @@
PORTNAME= yamcha
PORTVERSION= 0.33
+PORTREVISION= 1
CATEGORIES= textproc science
MASTER_SITES= http://chasen.org/~taku/software/yamcha/src/
@@ -11,28 +12,18 @@ COMMENT= Yet Another Multipurpose CHunk Annotator
BUILD_DEPENDS= svm_learn:${PORTSDIR}/science/svmlight
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= perl5
+USES= libtool perl5
USE_PERL5= build
-NO_STAGE= yes
-DOC_FILES= feature.png feature2.png feature3.png \
+PORTDOCS= feature.png feature2.png feature3.png \
feature4.png feature5.png index.html \
yamcha.html yamcha.css
-MAN1= yamcha.1
+OPTIONS_DEFINE= DOCS
-.if !defined(NOPORTDOCS)
post-install:
- @${MKDIR} ${DOCSDIR}
-.for doc in ${DOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${DOCSDIR}
-.endfor
- @${FIND} -s ${DOCSDIR} -type f | \
- ${SED} -e 's|^${PREFIX}/||' >> ${TMPPLIST}
- @${FIND} -s ${DOCSDIR} -type d | \
- ${SED} -e 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/textproc/yamcha/files/patch-configure b/textproc/yamcha/files/patch-configure
new file mode 100644
index 000000000000..48c9629d919b
--- /dev/null
+++ b/textproc/yamcha/files/patch-configure
@@ -0,0 +1,22 @@
+--- ./configure.orig 2014-08-06 17:30:04.739555036 +0200
++++ ./configure 2014-08-06 17:30:38.008555705 +0200
+@@ -20228,7 +20228,7 @@
+ echo "$as_me:$LINENO: result: $ac_cv_lib_stdcpp_main" >&5
+ echo "${ECHO_T}$ac_cv_lib_stdcpp_main" >&6
+ if test $ac_cv_lib_stdcpp_main = yes; then
+- STDCPP_LIBS="-lstdc++"
++ STDCPP_LIBS=""
+ fi
+
+ ac_ext=cc
+@@ -20257,10 +20257,6 @@
+ fi
+ fi
+
+-if test -n "$GCC"; then
+- CFLAGS="-O3 -Wno-deprecated -Wall"
+- CXXFLAGS="-O3 -Wno-deprecated -Wall"
+-fi
+
+
+
diff --git a/textproc/yamcha/pkg-plist b/textproc/yamcha/pkg-plist
index c0a0170a5db4..e41f66cd765d 100644
--- a/textproc/yamcha/pkg-plist
+++ b/textproc/yamcha/pkg-plist
@@ -2,21 +2,22 @@ bin/yamcha
bin/yamcha-config
bin/yamcha-mkmodel
include/yamcha.h
-lib/libyamcha.so.3
-lib/libyamcha.so
-lib/libyamcha.la
lib/libyamcha.a
+lib/libyamcha.so
+lib/libyamcha.so.1
+lib/libyamcha.so.1.2.0
+libexec/yamcha/Makefile
+libexec/yamcha/PKE.pm
+libexec/yamcha/PKI.pm
libexec/yamcha/mkdarts
-libexec/yamcha/mktrie
-libexec/yamcha/pkemine
libexec/yamcha/mkmodel
-libexec/yamcha/mksvmdata
-libexec/yamcha/svm_learn_wrapper
libexec/yamcha/mkparam
+libexec/yamcha/mksvmdata
+libexec/yamcha/mktrie
+libexec/yamcha/pkemine
+libexec/yamcha/selecttag
libexec/yamcha/showse
+libexec/yamcha/svm_learn_wrapper
libexec/yamcha/zipmodel
-libexec/yamcha/selecttag
-libexec/yamcha/PKI.pm
-libexec/yamcha/PKE.pm
-libexec/yamcha/Makefile
+man/man1/yamcha.1.gz
@dirrm libexec/yamcha