aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-03-21 05:22:11 +0800
committerpawel <pawel@FreeBSD.org>2013-03-21 05:22:11 +0800
commit382f48b6f6b45d2ef906c62b332837b496800344 (patch)
treecff25c6f8fdeed5e96e44f715fc24af32af6815b
parentd4a376879824f1f77591d97c33d918fe32bbb926 (diff)
downloadfreebsd-ports-gnome-382f48b6f6b45d2ef906c62b332837b496800344.tar.gz
freebsd-ports-gnome-382f48b6f6b45d2ef906c62b332837b496800344.tar.zst
freebsd-ports-gnome-382f48b6f6b45d2ef906c62b332837b496800344.zip
Library and tools to access the Personal Folder File (PFF) and the Offline
Folder File (OFF) formats. PFF/OFF is used in several file types: PAB (Personal Address Book) PST (Personal Storage Table) OST (Offline Storage Table) WWW: http://code.google.com/p/libpff/ PR: ports/177116 Submitted by: Antoine Brodin <antoine@FreeBSD.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libpff/Makefile46
-rw-r--r--devel/libpff/distinfo2
-rw-r--r--devel/libpff/pkg-descr8
-rw-r--r--devel/libpff/pkg-plist19
5 files changed, 76 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 85be8630a4f7..7142524c19f1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1054,6 +1054,7 @@
SUBDIR += libpciaccess
SUBDIR += libpdel
SUBDIR += libpeak
+ SUBDIR += libpff
SUBDIR += libphish
SUBDIR += libphk
SUBDIR += libplist
diff --git a/devel/libpff/Makefile b/devel/libpff/Makefile
new file mode 100644
index 000000000000..09ba4aefcf4c
--- /dev/null
+++ b/devel/libpff/Makefile
@@ -0,0 +1,46 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libpff
+DISTVERSION= alpha-20120802
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Library and tools to access the PFF and the OFF formats
+
+LICENSE= LGPL3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python
+USE_GETTEXT= yes
+USES= pathfix
+USE_ICONV= yes
+USE_PYTHON= yes
+USE_LDCONFIG= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+
+MAN1= pffexport.1 pffinfo.1
+MAN3= libpff.3
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+PORTDOCS= AUTHORS ChangeLog
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${PORTNAME}/* \
+ ${WRKSRC}/examples/${PORTNAME:S,lib,py,}/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libpff/distinfo b/devel/libpff/distinfo
new file mode 100644
index 000000000000..77dd3d8a45fe
--- /dev/null
+++ b/devel/libpff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libpff-alpha-20120802.tar.gz) = 4b78464200d04c77e182e09dc2af8d6f6c5519af12994e1ce96cd3b0e7a2ea62
+SIZE (libpff-alpha-20120802.tar.gz) = 1665471
diff --git a/devel/libpff/pkg-descr b/devel/libpff/pkg-descr
new file mode 100644
index 000000000000..3f95f5cc8db4
--- /dev/null
+++ b/devel/libpff/pkg-descr
@@ -0,0 +1,8 @@
+Library and tools to access the Personal Folder File (PFF) and the Offline
+Folder File (OFF) formats.
+PFF/OFF is used in several file types:
+ PAB (Personal Address Book)
+ PST (Personal Storage Table)
+ OST (Offline Storage Table)
+
+WWW: http://code.google.com/p/libpff/
diff --git a/devel/libpff/pkg-plist b/devel/libpff/pkg-plist
new file mode 100644
index 000000000000..a87dc593f194
--- /dev/null
+++ b/devel/libpff/pkg-plist
@@ -0,0 +1,19 @@
+bin/pffexport
+bin/pffinfo
+include/libpff.h
+include/libpff/codepage.h
+include/libpff/definitions.h
+include/libpff/error.h
+include/libpff/extern.h
+include/libpff/features.h
+include/libpff/mapi.h
+include/libpff/types.h
+lib/libpff.a
+lib/libpff.la
+lib/libpff.so
+lib/libpff.so.1
+%%PYTHON_SITELIBDIR%%/pypff.a
+%%PYTHON_SITELIBDIR%%/pypff.la
+%%PYTHON_SITELIBDIR%%/pypff.so
+libdata/pkgconfig/libpff.pc
+@dirrm include/libpff