aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-05-02 16:30:09 +0800
committermiwi <miwi@FreeBSD.org>2010-05-02 16:30:09 +0800
commit382fdb9527a81e8444d5d24fb9f9b81db4876079 (patch)
treea7dac4d5ac2e69587d955df76f8b23f9df9f3b44
parentee8b7b775940ad9d9ea373687422abee966ee01f (diff)
downloadfreebsd-ports-gnome-382fdb9527a81e8444d5d24fb9f9b81db4876079.tar.gz
freebsd-ports-gnome-382fdb9527a81e8444d5d24fb9f9b81db4876079.tar.zst
freebsd-ports-gnome-382fdb9527a81e8444d5d24fb9f9b81db4876079.zip
Drush is a command line shell and Unix scripting interface for the Drupal CMS
and is designed to make life easier for those who spend some of their working hours hacking away at the command prompt. WWW: http://drupal.org/project/drush PR: ports/146185 Submitted by: Thomas Sandford <freebsduser at paradisegreen.co.uk>
-rw-r--r--www/Makefile1
-rw-r--r--www/drush/Makefile36
-rw-r--r--www/drush/distinfo3
-rw-r--r--www/drush/files/patch-drush57
-rw-r--r--www/drush/pkg-descr5
-rw-r--r--www/drush/pkg-plist59
6 files changed, 161 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f4542f09656a..68f637f6e390 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -190,6 +190,7 @@
SUBDIR += drupal6-webform
SUBDIR += drupal6-wysiwyg
SUBDIR += drupal6-zeropoint
+ SUBDIR += drush
SUBDIR += dtse
SUBDIR += dummyflash
SUBDIR += e107
diff --git a/www/drush/Makefile b/www/drush/Makefile
new file mode 100644
index 000000000000..d306aa8c0411
--- /dev/null
+++ b/www/drush/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: www/drush
+# Date created: April 29th 2010
+# Whom: Thomas Sandford <freebsduser@paradisegreen.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drush
+PORTVERSION= 3.0
+CATEGORIES= www
+MASTER_SITES= http://ftp.drupal.org/files/projects/
+DISTNAME= drush-All-versions-${PORTVERSION}
+
+MAINTAINER= freebsduser@paradisegreen.co.uk
+COMMENT= Drupal command line and scripting interface
+
+NO_BUILD= yes
+
+# set php requirements same as drupal itself
+USE_PHP= gd pcre session xml mbstring
+IGNORE_WITH_PHP=4
+WANT_PHP_WEB= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ @${REINPLACE_CMD} -e 's|XXXDATADIRXXX|${DATADIR}|g' ${WRKSRC}/drush
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR} '! ( -name drush -or -name drush.bat -or -name *.orig -or -name *.bak )' )
+ ${INSTALL_SCRIPT} ${WRKSRC}/drush ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/www/drush/distinfo b/www/drush/distinfo
new file mode 100644
index 000000000000..f5e9b7e53a5d
--- /dev/null
+++ b/www/drush/distinfo
@@ -0,0 +1,3 @@
+MD5 (drush-All-versions-3.0.tar.gz) = 86bb79b783290930c12b66038ef8d742
+SHA256 (drush-All-versions-3.0.tar.gz) = 2112ab5a9b6c9ad9947c85f99a1a56dd1db40d4bb69d0cf962b84e6bd95c4207
+SIZE (drush-All-versions-3.0.tar.gz) = 171892
diff --git a/www/drush/files/patch-drush b/www/drush/files/patch-drush
new file mode 100644
index 000000000000..fcea332580c0
--- /dev/null
+++ b/www/drush/files/patch-drush
@@ -0,0 +1,57 @@
+--- drush.orig 2010-04-29 21:25:16.000000000 +0100
++++ drush 2010-04-29 21:32:18.000000000 +0100
+@@ -1,51 +1,16 @@
+-#!/usr/bin/env sh
++#!/bin/sh
+ # $Id: drush,v 1.17 2010/04/14 22:29:33 weitzman Exp $
+ #
+ # This script is a simple wrapper that will run Drush with the most appropriate
+ # php executable it can find.
+ #
+
+-# Get the absolute path of this executable
+-ORIGDIR=$(pwd)
+-SELF_PATH=$(cd -P -- "$(dirname -- "$0")" && pwd -P) && SELF_PATH=$SELF_PATH/$(basename -- "$0")
+-
+-# Resolve symlinks - this is the equivalent of "readlink -f", but also works with non-standard OS X readlink.
+-while [ -h $SELF_PATH ]; do
+- # 1) cd to directory of the symlink
+- # 2) cd to the directory of where the symlink points
+- # 3) Get the pwd
+- # 4) Append the basename
+- DIR=$(dirname -- "$SELF_PATH")
+- SYM=$(readlink $SELF_PATH)
+- SELF_PATH=$(cd $DIR && cd $(dirname -- "$SYM") && pwd)/$(basename -- "$SYM")
+-done
+-cd "$ORIGDIR"
+-
+ # Build the path to drush.php.
+-SCRIPT_PATH=$(dirname $SELF_PATH)/drush.php
+-case $(uname -a) in
+- CYGWIN*)
+- SCRIPT_PATH=$(cygpath -w -a -- "$SCRIPT_PATH") ;;
+-esac
++SCRIPT_PATH=XXXDATADIRXXX/drush.php
+
+ # If not exported and term is set determine and export the number of columns.
+ if [ -z $COLUMNS ] && [ -n "$TERM" ]; then
+ export COLUMNS=$(tput cols)
+ fi
+
+-# Special case for *AMP installers, since they normally don't set themselves as the default cli php out of the box.
+-for php in /Applications/MAMP/bin/php5/bin/php /opt/lampp/bin/php /Applications/xampp/xamppfiles/bin/php /Applications/acquia-drupal/php/bin/php; do
+- if [ -x $php ]; then
+- exec $php $SCRIPT_PATH --php="$php" "$@"
+- fi
+-done
+-
+-# We check for a command line (cli) version of php, and if found use that.
+-which php-cli >/dev/null 2>&1
+-if [ "$?" = 0 ] ; then
+- exec php-cli $SCRIPT_PATH --php="php-cli" "$@"
+-else
+- # Alternatively we run with straight php, which works on most other systems.
+- # The --php=`which php` is for Dreamhost, which behaves oddly. See http://drupal.org/node/662926
+- exec php $SCRIPT_PATH --php=`which php` "$@"
+-fi
++exec php $SCRIPT_PATH --php=`which php` "$@"
diff --git a/www/drush/pkg-descr b/www/drush/pkg-descr
new file mode 100644
index 000000000000..7c4186f587cd
--- /dev/null
+++ b/www/drush/pkg-descr
@@ -0,0 +1,5 @@
+Drush is a command line shell and Unix scripting interface for the Drupal CMS
+and is designed to make life easier for those who spend some of their working
+hours hacking away at the command prompt.
+
+WWW: http://drupal.org/project/drush
diff --git a/www/drush/pkg-plist b/www/drush/pkg-plist
new file mode 100644
index 000000000000..077edc44bebb
--- /dev/null
+++ b/www/drush/pkg-plist
@@ -0,0 +1,59 @@
+bin/drush
+%%DATADIR%%/LICENSE.txt
+%%DATADIR%%/README.txt
+%%DATADIR%%/commands/core/drupal/batch_6.inc
+%%DATADIR%%/commands/core/drupal/batch_7.inc
+%%DATADIR%%/commands/core/drupal/environment_5.inc
+%%DATADIR%%/commands/core/drupal/environment_6.inc
+%%DATADIR%%/commands/core/drupal/environment_7.inc
+%%DATADIR%%/commands/core/drupal/update_5.inc
+%%DATADIR%%/commands/core/drupal/update_6.inc
+%%DATADIR%%/commands/core/drupal/update_7.inc
+%%DATADIR%%/commands/core/clear.cache.inc
+%%DATADIR%%/commands/core/core.drush.inc
+%%DATADIR%%/commands/core/rsync.core.inc
+%%DATADIR%%/commands/core/scratch.php
+%%DATADIR%%/commands/core/search.drush.inc
+%%DATADIR%%/commands/core/site_install.drush.inc
+%%DATADIR%%/commands/core/sitealias.drush.inc
+%%DATADIR%%/commands/core/upgrade.drush.inc
+%%DATADIR%%/commands/core/variable.drush.inc
+%%DATADIR%%/commands/core/watchdog.drush.inc
+%%DATADIR%%/commands/pm/package_handler/wget.inc
+%%DATADIR%%/commands/pm/package_handler/cvs.inc
+%%DATADIR%%/commands/pm/pm.drush.inc
+%%DATADIR%%/commands/pm/updatecode.pm.inc
+%%DATADIR%%/commands/pm/update_info/drupal_5.inc
+%%DATADIR%%/commands/pm/update_info/drupal_6.inc
+%%DATADIR%%/commands/pm/update_info/drupal_7.inc
+%%DATADIR%%/commands/pm/version_control/backup.inc
+%%DATADIR%%/commands/pm/version_control/bzr.inc
+%%DATADIR%%/commands/pm/version_control/svn.inc
+%%DATADIR%%/commands/sql/sql.drush.inc
+%%DATADIR%%/commands/sql/sync.sql.inc
+%%DATADIR%%/drush.api.php
+%%DATADIR%%/drush.info
+%%DATADIR%%/drush.php
+%%DATADIR%%/drush_logo-black.png
+%%DATADIR%%/examples/example.aliases.drushrc.php
+%%DATADIR%%/examples/example.drushrc.php
+%%DATADIR%%/examples/sandwich.drush.inc
+%%DATADIR%%/examples/sandwich.txt
+%%DATADIR%%/includes/backend.inc
+%%DATADIR%%/includes/batch.inc
+%%DATADIR%%/includes/command.inc
+%%DATADIR%%/includes/context.inc
+%%DATADIR%%/includes/drush.inc
+%%DATADIR%%/includes/environment.inc
+%%DATADIR%%/includes/sitealias.inc
+@dirrmtry %%DATADIR%%/includes
+@dirrmtry %%DATADIR%%/examples
+@dirrmtry %%DATADIR%%/commands/sql
+@dirrmtry %%DATADIR%%/commands/pm/version_control
+@dirrmtry %%DATADIR%%/commands/pm/update_info
+@dirrmtry %%DATADIR%%/commands/pm/package_handler
+@dirrmtry %%DATADIR%%/commands/pm
+@dirrmtry %%DATADIR%%/commands/core/drupal
+@dirrmtry %%DATADIR%%/commands/core
+@dirrmtry %%DATADIR%%/commands
+@dirrmtry %%DATADIR%%