aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-02-07 23:11:37 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-02-07 23:11:37 +0800
commit3b3a01c2afe70a42c82d5b81c38c47260c77a85b (patch)
treef7826f97455ba6906d36bf3613b3efed770fb68d
parentb25d8f32b0b1949656269eb24f7e53047fdc1ee0 (diff)
downloadfreebsd-ports-gnome-3b3a01c2afe70a42c82d5b81c38c47260c77a85b.tar.gz
freebsd-ports-gnome-3b3a01c2afe70a42c82d5b81c38c47260c77a85b.tar.zst
freebsd-ports-gnome-3b3a01c2afe70a42c82d5b81c38c47260c77a85b.zip
- Add LICENSE
- Fix *_DEPENDS: Test::Deep is a test dependency - Bump PORTREVISION for dependency change - Cleanup Makefile header - Update pkg-descr
-rw-r--r--textproc/p5-Pod-Eventual/Makefile18
-rw-r--r--textproc/p5-Pod-Eventual/pkg-descr14
-rw-r--r--textproc/p5-Pod-Eventual/pkg-plist4
3 files changed, 24 insertions, 12 deletions
diff --git a/textproc/p5-Pod-Eventual/Makefile b/textproc/p5-Pod-Eventual/Makefile
index 727ff8ba1842..eb4197dfc840 100644
--- a/textproc/p5-Pod-Eventual/Makefile
+++ b/textproc/p5-Pod-Eventual/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Pod-Eventual
-# Date created: 27 December 2009
-# Whom: Andrey Kostenko <andrey@kostenko.name>
-#
+# Created by: Andrey Kostenko <andrey@kostenko.name>
# $FreeBSD$
-#
PORTNAME= Pod-Eventual
PORTVERSION= 0.093330
@@ -14,12 +10,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Read a POD document as a series of trivial events
-BUILD_DEPENDS= p5-Mixin-Linewise>=0.001:${PORTSDIR}/devel/p5-Mixin-Linewise \
- p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Mixin-Linewise>=0.001:${PORTSDIR}/devel/p5-Mixin-Linewise
RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_CONFIGURE= yes
-PERL_CONFIGURE= YES
-MAN3= Pod::Eventual.3\
+MAN3= Pod::Eventual.3 \
Pod::Eventual::Simple.3
.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Eventual/pkg-descr b/textproc/p5-Pod-Eventual/pkg-descr
index 20d872c35d5a..aef6013ec90a 100644
--- a/textproc/p5-Pod-Eventual/pkg-descr
+++ b/textproc/p5-Pod-Eventual/pkg-descr
@@ -1,3 +1,15 @@
-read a POD document as a series of trivial events
+POD is a pretty simple format to write, but it can be a big pain to deal with
+reading it and doing anything useful with it. Most existing POD parsers care
+about semantics, like whether a =item occurred after an =over but before a back,
+figuring out how to link a L<>, and other things like that.
+
+Pod::Eventual is much less ambitious and much more stupid. Fortunately, stupid
+is often better. (That's what I keep telling myself, anyway.)
+
+Pod::Eventual reads line-based input and produces events describing each POD
+paragraph or directive it finds. Once complete events are immediately passed to
+the handle_event method. This method should be implemented by Pod::Eventual
+subclasses. If it isn't, Pod::Eventual's own handle_event will be called, and
+will raise an exception.
WWW: http://search.cpan.org/dist/Pod-Eventual/
diff --git a/textproc/p5-Pod-Eventual/pkg-plist b/textproc/p5-Pod-Eventual/pkg-plist
index c5486ebe7730..271c5079cd21 100644
--- a/textproc/p5-Pod-Eventual/pkg-plist
+++ b/textproc/p5-Pod-Eventual/pkg-plist
@@ -1,7 +1,7 @@
%%SITE_PERL%%/Pod/Eventual.pm
%%SITE_PERL%%/Pod/Eventual/Simple.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Eventual/.packlist
-@dirrmtry %%SITE_PERL%%/Pod/Eventual
-@dirrmtry %%SITE_PERL%%/Pod
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Eventual
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod
+@dirrmtry %%SITE_PERL%%/Pod/Eventual
+@dirrmtry %%SITE_PERL%%/Pod