aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-06-24 06:51:07 +0800
committerbapt <bapt@FreeBSD.org>2016-06-24 06:51:07 +0800
commit3e5d85bc12730eb5922d064a937487a9ecda74ab (patch)
treeffbd88e83f0f1b26e324513438d3e91ac8b3749b
parent885879dfa709fbf4c8d2f761515970f323ea5d87 (diff)
downloadfreebsd-ports-gnome-3e5d85bc12730eb5922d064a937487a9ecda74ab.tar.gz
freebsd-ports-gnome-3e5d85bc12730eb5922d064a937487a9ecda74ab.tar.zst
freebsd-ports-gnome-3e5d85bc12730eb5922d064a937487a9ecda74ab.zip
New slibtool:
`slibtool` is an independent reimplementation of the widely used libtool, written in C. `slibtool` is designed to be a clean, fast, easy-to-use libtool drop-in replacement, and is accordingly aimed at package authors, distro developers, and system integrators. `slibtool` maintains compatibility with libtool in nearly every aspect of the tool's functionality as well as semantics, leaving out (or turning into a no-op) only a small number of features that are no longer needed on modern systems. Being a compiled binary, and although not primarily written for the sake of performance, building a package with `slibtool` is often faster than with its script-based counterpart. The resulting performance gain would normally vary between packages, and is most noticeable in builds that invoke libtool a large number of times, and which are characterized by the short compilation duration of individual translation units. WWW: http://git.midipix.org/cgit.cgi/slibtool/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/slibtool/Makefile24
-rw-r--r--devel/slibtool/distinfo3
-rw-r--r--devel/slibtool/pkg-descr16
-rw-r--r--devel/slibtool/pkg-plist9
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fb484c89a6d6..222376296253 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5296,6 +5296,7 @@
SUBDIR += simian
SUBDIR += simple_components
SUBDIR += skalibs
+ SUBDIR += slibtool
SUBDIR += slf4j
SUBDIR += smack
SUBDIR += smake
diff --git a/devel/slibtool/Makefile b/devel/slibtool/Makefile
new file mode 100644
index 000000000000..78594b76fc20
--- /dev/null
+++ b/devel/slibtool/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= slibtool
+PORTVERSION= 0.5.5
+CATEGORIES= devel
+MASTER_SITES= http://dl.midipix.org/${PORTNAME}/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Skinny libtool implementation, written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING.SLIBTOOL
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USES= gmake tar:xz
+
+post-patch:
+ ${REINPLACE_CMD} -e "s/make/${MAKE_CMD}/g" ${WRKSRC}/configure
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/slibtool
+
+.include <bsd.port.mk>
diff --git a/devel/slibtool/distinfo b/devel/slibtool/distinfo
new file mode 100644
index 000000000000..0b1119e298b3
--- /dev/null
+++ b/devel/slibtool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466721259
+SHA256 (slibtool-0.5.5.tar.xz) = 5b43ab54c7d40ec72225e3bacaf03098f77e92d79aa6ef3840b51cfab6be7c8e
+SIZE (slibtool-0.5.5.tar.xz) = 45144
diff --git a/devel/slibtool/pkg-descr b/devel/slibtool/pkg-descr
new file mode 100644
index 000000000000..df45b347b552
--- /dev/null
+++ b/devel/slibtool/pkg-descr
@@ -0,0 +1,16 @@
+`slibtool` is an independent reimplementation of the widely used libtool,
+written in C. `slibtool` is designed to be a clean, fast, easy-to-use
+libtool drop-in replacement, and is accordingly aimed at package authors,
+distro developers, and system integrators. `slibtool` maintains compatibility
+with libtool in nearly every aspect of the tool's functionality as well as
+semantics, leaving out (or turning into a no-op) only a small number of
+features that are no longer needed on modern systems.
+
+Being a compiled binary, and although not primarily written for the sake of
+performance, building a package with `slibtool` is often faster than with its
+script-based counterpart. The resulting performance gain would normally vary
+between packages, and is most noticeable in builds that invoke libtool a large
+number of times, and which are characterized by the short compilation duration
+of individual translation units.
+
+WWW: http://git.midipix.org/cgit.cgi/slibtool/
diff --git a/devel/slibtool/pkg-plist b/devel/slibtool/pkg-plist
new file mode 100644
index 000000000000..3d2fb3829f17
--- /dev/null
+++ b/devel/slibtool/pkg-plist
@@ -0,0 +1,9 @@
+bin/clibtool
+bin/clibtool-shared
+bin/clibtool-static
+bin/dlibtool
+bin/dlibtool-shared
+bin/dlibtool-static
+bin/slibtool
+bin/slibtool-shared
+bin/slibtool-static