aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2003-06-03 03:12:45 +0800
committerache <ache@FreeBSD.org>2003-06-03 03:12:45 +0800
commit415e66b5fc964275a0f13704923d7a7bd8432ef0 (patch)
treed1f8c70732565246c1a68d04f33ac3ec9f683a0b
parentba08dc2e9354c3811bba4e00cbe0574723d09740 (diff)
downloadfreebsd-ports-gnome-415e66b5fc964275a0f13704923d7a7bd8432ef0.tar.gz
freebsd-ports-gnome-415e66b5fc964275a0f13704923d7a7bd8432ef0.tar.zst
freebsd-ports-gnome-415e66b5fc964275a0f13704923d7a7bd8432ef0.zip
Understand '$1$' prefix for crypt() in dbmmanage
PR: 25031
-rw-r--r--www/apache13/Makefile2
-rw-r--r--www/apache13/files/patch-ad11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/apache13/Makefile b/www/apache13/Makefile
index c498bc6dd719..c8349483bd9c 100644
--- a/www/apache13/Makefile
+++ b/www/apache13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache
PORTVERSION= 1.3.27
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= apache_${PORTVERSION}
diff --git a/www/apache13/files/patch-ad b/www/apache13/files/patch-ad
new file mode 100644
index 000000000000..d92d2f447613
--- /dev/null
+++ b/www/apache13/files/patch-ad
@@ -0,0 +1,11 @@
+--- src/support/dbmmanage.bak Thu Mar 14 00:05:37 2002
++++ src/support/dbmmanage Mon Jun 2 23:05:27 2003
+@@ -338,6 +338,8 @@
+ } elsif (substr($chkpass, 0, 5) eq '{SHA}') {
+ need_sha1_crypt;
+ $crypt_method = "sha1";
++ } elsif (substr($chkpass, 0, 3) eq '$1$') {
++ $crypt_method = "crypt";
+ } elsif (length($chkpass) == 13 && $chkpass ne $testpass) {
+ $crypt_method = "crypt";
+ } else {