aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2017-12-04 20:36:55 +0800
committerkrion <krion@FreeBSD.org>2017-12-04 20:36:55 +0800
commit43f0640715d56379de24fb3e137fe286743aeefe (patch)
tree4bb6c0c90e10f82a95b3fda1cd9a3ea6e2faf13c
parent77e6956f813086e3f933460dac2caff93acc3908 (diff)
downloadfreebsd-ports-gnome-43f0640715d56379de24fb3e137fe286743aeefe.tar.gz
freebsd-ports-gnome-43f0640715d56379de24fb3e137fe286743aeefe.tar.zst
freebsd-ports-gnome-43f0640715d56379de24fb3e137fe286743aeefe.zip
Update to 4.0.7
- Drop support for Botan 1.10 in favor of Botan 2.x - Backported bugfixes/improvements from the 4.1.x branch - Pet portlint and use DISTVERSION - Added devel/protobuf as dependency as suggested by upstream PR: 224027 Submitted by: maintainer Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D13338
-rw-r--r--dns/powerdns-recursor/Makefile21
-rw-r--r--dns/powerdns-recursor/distinfo6
-rw-r--r--dns/powerdns-recursor/files/patch-botan110signers.cc15
3 files changed, 14 insertions, 28 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 666bcde067d9..626f62a7279b 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -2,30 +2,31 @@
# $FreeBSD$
PORTNAME= recursor
-PORTVERSION= 4.0.6
-PORTREVISION= 5
+DISTVERSION= 4.0.7
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
PKGNAMEPREFIX= powerdns-
-DISTNAME= pdns-${PORTNAME}-${PORTVERSION}
+DISTNAME= pdns-${PORTNAME}-${DISTVERSION}
MAINTAINER= tremere@cainites.net
COMMENT= Advanced DNS recursor
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-LIB_DEPENDS= libboost_context.so:devel/boost-libs
-
BROKEN_armv6= fails to compile: use of overloaded operator << is ambiguous
BROKEN_armv7= fails to compile: use of overloaded operator << is ambiguous
BROKEN_sparc64= fails to compile: json11.cpp: undefined reference to std::__throw_out_of_range_fmt
BROKEN_powerpc64= fails to compile: dnslabeltext.cc: undefined reference to std::__cxx11::basic_string
-USES= compiler:c++11-lib cpe gmake localbase pkgconfig ssl tar:bzip2
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+LIB_DEPENDS= libboost_context.so:devel/boost-libs \
+ libprotobuf.so:devel/protobuf
+
+USES= compiler:c++11-lib cpe gmake localbase:ldflags pkgconfig ssl tar:bzip2
GNU_CONFIGURE= YES
CXXFLAGS+= -D_GLIBCXX_USE_C99
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/pdns
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/pdns \
+ --with-protobuf
CPE_VENDOR= powerdns
@@ -46,9 +47,9 @@ LUA_USES= lua
LUAJIT_CONFIGURE_WITH= luajit
LUAJIT_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit
-OPTALGO_CONFIGURE_ON= --enable-botan1.10 \
+OPTALGO_CONFIGURE_ON= --enable-botan \
--enable-libsodium
-OPTALGO_LIB_DEPENDS= libbotan-1.10.so:security/botan110 \
+OPTALGO_LIB_DEPENDS= libbotan-2.so:security/botan2 \
libsodium.so:security/libsodium
SETUID_VARS= USERS=pdns_recursor GROUPS=pdns
diff --git a/dns/powerdns-recursor/distinfo b/dns/powerdns-recursor/distinfo
index a86df5f160c9..14535cc9ca5c 100644
--- a/dns/powerdns-recursor/distinfo
+++ b/dns/powerdns-recursor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499338924
-SHA256 (pdns-recursor-4.0.6.tar.bz2) = f2182ac644268bb08b865a71351f11d75c5015ac0608a1469eb4c1cd5494d60d
-SIZE (pdns-recursor-4.0.6.tar.bz2) = 1105423
+TIMESTAMP = 1512117295
+SHA256 (pdns-recursor-4.0.7.tar.bz2) = 966d1654c32c72bd0cc9b301ae5b723a34e36f3c02e62c73a7643260122f94e7
+SIZE (pdns-recursor-4.0.7.tar.bz2) = 1107546
diff --git a/dns/powerdns-recursor/files/patch-botan110signers.cc b/dns/powerdns-recursor/files/patch-botan110signers.cc
deleted file mode 100644
index 52f98472384a..000000000000
--- a/dns/powerdns-recursor/files/patch-botan110signers.cc
+++ /dev/null
@@ -1,15 +0,0 @@
-https://github.com/PowerDNS/pdns/pull/5498/commits/0f8f34997afc2c3609b2f3df72ca808940d2a778#diff-a69f1deeeb9a0d7ebabc200a4c24c9f9L184
---- botan110signers.cc.orig 2017-07-04 15:43:07 UTC
-+++ botan110signers.cc
-@@ -181,8 +181,9 @@ std::string GOSTDNSCryptoKeyEngine::getP
-
- std::string GOSTDNSCryptoKeyEngine::getPublicKeyString() const
- {
-- const BigInt&x =d_key->public_point().get_affine_x();
-- const BigInt&y =d_key->public_point().get_affine_y();
-+ std::shared_ptr<GOST_3410_PublicKey> pk = d_pubkey ? d_pubkey : d_key;
-+ const BigInt&x =pk->public_point().get_affine_x();
-+ const BigInt&y =pk->public_point().get_affine_y();
-
- size_t part_size = std::max(x.bytes(), y.bytes());
-