aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchie <archie@FreeBSD.org>2003-11-11 07:07:07 +0800
committerarchie <archie@FreeBSD.org>2003-11-11 07:07:07 +0800
commit450497ca2b0d39353263f33511ad747735e8c71d (patch)
tree3602ab07d03ab1c80849ed3f9afe9e432b4321c0
parentb849053a6f88074cfe378371908f6ec3f9911e8b (diff)
downloadfreebsd-ports-gnome-450497ca2b0d39353263f33511ad747735e8c71d.tar.gz
freebsd-ports-gnome-450497ca2b0d39353263f33511ad747735e8c71d.tar.zst
freebsd-ports-gnome-450497ca2b0d39353263f33511ad747735e8c71d.zip
Add iconv encoding support.
PR: ports/57725 Submitted by: Palle Girgensohn <girgen@pingpong.net>
-rw-r--r--java/jikes/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
index 770abb8c58be..9b43a0fd9c16 100644
--- a/java/jikes/Makefile
+++ b/java/jikes/Makefile
@@ -7,12 +7,15 @@
PORTNAME= jikes
PORTVERSION= 1.18
+PORTREVISION= 1
CATEGORIES= java
MASTER_SITES= http://oss.software.ibm.com/pub/jikes/${PORTVERSION}/
MAINTAINER= archie@freebsd.org
COMMENT= A very fast Java source to byte-code compiler made available by IBM
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
MAN1= jikes.1
PLIST_SUB= PORTVERSION=${PORTVERSION}
@@ -20,4 +23,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
.include <bsd.port.mk>