aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-11 22:49:35 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-11 22:49:35 +0800
commit45c3095f188449c61a0312537eae9c46b53543b8 (patch)
tree410e5c45dc5176b753d89f5cdb057c92ce7fbe8a
parent5fa24f70bbb735fe9e83738e7dd2844c94dbe325 (diff)
downloadfreebsd-ports-gnome-45c3095f188449c61a0312537eae9c46b53543b8.tar.gz
freebsd-ports-gnome-45c3095f188449c61a0312537eae9c46b53543b8.tar.zst
freebsd-ports-gnome-45c3095f188449c61a0312537eae9c46b53543b8.zip
- Simplify MASTER_SITES
- Add LICENSE - Strip library
-rw-r--r--devel/py-anonfunc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/py-anonfunc/Makefile b/devel/py-anonfunc/Makefile
index f8c8a86d9725..1d51326d1b7d 100644
--- a/devel/py-anonfunc/Makefile
+++ b/devel/py-anonfunc/Makefile
@@ -3,15 +3,17 @@
PORTNAME= anonfunc
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel python
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
+MASTER_SITES= LOCAL/perky \
http://people.freebsd.org/~perky/distfiles/
-MASTER_SITE_SUBDIR= perky
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python module that provides easy anonymous function
+LICENSE= BSD2CLAUSE
+
USES= python
USE_PYTHON= distutils autoplist
@@ -20,4 +22,7 @@ post-patch:
-e 's,distutils\.command\.install ,setuptools\.command\.install ,' \
${WRKSRC}/setup.py
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/anonfunc.so
+
.include <bsd.port.mk>