aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjfitz <jfitz@FreeBSD.org>1996-10-24 16:01:28 +0800
committerjfitz <jfitz@FreeBSD.org>1996-10-24 16:01:28 +0800
commit4d4a8bafa8966f00adff560f517834a60d5b6c90 (patch)
tree2c9a41ff63d52583b1643278c78d8b30dcfb109d
parent85a92871bb5ed8d79de6fb3d4758741b7235e6bd (diff)
downloadfreebsd-ports-gnome-4d4a8bafa8966f00adff560f517834a60d5b6c90.tar.gz
freebsd-ports-gnome-4d4a8bafa8966f00adff560f517834a60d5b6c90.tar.zst
freebsd-ports-gnome-4d4a8bafa8966f00adff560f517834a60d5b6c90.zip
perl5 module for file locking with flock
-rw-r--r--devel/p5-File-BasicFlock/Makefile33
-rw-r--r--devel/p5-File-BasicFlock/distinfo1
-rw-r--r--devel/p5-File-BasicFlock/pkg-comment1
-rw-r--r--devel/p5-File-BasicFlock/pkg-descr6
-rw-r--r--devel/p5-File-BasicFlock/pkg-plist2
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-File-BasicFlock/Makefile b/devel/p5-File-BasicFlock/Makefile
new file mode 100644
index 000000000000..ee996d37341e
--- /dev/null
+++ b/devel/p5-File-BasicFlock/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-File-BasicFlock
+# Version required: 96.072401
+# Date created:
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= File-BasicFLock-96.072401
+PKGNAME= p5-File-BasicFlock-96.072401
+CATEGORIES+= devel
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/File/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/File/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/File/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/File/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/File/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/File/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in File::BasicFlock; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-BasicFlock/distinfo b/devel/p5-File-BasicFlock/distinfo
new file mode 100644
index 000000000000..80084e709a88
--- /dev/null
+++ b/devel/p5-File-BasicFlock/distinfo
@@ -0,0 +1 @@
+MD5 (File-BasicFLock-96.072401.tar.gz) = 6a3722b04f1b5256dcfbbee803715677
diff --git a/devel/p5-File-BasicFlock/pkg-comment b/devel/p5-File-BasicFlock/pkg-comment
new file mode 100644
index 000000000000..5f59459a8fb4
--- /dev/null
+++ b/devel/p5-File-BasicFlock/pkg-comment
@@ -0,0 +1 @@
+perl5 module for file locking with flock.
diff --git a/devel/p5-File-BasicFlock/pkg-descr b/devel/p5-File-BasicFlock/pkg-descr
new file mode 100644
index 000000000000..b8d8b19d0295
--- /dev/null
+++ b/devel/p5-File-BasicFlock/pkg-descr
@@ -0,0 +1,6 @@
+File::Flock is a wrapper around the flock() call. The only thing it
+does that is special is that it creates the lock file if the lock file
+does not already exist.
+
+It will also try to remove the lock file. This makes it a bit
+complicated.
diff --git a/devel/p5-File-BasicFlock/pkg-plist b/devel/p5-File-BasicFlock/pkg-plist
new file mode 100644
index 000000000000..3a8cfc056986
--- /dev/null
+++ b/devel/p5-File-BasicFlock/pkg-plist
@@ -0,0 +1,2 @@
+lib/perl5/man/man3/File::BasicFlock.3.gz
+lib/perl5/site_perl/File/BasicFlock.pm