aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-06-14 02:36:44 +0800
committerijliao <ijliao@FreeBSD.org>2003-06-14 02:36:44 +0800
commit4ea5ffd6adeeabd5770c296f7d33bcbc9dd988c8 (patch)
treec60433f5ddb22bded69bab02d237e3c5ec22fc94
parentd0179d9aea740f29fb55b89cad07ffd45d06d24e (diff)
downloadfreebsd-ports-gnome-4ea5ffd6adeeabd5770c296f7d33bcbc9dd988c8.tar.gz
freebsd-ports-gnome-4ea5ffd6adeeabd5770c296f7d33bcbc9dd988c8.tar.zst
freebsd-ports-gnome-4ea5ffd6adeeabd5770c296f7d33bcbc9dd988c8.zip
add ArgoUML 0.12
A UML design tool with cognitive support
-rw-r--r--devel/Makefile1
-rw-r--r--devel/argouml/Makefile31
-rw-r--r--devel/argouml/distinfo1
-rw-r--r--devel/argouml/files/argouml3
-rw-r--r--devel/argouml/pkg-descr19
-rw-r--r--devel/argouml/pkg-plist9
6 files changed, 64 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 135501fa3a61..369f913ae093 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -23,6 +23,7 @@
SUBDIR += antlr
SUBDIR += apr
SUBDIR += arch
+ SUBDIR += argouml
SUBDIR += arm-aout-binutils
SUBDIR += arm-elf-binutils
SUBDIR += arm-elf-gcc295
diff --git a/devel/argouml/Makefile b/devel/argouml/Makefile
new file mode 100644
index 000000000000..259be32e6634
--- /dev/null
+++ b/devel/argouml/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: ArgoUML
+# Date created: June 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= argouml
+PORTVERSION= 0.12
+CATEGORIES= devel
+MASTER_SITES= http://argouml.tigris.org/files/documents/4/1087/
+DISTNAME= ArgoUML-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A UML design tool with cognitive support
+
+NO_WRKSUBDIR= yes
+USE_JAVA= 1.2+
+NO_BUILD= yes
+
+post-patch:
+ @${SED} 's,%%DATADIR%%,${DATADIR},' ${FILESDIR}/argouml > \
+ ${WRKSRC}/argouml
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/argouml ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.jar ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/devel/argouml/distinfo b/devel/argouml/distinfo
new file mode 100644
index 000000000000..480e3b187b48
--- /dev/null
+++ b/devel/argouml/distinfo
@@ -0,0 +1 @@
+MD5 (ArgoUML-0.12.tar.gz) = 0539995180670072a6bad71bbeb99bfd
diff --git a/devel/argouml/files/argouml b/devel/argouml/files/argouml
new file mode 100644
index 000000000000..79a043e67e2e
--- /dev/null
+++ b/devel/argouml/files/argouml
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -jar %%DATADIR%%/argouml.jar
diff --git a/devel/argouml/pkg-descr b/devel/argouml/pkg-descr
new file mode 100644
index 000000000000..f2461aff951a
--- /dev/null
+++ b/devel/argouml/pkg-descr
@@ -0,0 +1,19 @@
+ ArgoUML is a powerful yet easy-to-use interactive, graphical software
+ design environment that supports the design, development and
+ documentation of object-oriented software applications.
+
+ If you are familiar with a family of software applications called
+ Computer Aided Software Engineering (CASE) tools then you should find
+ ArgoUML instantly familiar.
+
+ The users of ArgoUML are software designers & architects, software
+ developers, business analysts, systems analysts and other
+ professionals involved in the analysis, design and development of
+ software applications. Main features:
+ * Open standards: XMI, SVG and PGML
+ * 100% Java
+ * Open Source allows to extend or customize it.
+ * Cognitive features like: reflection-in-action, bopportunistic
+ design, comprehension and problem solving
+
+WWW: http://argouml.tigris.org/
diff --git a/devel/argouml/pkg-plist b/devel/argouml/pkg-plist
new file mode 100644
index 000000000000..4c07eb7a8a92
--- /dev/null
+++ b/devel/argouml/pkg-plist
@@ -0,0 +1,9 @@
+bin/argouml
+%%DATADIR%%/antlrall.jar
+%%DATADIR%%/argouml.jar
+%%DATADIR%%/gef-0.9.6.jar
+%%DATADIR%%/log4j.jar
+%%DATADIR%%/nsuml.jar
+%%DATADIR%%/ocl-argo.jar
+%%DATADIR%%/xerces.jar
+@dirrm %%DATADIR%%