aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcel <marcel@FreeBSD.org>1999-08-18 20:49:53 +0800
committermarcel <marcel@FreeBSD.org>1999-08-18 20:49:53 +0800
commit507fd33573fb948e4be95f15b8c5784af2aa56e3 (patch)
tree0492ea04fdfbe435b6872ee19c08f7381af9ad1e
parent0fe66ad87b42a3ad89a61510782570589a85c9d3 (diff)
downloadfreebsd-ports-gnome-507fd33573fb948e4be95f15b8c5784af2aa56e3.tar.gz
freebsd-ports-gnome-507fd33573fb948e4be95f15b8c5784af2aa56e3.tar.zst
freebsd-ports-gnome-507fd33573fb948e4be95f15b8c5784af2aa56e3.zip
Fix the way the port figures out if linux support is present in the kernel.
It now also works when the linuxulator is compiled into the kernel (using options COMPAT_LINUX). Due to my misunderstanding, PR/12918 has been closed for the wrong reasons. My apologies to the originator. PR: 12918 Originator: Dean Lombardo <dlombardo@excite.com>
-rw-r--r--devel/linux_devtools-6/Makefile14
-rw-r--r--devel/linux_devtools-7/Makefile14
-rw-r--r--devel/linux_devtools/Makefile14
-rw-r--r--emulators/linux_base-6/Makefile14
-rw-r--r--emulators/linux_base-62/Makefile14
-rw-r--r--emulators/linux_base-8/Makefile14
-rw-r--r--emulators/linux_base-rh-9/Makefile14
-rw-r--r--emulators/linux_base-suse-9.1/Makefile14
-rw-r--r--emulators/linux_base-suse-9.2/Makefile14
-rw-r--r--emulators/linux_base-suse-9.3/Makefile14
-rw-r--r--emulators/linux_base/Makefile14
11 files changed, 77 insertions, 77 deletions
diff --git a/devel/linux_devtools-6/Makefile b/devel/linux_devtools-6/Makefile
index 9e444d1bd6bb..bcd701be3a41 100644
--- a/devel/linux_devtools-6/Makefile
+++ b/devel/linux_devtools-6/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 9, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.10 1999/07/21 11:16:09 marcel Exp $
+# $Id: Makefile,v 1.11 1999/08/11 18:46:08 marcel Exp $
#
DISTNAME= linux_devtools
@@ -76,13 +76,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/devel/linux_devtools-7/Makefile b/devel/linux_devtools-7/Makefile
index 9e444d1bd6bb..bcd701be3a41 100644
--- a/devel/linux_devtools-7/Makefile
+++ b/devel/linux_devtools-7/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 9, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.10 1999/07/21 11:16:09 marcel Exp $
+# $Id: Makefile,v 1.11 1999/08/11 18:46:08 marcel Exp $
#
DISTNAME= linux_devtools
@@ -76,13 +76,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/devel/linux_devtools/Makefile b/devel/linux_devtools/Makefile
index 9e444d1bd6bb..bcd701be3a41 100644
--- a/devel/linux_devtools/Makefile
+++ b/devel/linux_devtools/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 9, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.10 1999/07/21 11:16:09 marcel Exp $
+# $Id: Makefile,v 1.11 1999/08/11 18:46:08 marcel Exp $
#
DISTNAME= linux_devtools
@@ -76,13 +76,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base-6/Makefile b/emulators/linux_base-6/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base-6/Makefile
+++ b/emulators/linux_base-6/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base-62/Makefile b/emulators/linux_base-62/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base-62/Makefile
+++ b/emulators/linux_base-62/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base-rh-9/Makefile b/emulators/linux_base-rh-9/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base-rh-9/Makefile
+++ b/emulators/linux_base-rh-9/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base-suse-9.1/Makefile b/emulators/linux_base-suse-9.1/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base-suse-9.1/Makefile
+++ b/emulators/linux_base-suse-9.1/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base-suse-9.2/Makefile
+++ b/emulators/linux_base-suse-9.2/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base-suse-9.3/Makefile b/emulators/linux_base-suse-9.3/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base-suse-9.3/Makefile
+++ b/emulators/linux_base-suse-9.3/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi
diff --git a/emulators/linux_base/Makefile b/emulators/linux_base/Makefile
index 9ad65d92c066..06538e971939 100644
--- a/emulators/linux_base/Makefile
+++ b/emulators/linux_base/Makefile
@@ -3,7 +3,7 @@
# Date created: Jul 7, 1999
# Whom: marcel@FreeBSD.org
#
-# $Id: Makefile,v 1.27 1999/08/06 15:13:17 billf Exp $
+# $Id: Makefile,v 1.28 1999/08/08 11:40:53 marcel Exp $
#
DISTNAME= linux_base
@@ -105,13 +105,13 @@ NEEDLOADLINK= true
.endif
do-install:
- @if [ -z "`kldstat | ${GREP} linux.ko | ${AWK} '{print $1}'`" ]; then \
- ${ECHO} 'The Linux emulator kernel module is not loaded.\
- Loading Linux emulator kernel module...' | fmt; \
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading linux kernel module...' | fmt; \
linux || { \
- ${ECHO} 'The Linux emulator kernel module could not be\
- loaded. Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
+ ${ECHO} 'The linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
${FALSE}; \
};\
fi