aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-24 00:03:51 +0800
committermarcus <marcus@FreeBSD.org>2004-08-24 00:03:51 +0800
commit53da18a61241b8586c124dbc1a9ee5241678a1dd (patch)
tree7355a1d9536377a4a3874ccb083fddb0887a7324
parent5e888e83eb6c39e9b69c426a7b354c97652a8fe8 (diff)
downloadfreebsd-ports-gnome-53da18a61241b8586c124dbc1a9ee5241678a1dd.tar.gz
freebsd-ports-gnome-53da18a61241b8586c124dbc1a9ee5241678a1dd.tar.zst
freebsd-ports-gnome-53da18a61241b8586c124dbc1a9ee5241678a1dd.zip
Fix a crash with certain pixbuf-based themes (e.g. Neutrino).
Reported by: Tom McLaughlin <tmclaugh@sdf.lonestar.org> Obtained from: gtk-engines CVS
-rw-r--r--x11-themes/gtk-engines2/Makefile2
-rw-r--r--x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
index 459bd1c8a73a..f483e6818196 100644
--- a/x11-themes/gtk-engines2/Makefile
+++ b/x11-themes/gtk-engines2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gtk-engines2
PORTVERSION= 2.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
diff --git a/x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c b/x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c
new file mode 100644
index 000000000000..7d26e2d451bf
--- /dev/null
+++ b/x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c
@@ -0,0 +1,11 @@
+--- pixbuf/pixbuf-draw.c.orig Mon Aug 23 11:59:28 2004
++++ pixbuf/pixbuf-draw.c Mon Aug 23 12:00:13 2004
+@@ -75,7 +75,7 @@
+ continue;
+
+ if (image->match_data.detail &&
+- (!image->match_data.detail ||
++ (!match_data->detail ||
+ strcmp (match_data->detail, image->match_data.detail) != 0))
+ continue;
+