aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2018-03-08 03:42:09 +0800
committerjoneum <joneum@FreeBSD.org>2018-03-08 03:42:09 +0800
commit561b1fddf7820095665c2b96e0f9e7c7d4171edf (patch)
tree773adae601b484b632c0c1380106d95fda2c0a3a
parent6fb4644401e1a94d830206e6fd089e003b5efef2 (diff)
downloadfreebsd-ports-gnome-561b1fddf7820095665c2b96e0f9e7c7d4171edf.tar.gz
freebsd-ports-gnome-561b1fddf7820095665c2b96e0f9e7c7d4171edf.tar.zst
freebsd-ports-gnome-561b1fddf7820095665c2b96e0f9e7c7d4171edf.zip
New port: www/trac-devel
Trac uses a minimalistic approach to web-based software project management. Our mission; to help developers write great software while staying out of the way. Trac should impose as little as possible on a team's established development process and policies. All aspects of Trac have been designed with one single goal, to simplify tracking and communication of software issues, enhancements and monitoring overall progress. What is Trac? * An integrated system for managing software projects * An enhanced wiki * A flexible web-based issue tracker * An interface to the Subversion revision control system At the core of Trac lies an integrated wiki and issue/bug database. Using wiki markup, all objects managed by Trac can directly link to other issues/bug reports, code changesets, documentation and files. WWW: http://trac.edgewall.org/ Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D14588
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-devel/Makefile60
-rw-r--r--www/trac-devel/distinfo3
-rw-r--r--www/trac-devel/files/tracd.in61
-rw-r--r--www/trac-devel/pkg-descr21
-rw-r--r--www/trac-devel/pkg-message15
6 files changed, 161 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 13fb2f93ce3d..0037ef901833 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2325,6 +2325,7 @@
SUBDIR += trac-customfieldadmin
SUBDIR += trac-datefield
SUBDIR += trac-defaultcc
+ SUBDIR += trac-devel
SUBDIR += trac-discussion
SUBDIR += trac-downloads
SUBDIR += trac-email2trac
diff --git a/www/trac-devel/Makefile b/www/trac-devel/Makefile
new file mode 100644
index 000000000000..20ada69f9690
--- /dev/null
+++ b/www/trac-devel/Makefile
@@ -0,0 +1,60 @@
+# $FreeBSD$
+
+PORTNAME= trac
+DISTVERSION= 1.3.2
+CATEGORIES= www devel python
+MASTER_SITES= http://ftp.edgewall.com/pub/trac/ \
+ ftp://ftp.edgewall.com/pub/trac/
+DISTNAME= Trac-${DISTVERSION}
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= joneum@FreeBSD.org
+COMMENT= Enhanced wiki and issue tracking system for software projects
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS_INSTALL= trac
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Genshi>=0.7:textproc/py-genshi@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.10:devel/py-Jinja2@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Genshi>=0.7:textproc/py-genshi@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.10:devel/py-Jinja2@${FLAVOR}
+
+USES= python:-2.7 shebangfix
+SHEBANG_FILES= trac/tests/functional/better_twill.py trac/tests/functional/tester.py \
+ trac/tests/functional/testenv.py trac/tests/functional/compat.py \
+ trac/tests/functional/__init__.py contrib/emailfilter.py \
+ contrib/checkwiki.py contrib/htpasswd.py
+USE_PYTHON= distutils autoplist
+USE_RC_SUBR= tracd
+SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
+
+PORTEXAMPLES= *
+PORTDATA= *
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCUTILS PYGMENTS TZ SVN EXAMPLES
+OPTIONS_DEFAULT= DOCUTILS PYGMENTS TZ SVN SQLITE
+OPTIONS_RADIO= DATABASE
+OPTIONS_RADIO_DATABASE= PGSQL SQLITE
+DOCUTILS_DESC= Allow additional text markup
+PYGMENTS_DESC= Use generic syntax highlighter
+TZ_DESC= Process Time Zones
+
+DOCUTILS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0.14:textproc/py-docutils@${FLAVOR}
+PYGMENTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=2.2.0:textproc/py-pygments@${FLAVOR}
+TZ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${FLAVOR}
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2@${FLAVOR}
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR}
+SVN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}subversion>0:devel/py-subversion@${FLAVOR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample-plugins
+ ${FIND} ${WRKSRC}/contrib -type f -maxdepth 1 -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/ \;
+ (cd ${WRKSRC}/sample-plugins && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/sample-plugins)
+
+.include <bsd.port.mk>
diff --git a/www/trac-devel/distinfo b/www/trac-devel/distinfo
new file mode 100644
index 000000000000..04cd2ecff8b4
--- /dev/null
+++ b/www/trac-devel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520275493
+SHA256 (Trac-1.3.2.tar.gz) = 6e9b235ec0b5befc6efe5d05ae3b2459b459e073f6558442ba23acbacd225930
+SIZE (Trac-1.3.2.tar.gz) = 6321679
diff --git a/www/trac-devel/files/tracd.in b/www/trac-devel/files/tracd.in
new file mode 100644
index 000000000000..27756822a86a
--- /dev/null
+++ b/www/trac-devel/files/tracd.in
@@ -0,0 +1,61 @@
+#!/bin/sh
+#
+# tracd startup
+#
+# $FreeBSD$
+
+# PROVIDE: tracd
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable or configure tracd:
+# tracd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable tracd.
+# tracd_listen (str): The host name or IP address to bind tracd to.
+# By default tracd listens 0.0.0.0, i.e. all the
+# available addresses on all interfaces.
+# tracd_port (str): The port number to bind to, 80 by default.
+# tracd_pidfile (str): When daemonizing, file to which to write pid
+# if not to /var/run/tracd.pid.
+# tracd_envdir (str): Directory of the project environments. Set to
+# "/home/trac" by default.
+# tracd_env (str): The project environment name while using single
+# environment mode. The default is empty, meaning
+# multiproject mode.
+# tracd_args (str): Extra arguments passed to tracd startup
+# command. Empty by default.
+#
+
+. /etc/rc.subr
+
+name="tracd"
+rcvar=tracd_enable
+
+tracd_enable=${tracd_enable:-"NO"}
+tracd_listen=${tracd_listen:-"0.0.0.0"}
+tracd_port=${tracd_port:-"80"}
+tracd_pidfile=${tracd_pidfile:-"/var/run/tracd.pid"}
+tracd_envdir=${tracd_envdir:-"/home/trac"}
+tracd_env=${tracd_env:-""}
+tracd_args=${tracd_args:-""}
+
+load_rc_config ${name}
+
+command_args="--daemonize --hostname=${tracd_listen} --port=${tracd_port}"
+command_args="${command_args} --pidfile=${tracd_pidfile} ${tracd_args}"
+
+required_dirs=${tracd_envdir}
+pidfile=${tracd_pidfile}
+
+if [ -z "${tracd_env}" ]; then
+ _trac_env="--env-parent-dir ${tracd_envdir}"
+else
+ _trac_env="${tracd_envdir}/${tracd_env}"
+ command_args="${command_args} --single-env"
+fi
+
+command_args="%%PREFIX%%/bin/tracd ${command_args} ${_trac_env}"
+command="%%PYTHON_CMD%%"
+
+run_rc_command $1
diff --git a/www/trac-devel/pkg-descr b/www/trac-devel/pkg-descr
new file mode 100644
index 000000000000..b008fe05e687
--- /dev/null
+++ b/www/trac-devel/pkg-descr
@@ -0,0 +1,21 @@
+Trac uses a minimalistic approach to web-based software project management.
+Our mission; to help developers write great software while staying out of
+the way. Trac should impose as little as possible on a team's established
+development process and policies.
+
+All aspects of Trac have been designed with one single goal, to simplify
+tracking and communication of software issues, enhancements and monitoring
+overall progress.
+
+What is Trac?
+
+ * An integrated system for managing software projects
+ * An enhanced wiki
+ * A flexible web-based issue tracker
+ * An interface to the Subversion revision control system
+
+At the core of Trac lies an integrated wiki and issue/bug database. Using
+wiki markup, all objects managed by Trac can directly link to other
+issues/bug reports, code changesets, documentation and files.
+
+WWW: http://trac.edgewall.org/
diff --git a/www/trac-devel/pkg-message b/www/trac-devel/pkg-message
new file mode 100644
index 000000000000..0298f4551323
--- /dev/null
+++ b/www/trac-devel/pkg-message
@@ -0,0 +1,15 @@
+*******************************************************************************
+
+From 0.12.x to 1.0.x
+---------------------
+You should be careful to check that the plugins you depend on have
+been ported to 1.0.x, as they most probably won't work without adaptation
+due to the numerous internal changes that occurred during 1.0.x development.
+
+See: http://trac.edgewall.org/wiki/TracDev/ApiChanges/1.0
+
+Consult the upgrade instructions at:
+
+ http://trac.edgewall.org/wiki/TracUpgrade
+
+*******************************************************************************