aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-31 20:14:30 +0800
committermiwi <miwi@FreeBSD.org>2014-01-31 20:14:30 +0800
commit575b569687696d3ff7a187890eafa4bd37ae63b9 (patch)
treec56f8f84434450ac32b875839c719d59250ff69c
parent150bc2a50a0846efb0b6d01bfd5fc45c512e1f44 (diff)
downloadfreebsd-ports-gnome-575b569687696d3ff7a187890eafa4bd37ae63b9.tar.gz
freebsd-ports-gnome-575b569687696d3ff7a187890eafa4bd37ae63b9.tar.zst
freebsd-ports-gnome-575b569687696d3ff7a187890eafa4bd37ae63b9.zip
- Stage Support
- Convert to USES
-rw-r--r--devel/libgutenfetch/Makefile34
-rw-r--r--lang/rexx-regina/Makefile5
-rw-r--r--lang/rexx-regina/pkg-plist4
-rw-r--r--multimedia/audacious/Makefile6
-rw-r--r--multimedia/audacious/pkg-plist2
-rw-r--r--net/owamp/Makefile6
-rw-r--r--net/owamp/pkg-plist11
-rw-r--r--net/rfbproxy/Makefile6
-rw-r--r--net/sofia-sip/Makefile8
-rw-r--r--net/sofia-sip/pkg-plist6
-rw-r--r--net/yazproxy/Makefile3
-rw-r--r--net/yazproxy/pkg-plist1
12 files changed, 45 insertions, 47 deletions
diff --git a/devel/libgutenfetch/Makefile b/devel/libgutenfetch/Makefile
index f0df6951c951..38ed94f8f64c 100644
--- a/devel/libgutenfetch/Makefile
+++ b/devel/libgutenfetch/Makefile
@@ -16,32 +16,30 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
-USE_GMAKE= yes
+USES= gmake
USE_BZIP2= yes
-MAN3= libgutenfetch.3 \
- gutenfetch_version.3 \
- gutenfetch_shutdown.3 \
- gutenfetch_set_active_server_full.3 \
- gutenfetch_set_active_server.3 \
- gutenfetch_new_server.3 \
- gutenfetch_list_servers.3 \
- gutenfetch_is_threadsafe.3 \
- gutenfetch_init.3 \
- gutenfetch_get_aussie_server.3 \
- gutenfetch_get_active_server.3 \
- gutenfetch_free_server.3 \
- gutenfetch_free_servers.3 \
- gutenfetch_duplicate_server.3
-
PLIST_FILES= include/gutenfetch.h \
lib/libgutenfetch.a \
lib/libgutenfetch.la \
lib/libgutenfetch.so \
lib/libgutenfetch.so.0 \
- share/libgutenfetch/servers.txt
+ share/libgutenfetch/servers.txt \
+ man/man3/gutenfetch_duplicate_server.3.gz \
+ man/man3/gutenfetch_free_server.3.gz \
+ man/man3/gutenfetch_free_servers.3.gz \
+ man/man3/gutenfetch_get_active_server.3.gz \
+ man/man3/gutenfetch_get_aussie_server.3.gz \
+ man/man3/gutenfetch_init.3.gz \
+ man/man3/gutenfetch_is_threadsafe.3.gz \
+ man/man3/gutenfetch_list_servers.3.gz \
+ man/man3/gutenfetch_new_server.3.gz \
+ man/man3/gutenfetch_set_active_server.3.gz \
+ man/man3/gutenfetch_set_active_server_full.3.gz \
+ man/man3/gutenfetch_shutdown.3.gz \
+ man/man3/gutenfetch_version.3.gz \
+ man/man3/libgutenfetch.3.gz
PLIST_DIRS= share/libgutenfetch
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/lang/rexx-regina/Makefile b/lang/rexx-regina/Makefile
index 5e94482044a6..9f3f72a8215c 100644
--- a/lang/rexx-regina/Makefile
+++ b/lang/rexx-regina/Makefile
@@ -15,14 +15,11 @@ CONFLICTS= rexx-imc-* oorexx-[0-9]*
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
USE_RC_SUBR= rxstack
-MAN1= regina.1 regina-config.1 rxqueue.1 rxstack.1
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
diff --git a/lang/rexx-regina/pkg-plist b/lang/rexx-regina/pkg-plist
index aed504726d82..c20f2ad7f64d 100644
--- a/lang/rexx-regina/pkg-plist
+++ b/lang/rexx-regina/pkg-plist
@@ -25,4 +25,8 @@ lib/librxtest2.so
%%DATADIR%%/sv.mtb
%%DATADIR%%/timeconv.rexx
%%DATADIR%%/tr.mtb
+man/man1/regina-config.1.gz
+man/man1/regina.1.gz
+man/man1/rxqueue.1.gz
+man/man1/rxstack.1.gz
@dirrm %%DATADIR%%
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index 6eb43dc15bd4..cf34da11c941 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -14,8 +14,7 @@ LIB_DEPENDS= mcs:${PORTSDIR}/devel/libmcs \
xml2:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
-USES= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
USE_XORG= x11 sm
USE_BZIP2= yes
USE_GNOME= gtk30
@@ -25,7 +24,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-chardet --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
-MAN1= audacious.1 audtool.1
OPTIONS_DEFINE= DBUS GNOME ICONV NLS EXECINFO SSE2 CHARSET
OPTIONS_DEFAULT= DBUS ICONV NLS EXECINFO SSE2 CHARSET
@@ -33,7 +31,6 @@ CHARSET_DESC= Build with automatic charset detection
EXECINFO_DESC= Build with libexecinfo support
SSE2_DESC=Build with SSE2 instruction set
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDBUS}
@@ -89,7 +86,6 @@ post-patch:
.endif
post-install:
- @${CAT} ${PKGMESSAGE}
.if defined(WITH_GNOME)
@${ECHO_MSG} ""
@${ECHO_MSG} "You have installed audacious with gconf support."
diff --git a/multimedia/audacious/pkg-plist b/multimedia/audacious/pkg-plist
index c1ceba86da67..8e76720dc804 100644
--- a/multimedia/audacious/pkg-plist
+++ b/multimedia/audacious/pkg-plist
@@ -121,6 +121,8 @@ share/icons/hicolor/scalable/apps/audacious.svg
%%NLS%%@dirrmtry share/locale/ast
%%NLS%%@dirrmtry share/locale/ml_IN/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ml_IN
+man/man1/audacious.1.gz
+man/man1/audtool.1.gz
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%
@dirrm include/libaudgui
diff --git a/net/owamp/Makefile b/net/owamp/Makefile
index be4ef423240d..a910edfcaaa7 100644
--- a/net/owamp/Makefile
+++ b/net/owamp/Makefile
@@ -12,10 +12,4 @@ LICENSE= APACHE20
GNU_CONFIGURE= yes
-MAN1= aespasswd.1 owfetch.1 owping.1 owstats.1 owup.1 \
- pfstore.1 powstream.1
-MAN5= owampd.conf.5 owampd.limits.5 owampd.pfs.5
-MAN8= owampd.8
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/owamp/pkg-plist b/net/owamp/pkg-plist
index b7f1ae030a8a..a0d2745397de 100644
--- a/net/owamp/pkg-plist
+++ b/net/owamp/pkg-plist
@@ -28,4 +28,15 @@ include/I2util/table.h
include/I2util/util.h
lib/libI2util.a
lib/libowamp.a
+man/man1/aespasswd.1.gz
+man/man1/owfetch.1.gz
+man/man1/owping.1.gz
+man/man1/owstats.1.gz
+man/man1/owup.1.gz
+man/man1/pfstore.1.gz
+man/man1/powstream.1.gz
+man/man5/owampd.conf.5.gz
+man/man5/owampd.limits.5.gz
+man/man5/owampd.pfs.5.gz
+man/man8/owampd.8.gz
@dirrm include/I2util
diff --git a/net/rfbproxy/Makefile b/net/rfbproxy/Makefile
index 55021f7d0960..416f34ac0f92 100644
--- a/net/rfbproxy/Makefile
+++ b/net/rfbproxy/Makefile
@@ -13,8 +13,8 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
-MAN1= rfbproxy.1
-PLIST_FILES= bin/rfbproxy
+PLIST_FILES= bin/rfbproxy \
+ man/man1/rfbproxy.1.gz
+
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/sofia-sip/Makefile b/net/sofia-sip/Makefile
index a89b95f1bd4e..b4d5e56a5996 100644
--- a/net/sofia-sip/Makefile
+++ b/net/sofia-sip/Makefile
@@ -16,12 +16,4 @@ GNU_CONFIGURE= yes
USE_OPENSSL= yes
USE_GNOME= glib20
-MAN1= sip-date.1 \
- sip-options.1 \
- localinfo.1 \
- addrinfo.1 \
- stunc.1 \
- sip-dig.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/sofia-sip/pkg-plist b/net/sofia-sip/pkg-plist
index bf01d2e712d7..b362e149e149 100644
--- a/net/sofia-sip/pkg-plist
+++ b/net/sofia-sip/pkg-plist
@@ -129,6 +129,12 @@ lib/libsofia-sip-ua.so
lib/libsofia-sip-ua.so.6
libdata/pkgconfig/sofia-sip-ua-glib.pc
libdata/pkgconfig/sofia-sip-ua.pc
+man/man1/addrinfo.1.gz
+man/man1/localinfo.1.gz
+man/man1/sip-date.1.gz
+man/man1/sip-dig.1.gz
+man/man1/sip-options.1.gz
+man/man1/stunc.1.gz
@dirrm include/sofia-sip-1.12/sofia-resolv
@dirrm include/sofia-sip-1.12/sofia-sip
@dirrm include/sofia-sip-1.12
diff --git a/net/yazproxy/Makefile b/net/yazproxy/Makefile
index bd9f38494ae7..580a26ec672b 100644
--- a/net/yazproxy/Makefile
+++ b/net/yazproxy/Makefile
@@ -15,7 +15,4 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-shared --with-yazpp=${LOCALBASE}/bin
USE_LDCONFIG= yes
-MAN8= yazproxy.8
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/yazproxy/pkg-plist b/net/yazproxy/pkg-plist
index d139e1633980..c42ac2c0cd51 100644
--- a/net/yazproxy/pkg-plist
+++ b/net/yazproxy/pkg-plist
@@ -51,6 +51,7 @@ lib/yazproxy/mod_proxy_sample.so
%%DATADIR%%/yazproxy.xsd
%%DATADIR%%/yazproxyctl.sh
%%DATADIR%%/zeerex-2.0.xsd
+man/man8/yazproxy.8.gz
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%/common
@dirrm %%DOCSDIR%%