aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-22 16:16:07 +0800
committerbapt <bapt@FreeBSD.org>2013-03-22 16:16:07 +0800
commit585c8a6ae1e9af6cd6b5b6cf169015af3814e03b (patch)
tree0eed80486c0c9ee317000732b7da17a2b76db9f5
parent170f3db0c400763a4a07eadc79e7abfece921b1c (diff)
downloadfreebsd-ports-gnome-585c8a6ae1e9af6cd6b5b6cf169015af3814e03b.tar.gz
freebsd-ports-gnome-585c8a6ae1e9af6cd6b5b6cf169015af3814e03b.tar.zst
freebsd-ports-gnome-585c8a6ae1e9af6cd6b5b6cf169015af3814e03b.zip
Convert to new options framework left unconverted ports in x* categories
-rw-r--r--x11-fonts/font-manager/Makefile8
-rw-r--r--x11-themes/gtk-murrine-engine/Makefile16
-rw-r--r--x11-toolkits/gigi/Makefile9
-rw-r--r--x11-toolkits/irrlicht/Makefile23
-rw-r--r--x11-toolkits/paragui-devel/Makefile14
-rw-r--r--x11-toolkits/swt/Makefile17
-rw-r--r--x11-toolkits/tkshape/Makefile17
-rw-r--r--x11-toolkits/wxd/Makefile15
-rw-r--r--x11-toolkits/wxgtk28/Makefile19
-rw-r--r--x11-toolkits/wxgtk29/Makefile19
-rw-r--r--x11-wm/fvwm2/Makefile67
-rw-r--r--x11/alltray/Makefile15
-rw-r--r--x11/dmenu/Makefile16
-rw-r--r--x11/dzen2/Makefile22
-rw-r--r--x11/metalock/Makefile18
-rw-r--r--x11/mrxvt-devel/Makefile58
-rw-r--r--x11/slim/Makefile10
-rw-r--r--x11/workrave/Makefile24
18 files changed, 170 insertions, 217 deletions
diff --git a/x11-fonts/font-manager/Makefile b/x11-fonts/font-manager/Makefile
index 5d3b20837f40..0f604bcbb32a 100644
--- a/x11-fonts/font-manager/Makefile
+++ b/x11-fonts/font-manager/Makefile
@@ -24,8 +24,8 @@ MAKE_JOBS_SAFE= yes
LICENSE_FILE= ${WRKSRC}/COPYING
PORTDATA= *
-OPTIONS= REPORTLAB "Enable font-sampler (PDF sample sheet)" off \
- NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= REPORTLAB NLS
+REPORTLAB_DESC= Enable font-sampler (PDF sample sheet)
.include <bsd.port.options.mk>
@@ -33,7 +33,7 @@ OPTIONS= REPORTLAB "Enable font-sampler (PDF sample sheet)" off \
IGNORE= port data is source code, undefine NOPORTDATA
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
@@ -42,7 +42,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_REPORTLAB)
+.if ${PORT_OPTIONS:MREPORTLAB}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/reportlab/:${PORTSDIR}/print/py-reportlab2
.endif
diff --git a/x11-themes/gtk-murrine-engine/Makefile b/x11-themes/gtk-murrine-engine/Makefile
index bf50098cd700..dff75ee0a244 100644
--- a/x11-themes/gtk-murrine-engine/Makefile
+++ b/x11-themes/gtk-murrine-engine/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtk-murrine-engine
-# Date created: 2006-08-20
-# Whom: Phillip Neumann <pneumann@gmail.com>
-#
+# Created by: Phillip Neumann <pneumann@gmail.com>
# $FreeBSD$
-#
PORTNAME= murrine
PORTVERSION= 0.98.1.1
@@ -26,12 +22,14 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= ANIMATION "Enable animation support" off
+OPTIONS_DEFINE= ANIMATION
+OPTIONS_DEFAULT= ANIMATION
+ANIMATION_DESC= Animation support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_ANIMATION)
+.if ${PORT_OPTIONS:MANIMATION}
CONFIGURE_ARGS+=--enable-animation
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gigi/Makefile b/x11-toolkits/gigi/Makefile
index 90ec616f1ad6..1180820ab532 100644
--- a/x11-toolkits/gigi/Makefile
+++ b/x11-toolkits/gigi/Makefile
@@ -25,16 +25,17 @@ USE_LDCONFIG= yes
# Ensure local headers are found first, otherwise updating would fail.
CFLAGS+= -I.
-OPTIONS= OGRE "Enable Ogre (3D engine) support" on
+OPTIONS_DEFINE= OGRE
+OGRE_DESC= Ogre (3D engine) support
SHLIB_VER= 0
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GIGI_LIBS= GiGi GiGiSDL
WRKSRC= ${WRKDIR}/gigi/GG
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OGRE)
+.if ${PORT_OPTIONS:MOGRE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
RUN_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
@@ -69,4 +70,4 @@ maint-gen-distfile:
tar cjf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}
${RM} -rf ${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/irrlicht/Makefile b/x11-toolkits/irrlicht/Makefile
index aa78017db6d8..9e21c3cc26c7 100644
--- a/x11-toolkits/irrlicht/Makefile
+++ b/x11-toolkits/irrlicht/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: irrlicht
-# Date created: 19 September 2004
-# Whom: Simon Barner <barner@gmx.de>
-#
+# Created by: Simon Barner <barner@gmx.de>
# $FreeBSD$
-#
PORTNAME= irrlicht
PORTVERSION= 1.7.3
@@ -35,11 +31,10 @@ EXAMPLEDIRS= 01.HelloWorld 02.Quake3Map 03.CustomSceneNode 04.Movement 05.UserIn
11.PerPixelLighting 12.TerrainRendering 13.RenderToTexture 15.LoadIrrFile \
Demo
-OPTIONS= DEBUG "Compile with debugging simbols" off \
- EXAMPLES "Install example files" on \
- JOYSTICK "Support for Linux Joystick" off
+OPTIONS_DEFINE= DEBUG EXAMPLES JOYSTICK
+JOYSTICK_DESC= Support for Linux Joystick
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if (${ARCH} == "amd64") || (${ARCH} == "ia64")
CFLAGS+= -fPIC
@@ -49,18 +44,18 @@ CFLAGS+= -fPIC
BROKEN= Does not compile on sparc64
.endif
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if defined(WITH_JOYSTICK)
+.if ${PORT_OPTIONS:MJOYSTICK}
BUILD_DEPENDS+= ${LOCALBASE}/include/linux/joystick.h:${PORTSDIR}/devel/linux-js
HAVE_JOYSTICK= true
.endif
-.if !defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
MAKE_ENV+= NDEBUG=1
.endif
@@ -87,7 +82,7 @@ do-install:
${PREFIX}/lib && ${LN} -s libIrrlicht.so.${SHARED_LIB_VER} \
${PREFIX}/lib/libIrrlicht.so
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
.for DIRE in ${EXAMPLEDIRS}
${MKDIR} ${EXAMPLESDIR}/${DIRE}
${INSTALL_DATA} ${WRKSRC}/examples/${DIRE}/Makefile \
@@ -103,4 +98,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/paragui-devel/Makefile b/x11-toolkits/paragui-devel/Makefile
index 2cf54c99b6b5..3efe1741c48d 100644
--- a/x11-toolkits/paragui-devel/Makefile
+++ b/x11-toolkits/paragui-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: paragui
-# Date Created: Mar 28, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= paragui
PORTVERSION= 1.1.8
@@ -33,11 +29,11 @@ USE_LDCONFIG= yes
SHLIB_VER= 4
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
-OPTIONS= DEBUG "Debug information" off
+OPTIONS_DEFINE= DEBUG
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -54,4 +50,4 @@ post-patch:
s|-L[./]*../src|&/.libs |g ; \
s|-release $$(LT_RELEASE)||g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index 8e8a0e06e283..9d1c94133d29 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -42,25 +42,26 @@ PLIST_FILES= %%JAVAJARDIR%%/${OUTPUT_JAR} \
NO_WRKSUBDIR= yes
-OPTIONS= CAIRO "Cairo Support" on \
- GNOMEVFS "Gnome VFS Support" on \
- BROWSER "Gecko Browser Support" on
+OPTIONS_DEFINE= CAIRO GNOMEVFS BROWSER
+OPTIONS_DEFAULT= CAIRO GNOMEVFS BROWSER
+GNOMEVFS_DESC= Gnome VFS Support
+BROWSER_DESC= Gecko Browser Support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_CAIRO)
+.if ${PORT_OPTIONS:MCAIRO}
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
PLIST_FILES+= lib/libswt-cairo-gtk-%%BUILD%%.so
MAKE_CAIRO= make_cairo
.endif
-.if defined(WITH_GNOMEVFS)
+.if ${PORT_OPTIONS:MGNOMEVFS}
USE_GNOME+= gnomevfs2 libgnome libgnomeui
PLIST_FILES+= lib/libswt-gnome-gtk-%%BUILD%%.so
MAKE_GNOME= make_gnome
.endif
-.if defined(WITH_BROWSER)
+.if ${PORT_OPTIONS:MBROWSER}
USE_GECKO= libxul19
PLIST_FILES+= lib/libswt-xulrunner-gtk-%%BUILD%%.so
MAKE_MOZILLA= make_xulrunner
@@ -86,4 +87,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/libswt-*.so ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/${OUTPUT_JAR} ${JAVAJARDIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/tkshape/Makefile b/x11-toolkits/tkshape/Makefile
index 3af48632b314..3a0a3b39ccb9 100644
--- a/x11-toolkits/tkshape/Makefile
+++ b/x11-toolkits/tkshape/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: TkShape
-# Date created: 13 March 2004
-# Whom: nivit@users.sourceforge.net
-#
+# Created by: nivit@users.sourceforge.net
# $FreeBSD$
PORTNAME= tkshape
@@ -23,11 +20,13 @@ PLIST_SUB= PORTNAME="${PORTNAME}"
USE_LDCONFIG= yes
-OPTIONS= MANPAGES "Install manual pages" on
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT= MANPAGES
+MANPAGES_DESC= Install manual pages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MANPAGES)
+.if ${PORT_OPTIONS:MMANPAGES}
MAN3= CombShape.3 QuryShape.3
MANN= shape.n
.endif
@@ -83,7 +82,7 @@ do-install:
${INSTALL_DATA} unix/pkgIndex.tcl ${TARGET_DIR}/pkgIndex.tcl;
# manpages
-.if defined(WITH_MANPAGES)
+.if ${PORT_OPTIONS:MMANPAGES}
cd ${WRKSRC}; \
for m in ${MANPAGES} ; do \
s=$${m##*.}; \
@@ -91,4 +90,4 @@ do-install:
done;
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wxd/Makefile b/x11-toolkits/wxd/Makefile
index 30836b7efacf..beff314ecfca 100644
--- a/x11-toolkits/wxd/Makefile
+++ b/x11-toolkits/wxd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wxd
-# Date created: 29 August 2006
-# Whom: Jona Joachim <walkingshadow@grummel.net>
-#
+# Created by: Jona Joachim <walkingshadow@grummel.net>
# $FreeBSD$
-#
PORTNAME= wxd
PORTVERSION= 0.14
@@ -22,15 +18,16 @@ USE_LDCONFIG= yes
USE_WX= 2.8
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= UNICODE "Build the Unicode version" On
+OPTIONS_DEFINE= UNICODE
+OPTIONS_DEFAULT= UNICODE
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
BROKEN= does not compile
.endif
-.if !defined(WITHOUT_UNICODE)
+.if ${PORT_OPTIONS:MUNICODE}
WX_UNICODE= yes
.endif
@@ -42,4 +39,4 @@ pre-patch:
@${RM} ${WRKSRC}/wx/Makefile
@${MV} ${WRKSRC}/wx/GNUmakefile ${WRKSRC}/wx/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
index 7f57d36abfef..9519d4b33039 100644
--- a/x11-toolkits/wxgtk28/Makefile
+++ b/x11-toolkits/wxgtk28/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wxgtk26
-# Date created: June 27, 2004
-# Whom: fjoe@FreeBSD.ORG
-#
+# Created by: fjoe@FreeBSD.ORG
# $FreeBSD$
-#
PORTNAME= wx
PORTVERSION= 2.8.12
@@ -49,12 +45,13 @@ PLIST= ${.CURDIR}/pkg-plist
WXGTK_FLAVOR?= gtk2
-OPTIONS= GSTREAMER "media support" on\
- MSPACK "MS archives support" on
+OPTIONS_DEFINE= GSTREAMER MSPACK
+OPTIONS_DEFAULT= GSTREAMER MSPACK
+MSPACK_DESC= MS archives support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GSTREAMER)
+.if ${PORT_OPTIONS:MGSTREAMER}
CONFIGURE_ARGS+=--enable-mediactrl
USE_GNOME+= gconf2
USE_GSTREAMER= yes
@@ -64,7 +61,7 @@ CONFIGURE_ARGS+=--disable-mediactrl
PLIST_SUB+= GSTREAMER="@comment "
.endif
-.if defined(WITH_MSPACK)
+.if ${PORT_OPTIONS:MMSPACK}
CONFIGURE_ARGS+=--with-libmspack
LIB_DEPENDS+= mspack.1:${PORTSDIR}/archivers/libmspack
.else
@@ -113,4 +110,4 @@ post-patch:
-e 's|png_check_sig|png_sig_cmp|g' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
index f1dce9e1f18f..b6dda7a7d70d 100644
--- a/x11-toolkits/wxgtk29/Makefile
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wxgtk26
-# Date created: June 27, 2004
-# Whom: fjoe@FreeBSD.ORG
-#
+# Created by: fjoe@FreeBSD.ORG
# $FreeBSD$
-#
PORTNAME= wx
PORTVERSION= 2.9.4
@@ -50,12 +46,13 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -linotify"\
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
NO_LATEST_LINK= yes
-OPTIONS= GSTREAMER "media support" on\
- MSPACK "MS archives support" on
+OPTIONS_DEFINE= GSTREAMER MSPACK
+OPTIONS_DEFAULT= GSTREAMER MSPACK
+MSPACK_DESC= MS archives support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GSTREAMER)
+.if ${PORT_OPTIONS:MGSTREAMER}
CONFIGURE_ARGS+=--enable-mediactrl
USE_GNOME+= gconf2
USE_GSTREAMER= yes
@@ -65,11 +62,11 @@ CONFIGURE_ARGS+=--disable-mediactrl
PLIST_SUB+= GSTREAMER="@comment "
.endif
-.if defined(WITH_MSPACK)
+.if ${PORT_OPTIONS:MMSPACK}
CONFIGURE_ARGS+=--with-libmspack
LIB_DEPENDS+= mspack.1:${PORTSDIR}/archivers/libmspack
.else
CONFIGURE_ARGS+=--without-libmspack
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/fvwm2/Makefile b/x11-wm/fvwm2/Makefile
index 14f6729e091b..46ba388664f5 100644
--- a/x11-wm/fvwm2/Makefile
+++ b/x11-wm/fvwm2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Fvwm2
-# Date created: 20 Jan 1996
-# Whom: peter
-#
+# Created by: peter
# $FreeBSD$
-#
PORTNAME= fvwm
PORTVERSION= 2.6.5
@@ -32,26 +28,23 @@ USE_XORG= xpm xft
USE_BZIP2= yes
WANT_GNOME= yes
-OPTIONS= ICONS "Install default icon set" on \
- ICONV "Enable iconv character conversion support" on \
- STROKE "Enable support for mouse gestures" off \
- RPLAY "Enable RPlay support in FvwmEvent" off \
- SESSION_MGMT "Enable Session Management support" on \
- PNG "Build with PNG graphics support" on \
- SVG "Build with SVG graphics support using librsvg2" off \
- BIDI "Enable Asian bi-directional text support" off \
- NLS "Enable National Language Support" on \
- IMLIB "Enable imlib library (requires gtk12)" off \
- GNOME "Enable GNOME desktop support" off
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_ICONS)
+OPTIONS_DEFINE= ICONS ICONV STROKE RPLAY SESSION_MGMT PNG SVG BIDI NLS IMLIB GNOME1
+OPTIONS_DEFAULT= ICONV ICONV PNG
+STROKE_DESC= support for mouse gestures
+RPLAY_DESC= RPlay support in FvwmEvent
+SESSION_MGMT_DESC= Session Management support
+BIDI_DESC= Asian bi-directional text support
+IMLIB_DESC= imlib library (requires gtk12)
+GNOME1_DESC= GNOME 1 desktop support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MICONS}
FVWM_ICONS= fvwm_icons-20070101
DISTFILES+= ${FVWM_ICONS}.tar.bz2
.endif
-.if defined(WITHOUT_ICONV)
+.if ! ${PORT_OPTIONS:MICONV}
CONFIGURE_ARGS+= --disable-iconv
.else
USE_ICONV= yes
@@ -59,7 +52,7 @@ CONFIGURE_ARGS+= --with-iconv-library=${LOCALBASE}/lib \
--with-iconv-includes=${LOCALBASE}/include
.endif
-.if defined(WITH_STROKE)
+.if ${PORT_OPTIONS:MSTROKE}
LIB_DEPENDS+= stroke.0:${PORTSDIR}/devel/libstroke
CONFIGURE_ARGS+= --with-stroke-library=${LOCALBASE}/lib \
--with-stroke-includes=${LOCALBASE}/include
@@ -67,7 +60,7 @@ CONFIGURE_ARGS+= --with-stroke-library=${LOCALBASE}/lib \
CONFIGURE_ARGS+= --without-stroke-library
.endif
-.if defined(WITH_RPLAY)
+.if ${PORT_OPTIONS:MRPLAY}
LIB_DEPENDS+= rplay.1:${PORTSDIR}/audio/rplay
CONFIGURE_ARGS+= --with-rplay-library=${LOCALBASE}/lib \
--with-rplay-includes=${LOCALBASE}/include
@@ -75,11 +68,11 @@ CONFIGURE_ARGS+= --with-rplay-library=${LOCALBASE}/lib \
CONFIGURE_ARGS+= --without-rplay-library
.endif
-.if defined(WITHOUT_SESSION_MGMT)
+.if ! ${PORT_OPTIONS:MSESSION_MGMT}
CONFIGURE_ARGS+= --disable-sm
.endif
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-png-includes=${LOCALBASE}/include \
--with-png-library=${LOCALBASE}/lib
@@ -87,23 +80,23 @@ CONFIGURE_ARGS+= --with-png-includes=${LOCALBASE}/include \
CONFIGURE_ARGS+= --without-png-library
.endif
-.if defined(WITH_SVG) && !defined(WITHOUT_SVG)
+.if ${PORT_OPTIONS:MSVG) && !defined(WITHOUT_SVG}
USE_GNOME+= librsvg2
.else
CONFIGURE_ARGS+= --disable-rsvg
.endif
-.if defined(WITHOUT_BIDI)
-CONFIGURE_ARGS+= --disable-bidi
-.else
+.if ${PORT_OPTIONS:MBIDI}
LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --enable-bidi \
--with-bidi-bindir=${LOCALBASE}/bin
+.else
+CONFIGURE_ARGS+= --disable-bidi
.endif
PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
-.if defined(WITH_IMLIB) && !defined(WITHOUT_GTK)
+.if ${PORT_OPTIONS:MIMLIB) && !defined(WITHOUT_GTK}
USE_GNOME+= imlib
CONFIGURE_ARGS+= --enable-gtktest --enable-imlibtest
PLIST_SUB+= GTK=""
@@ -115,7 +108,7 @@ PLIST_SUB+= GTK="@comment not installed: "
WITHOUT_GNOME= true
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+= --with-intl-library=${LOCALBASE}/lib \
--with-intl-includes=${LOCALBASE}/include
@@ -125,11 +118,11 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment not installed: "
.endif
-.if defined(WITHOUT_GNOME)
-CONFIGURE_ARGS+= --without-gnome
-.else
+.if ${PORT_OPTIONS:MGNOME1}
USE_GNOME+=gnomelibs
CONFIGURE_ARGS+= --with-gnome
+.else
+CONFIGURE_ARGS+= --without-gnome
.endif
MAN1+= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
@@ -147,7 +140,7 @@ MAN1+= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
MLINKS= fvwm.1 fvwm2.1 \
fvwm-root.1 xpmroot.1
-.if !defined(WITHOUT_ICONS)
+.if ${PORT_OPTIONS:MICONS}
PLIST_SUB+= ICONS=""
post-extract:
@${MKDIR} ${WRKDIR}/icons
@@ -169,10 +162,10 @@ post-install:
${PREFIX}/etc/system.fvwm2rc; \
fi
-.if !defined(WITHOUT_ICONS)
+.if ${PORT_OPTIONS:MICONS}
@${MKDIR} ${PREFIX}/share/fvwm/pixmaps
${INSTALL_DATA} ${WRKDIR}/icons/${FVWM_ICONS}/*.xpm \
${PREFIX}/share/fvwm/pixmaps
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/alltray/Makefile b/x11/alltray/Makefile
index aa49b22eb110..9e2b701e7ab4 100644
--- a/x11/alltray/Makefile
+++ b/x11/alltray/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: alltray
-# Date created: 2005-10-15
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= alltray
PORTVERSION= 0.70
@@ -22,11 +18,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= alltray.1
-OPTIONS= KDE "Support only KDE desktop" off
+OPTIONS_DEFINE= KDE
+KDE_DESC= Support only KDE desktop
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_KDE)
+.if ${PORT_OPTIONS:MKDE}
CONFIGURE_ARGS= --disable-gconf
.else
USE_GNOME+= gconf2
@@ -42,4 +39,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|liballtray\.so\.0\.0\.0|liballtray.so.0|; \
s|/usr/lib|${PREFIX}/lib|' ${WRKSRC}/src/child.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/dmenu/Makefile b/x11/dmenu/Makefile
index 30c021294a33..213ab1445b0d 100644
--- a/x11/dmenu/Makefile
+++ b/x11/dmenu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dmenu
-# Date created: August 4, 2006
-# Whom: Jeroen Schot <schot@a-eskwadraat.nl>
-#
+# Created by: Jeroen Schot <schot@a-eskwadraat.nl>
# $FreeBSD$
-#
PORTNAME= dmenu
PORTVERSION= 4.5
@@ -21,8 +17,8 @@ COMMENT= X11 menu application designed for the dwm window manager
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS= XINERAMA "Enable Xinerama support" On \
- XFT "Enable Xft support" Off
+OPTIONS_DEFINE= XINERAMA XFT
+OPTIONS_DEFAULT= XINERAMA
USE_XORG= x11
@@ -31,11 +27,11 @@ PLIST_FILES= bin/dmenu bin/dmenu_run bin/stest
.include <bsd.port.options.mk>
-.if defined(WITH_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
USE_XORG+= xinerama
.endif
-.if defined(WITH_XFT)
+.if ${PORT_OPTIONS:MXFT}
USE_XORG+= xft
PATCHFILES+= ${PORTNAME}-${PORTVERSION}-xft.diff
.endif
@@ -45,7 +41,7 @@ post-patch:
-e "s,%%PREFIX%%,${PREFIX},g" \
-e "s,%%LOCALBASE%%,${LOCALBASE},g" \
-e "s,%%MANPREFIX%%,${MANPREFIX},g"
-.if defined(WITHOUT_XINERAMA)
+.if ! ${PORT_OPTIONS:MXINERAMA}
@${REINPLACE_CMD} -e 's,$${XINERAMALIBS},,g' \
-e 's,$${XINERAMAFLAGS},,g' ${WRKSRC}/config.mk
.endif
diff --git a/x11/dzen2/Makefile b/x11/dzen2/Makefile
index eb85450c24ad..3f4d501706a2 100644
--- a/x11/dzen2/Makefile
+++ b/x11/dzen2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dzen2
-# Date created: May 26 2008
-# Whom: Morten Slot Kristensen
-#
+# Created by: Morten Slot Kristensen
# $FreeBSD$
-#
PORTNAME= dzen2
PORTVERSION= 0.8.5
@@ -18,26 +14,26 @@ USE_XORG= x11
PLIST_FILES= bin/${PORTNAME}
-OPTIONS= XPM "Enable XPM support" On \
- XINERAMA "Enable Xinerama support" On
+OPTIONS_DEFINE= XPM XINERAMA
+OPTIONS_DEFAULT= XPM XINERAMA
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_XPM)
+.if ${PORT_OPTIONS:MXPM}
USE_XORG+= xpm
.endif
-.if !defined(WITHOUT_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
USE_XORG+= xinerama
.endif
post-patch:
-.if !defined(WITHOUT_XPM)
+.if ${PORT_OPTIONS:MXPM}
${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXpm/g' \
-e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XPM/g' \
${WRKSRC}/config.mk
.endif
-.if !defined(WITHOUT_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXinerama/g' \
-e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XINERAMA/g' \
${WRKSRC}/config.mk
@@ -45,4 +41,4 @@ post-patch:
${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
${WRKSRC}/config.mk
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/metalock/Makefile b/x11/metalock/Makefile
index 844ea3aa9aea..67741d0a102d 100644
--- a/x11/metalock/Makefile
+++ b/x11/metalock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: metalock
-# Date created: 21 March 2012
-# Whom: Timothy Beyer <beyert@cs.ucr.edu>
-#
+# Created by: Timothy Beyer <beyert@cs.ucr.edu>
# $FreeBSD$
-#
PORTNAME= metalock
PORTVERSION= 0.8.0
@@ -23,29 +19,29 @@ FETCH_ARGS= "-Fpr"
USE_BZIP2= yes
USE_XORG= x11 xt xproto xext xpm
-OPTIONS= IMLIB2 "Use Imlib2" on \
- XFT "Use Xft Fonts" on \
- ULTRAGETOPT "Use Ultragetopt" on
+OPTIONS_DEFINE= IMLIB2 XFT ULTRAGETOPT
+OPTIONS_DEFAULT= IMLIB2 XFT ULTRAGETOPT
+ULTRAGETOPT_DESC= Use Ultragetopt
.include <bsd.port.options.mk>
MAKE_ARGS= PREFIX="${LOCALBASE}" DEST_PREFIX="${PREFIX}" CC="${CC}"
-.if !defined(WITHOUT_ULTRAGETOPT)
+.if ${PORT_OPTIONS:MULTRAGETOPT}
LIB_DEPENDS+= ultragetopt.0:${PORTSDIR}/devel/ultragetopt
MAKE_ARGS+= USE_ULTRAGETOPT=yes
.else
MAKE_ARGS+= USE_ULTRAGETOPT=no
.endif
-.if !defined(WITHOUT_IMLIB2)
+.if ${PORT_OPTIONS:MIMLIB2}
USE_EFL= imlib2
MAKE_ARGS+= USE_IMLIB2=yes
.else
MAKE_ARGS+= USE_IMLIB2=no
.endif
-.if !defined(WITHOUT_XFT)
+.if ${PORT_OPTIONS:MXFT}
USE_XORG+= xft
MAKE_ARGS+= USE_XFT=yes
.else
diff --git a/x11/mrxvt-devel/Makefile b/x11/mrxvt-devel/Makefile
index 90e1e7a53b43..0476c9efebe5 100644
--- a/x11/mrxvt-devel/Makefile
+++ b/x11/mrxvt-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mrxvt-devel
-# Date created: 24 Apr 2005
-# Whom: Lars Engels <lars.engels@0x20.net>
-#
+# Created by: Lars Engels <lars.engels@0x20.net>
# $FreeBSD$
-#
PORTNAME= mrxvt-devel
PORTVERSION= 0.5.4
@@ -28,19 +24,19 @@ DESKTOP_ENTRIES= "mrxvt" "mrxvt terminal emulator" \
"mrxvt" "Utility;TerminalEmulator;" \
false
-OPTIONS= XFT "Enable Xft support for fonts" Off \
- BACKGROUND "Enable background images" On\
- JPEG "Enable JPEG background images" On \
- PNG "Enable PNG background images" On \
- TRANSPARENCY "Enable transparency" On \
- SWAPSCREEN "Enable swapscreen" On \
- JAPANESE "Enable support for Japanese language" Off \
- 24BITS "Prefer 24 bits color" On \
- MENUBAR "Enable menubar" On \
- TEXTSHADOW "Enable text shadow" Off \
- FRILLS "Enable internal borders and smart resizing" Off
+OPTIONS_DEFINE= XFT BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN JAPANESE 24BITS \
+ MENUBAR TEXTSHADOW FRILLS DOCS EXAMPLES
+OPTIONS_DEFAULT= BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN 24BITS MENUBAR
+BACKGROUND_DESC= Background images
+TRANSPARENCY_DESC= transparency
+SWAPSCREEN_DESC= Swapscreen
+JAPANESE_DESC= Support for Japanese language
+24BITS_DESC= Prefer 24 bits color
+MENUBAR_DESC= Menubar
+TEXTSHADOW_DESC= Text shadow
+FRILLS_DESC= Internal borders and smart resizing
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CONFIGURE_ARGS+= --enable-utempter
.if ${OSVERSION} >= 900004
@@ -49,52 +45,52 @@ CONFIGURE_ARGS+= --disable-lastlog
LIB_DEPENDS+= utempter.0:${PORTSDIR}/sysutils/libutempter
.endif
-.if defined(WITH_JAPANESE)
+.if ${PORT_OPTIONS:MJAPANESE}
CONFIGURE_ARGS+= --enable-xim --enable-cjk --with-encoding=eucj
.endif
-.if defined(WITH_XFT)
+.if ${PORT_OPTIONS:MXFT}
USE_XORG+= xft
CONFIGURE_ARGS+= --enable-xft
.endif
-.if defined(WITH_24BITS)
+.if ${PORT_OPTIONS:M24BITS}
CONFIGURE_ARGS+= --enable-24bits
.endif
-.if defined(WITHOUT_BACKGROUND)
+.if ! ${PORT_OPTIONS:MBACKGROUND}
CONFIGURE_ARGS+= --disable-xpm
.endif
-.if defined(WITHOUT_JPEG) || defined(WITHOUT_BACKGROUND)
+.if ! ${PORT_OPTIONS:MJPEG} || ! ${PORT_OPTIONS:MBACKGROUND}
CONFIGURE_ARGS+= --disable-jpeg
.else
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
.endif
-.if defined(WITHOUT_PNG) || defined(WITHOUT_BACKGROUND)
+.if ! ${PORT_OPTIONS:MPNG} || ! ${PORT_OPTIONS:MBACKGROUND}
CONFIGURE_ARGS+= --disable-png
.else
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
.endif
-.if defined(WITHOUT_TRANSPARENCY)
+.if ! ${PORT_OPTIONS:MTRANSPARENCY}
CONFIGURE_ARGS+= --disable-transparency
.endif
-.if !defined(WITHOUT_MENUBAR)
+.if ${PORT_OPTIONS:MMENUBAR}
CONFIGURE_ARGS+= --enable-menubar
.endif
-.if defined(WITH_TEXTSHADOW)
+.if ${PORT_OPTIONS:MTEXTSHADOW}
CONFIGURE_ARGS+= --enable-text-shadow
.endif
-.if defined(WITHOUT_SWAPSCREEN)
+.if ! ${PORT_OPTIONS:MSWAPSCREEN}
CONFIGURE_ARGS+= --disable-swapscreen
.endif
-.if defined(WITH_FRILLS)
+.if ${PORT_OPTIONS:MFRILLS}
CONFIGURE_ARGS+= --enable-frills
.endif
@@ -135,16 +131,16 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/share/default.menu ${PREFIX}/etc/mrxvt/default.menu.sample
${INSTALL_DATA} ${WRKSRC}/share/submenus.menu ${PREFIX}/etc/mrxvt/submenus.menu.sample
${INSTALL_MAN} ${WRKSRC}/doc/mrxvt.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}/scripts
${INSTALL_DATA} ${WRKSRC}/share/scripts/mrxvtset.pl ${EXAMPLESDIR}/scripts
${INSTALL_DATA} ${WRKSRC}/share/scripts/settitle.c ${EXAMPLESDIR}/scripts
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${CP} ${WRKSRC}/doc/*.bz2 ${DOCSDIR}
${BZIP2_CMD} -d ${DOCSDIR}/*.bz2
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 9cf4e0d6ef57..1022e54211c1 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -32,11 +32,11 @@ CMAKE_ARGS= -DUSE_CONSOLEKIT=yes
MAN1= slim.1
-OPTIONS= PAM "Use pam" off
+OPTIONS_DEFINE= PAM
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PAM)
+.if ${PORT_OPTIONS:MPAM}
CMAKE_ARGS+= -DUSE_PAM=yes
PLIST_SUB+= PAM=""
.else
@@ -64,7 +64,7 @@ post-install:
@if [ ! -f ${PREFIX}/etc/slim.conf ]; then \
${CP} ${PREFIX}/etc/slim.conf.sample ${PREFIX}/etc/slim.conf ; \
fi
-. if defined(WITH_PAM)
+. if ${PORT_OPTIONS:MPAM}
@${INSTALL_DATA} ${FILESDIR}/pam.conf ${PREFIX}/etc/pam.d/slim.default
@if [ ! -f ${PREFIX}/etc/pam.d/slim ]; then \
${CP} ${PREFIX}/etc/pam.d/slim.default ${PREFIX}/etc/pam.d/slim ; \
@@ -72,4 +72,4 @@ post-install:
. endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index d635f6ca05d7..6f982cfd09c6 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: workrave
-# Date created: 15 Jul 2003
-# Whom: Koop Mast <einekoai@chello.nl>
-#
+# Created by: Koop Mast <einekoai@chello.nl>
# $FreeBSD$
-#
PORTNAME= workrave
PORTVERSION= 1.9.4
@@ -16,8 +12,8 @@ COMMENT= RSI prevention tool
BUILD_DEPENDS= gdome-config:${PORTSDIR}/textproc/gdome2
-OPTIONS= GNOME "Build with Gnome support" off \
- NETWORK "Build with network support" off
+OPTIONS_DEFINE= GNOME NETWORK NLS
+NETWORK_DESC= Build with network support
INSTALLS_ICONS= yes
DESKTOP_ENTRIES= "Workrave" "RSI prevention tool" \
@@ -27,19 +23,21 @@ DESKTOP_ENTRIES= "Workrave" "RSI prevention tool" \
false
USE_XORG= x11 xmu recordproto xtst xext
+USES= pathfix
+USE_PKGCONFIG= build
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gconf2 intltool
+USE_GNOME= gnomeprefix intlhack gconf2 intltool
USE_GSTREAMER= good
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-gconf --disable-pulse
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
-.if defined(WITH_GNOME)
+.if ${PORT_OPTIONS:MGNOME}
LIB_DEPENDS+= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26
USE_GNOME+= gnomepanel
PLIST_SUB+= GNOME=""
@@ -49,13 +47,13 @@ CONFIGURE_ARGS+=--disable-gnome
PLIST_SUB+= GNOME="@comment "
.endif
-.if defined(WITH_NETWORK)
+.if ${PORT_OPTIONS:MNETWORK}
LIB_DEPENDS+= gnet-2.0.0:${PORTSDIR}/net/gnet2
.else
CONFIGURE_ARGS+=--disable-distribution
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -63,4 +61,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>