aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-05 00:59:57 +0800
committerpawel <pawel@FreeBSD.org>2014-04-05 00:59:57 +0800
commit5c6f17e2f611e21ec383c7ac8d3d9a109f1a48c5 (patch)
tree6ed5cce868ede1e9473f76c4bb90b2c38c2f1d9c
parent87156a8c466370efd4ad992c778a92e907638bd3 (diff)
downloadfreebsd-ports-gnome-5c6f17e2f611e21ec383c7ac8d3d9a109f1a48c5.tar.gz
freebsd-ports-gnome-5c6f17e2f611e21ec383c7ac8d3d9a109f1a48c5.tar.zst
freebsd-ports-gnome-5c6f17e2f611e21ec383c7ac8d3d9a109f1a48c5.zip
Add staging support
-rw-r--r--dns/ez-ipupdate/Makefile10
-rw-r--r--dns/ez-ipupdate/pkg-plist22
2 files changed, 14 insertions, 18 deletions
diff --git a/dns/ez-ipupdate/Makefile b/dns/ez-ipupdate/Makefile
index b65705263631..51392cc9150d 100644
--- a/dns/ez-ipupdate/Makefile
+++ b/dns/ez-ipupdate/Makefile
@@ -15,14 +15,10 @@ COMMENT= Update your host name on any dynamic DNS service
USE_RC_SUBR= ez-ipupdate
GNU_CONFIGURE= yes
-NO_STAGE= yes
post-install:
- ${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
- for f in ${WRKSRC}/example-*.conf; \
- do \
- ${INSTALL_DATA} $$f ${PREFIX}/share/examples/${PORTNAME}/; \
- done
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} example-*.conf ${STAGEDIR}${EXAMPLESDIR})
${INSTALL_DATA} ${WRKSRC}/example.conf \
- ${PREFIX}/etc/${PORTNAME}.conf.sample
+ ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
.include <bsd.port.mk>
diff --git a/dns/ez-ipupdate/pkg-plist b/dns/ez-ipupdate/pkg-plist
index 218cc8411137..128e34c24a8a 100644
--- a/dns/ez-ipupdate/pkg-plist
+++ b/dns/ez-ipupdate/pkg-plist
@@ -1,13 +1,13 @@
bin/ez-ipupdate
etc/ez-ipupdate.conf.sample
-share/examples/ez-ipupdate/example-dhs.conf
-share/examples/ez-ipupdate/example-dyndns.conf
-share/examples/ez-ipupdate/example-dyns.conf
-share/examples/ez-ipupdate/example-easydns.conf
-share/examples/ez-ipupdate/example-gnudip.conf
-share/examples/ez-ipupdate/example-heipv6tb.conf
-share/examples/ez-ipupdate/example-justlinux.conf
-share/examples/ez-ipupdate/example-ods.conf
-share/examples/ez-ipupdate/example-pgpow.conf
-share/examples/ez-ipupdate/example-tzo.conf
-@dirrm share/examples/ez-ipupdate
+%%EXAMPLESDIR%%/example-dhs.conf
+%%EXAMPLESDIR%%/example-dyndns.conf
+%%EXAMPLESDIR%%/example-dyns.conf
+%%EXAMPLESDIR%%/example-easydns.conf
+%%EXAMPLESDIR%%/example-gnudip.conf
+%%EXAMPLESDIR%%/example-heipv6tb.conf
+%%EXAMPLESDIR%%/example-justlinux.conf
+%%EXAMPLESDIR%%/example-ods.conf
+%%EXAMPLESDIR%%/example-pgpow.conf
+%%EXAMPLESDIR%%/example-tzo.conf
+@dirrm %%EXAMPLESDIR%%