aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-02-19 06:11:27 +0800
committermarino <marino@FreeBSD.org>2016-02-19 06:11:27 +0800
commit62309014cd2637adfcb5b2e82eb182a23d1e2b83 (patch)
treeb3ec4c3ea657a8cea9044ebcb565de968733e5d6
parentd68fef0f74f727d8fb03f4d4721617a3415cf304 (diff)
downloadfreebsd-ports-gnome-62309014cd2637adfcb5b2e82eb182a23d1e2b83.tar.gz
freebsd-ports-gnome-62309014cd2637adfcb5b2e82eb182a23d1e2b83.tar.zst
freebsd-ports-gnome-62309014cd2637adfcb5b2e82eb182a23d1e2b83.zip
lang/gcc6-aux: re-enable the -march filter
It did not take long for gcc6-aux to fail again when CPUTYPE is set (this time to native). Just block this settings by filtering out -march CFLAGS again to solve the issue permanently. PR: 207311
-rw-r--r--lang/gcc6-aux/Makefile.common1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/gcc6-aux/Makefile.common b/lang/gcc6-aux/Makefile.common
index 4f24cc2b0b03..64fff293ea61 100644
--- a/lang/gcc6-aux/Makefile.common
+++ b/lang/gcc6-aux/Makefile.common
@@ -12,3 +12,4 @@ GNU_CONFIGURE= yes
USES= gmake libtool perl5 tar:bzip2
USE_PERL5= build
ALL_TARGET= default
+CFLAGS:= ${CFLAGS:N-march=*}