aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-02-20 00:20:42 +0800
committermat <mat@FreeBSD.org>2018-02-20 00:20:42 +0800
commit649d780af05fa5621a29ffcc3e7958501d508a54 (patch)
treef8a3be0074b269ddac8b288c7cac4f12a044a6f7
parent1a89db0493d7b55889b2bf1bff143a6c3bd2937c (diff)
downloadfreebsd-ports-gnome-649d780af05fa5621a29ffcc3e7958501d508a54.tar.gz
freebsd-ports-gnome-649d780af05fa5621a29ffcc3e7958501d508a54.tar.zst
freebsd-ports-gnome-649d780af05fa5621a29ffcc3e7958501d508a54.zip
Don't abuse opt_VARS to add to USES.
Sponsored by: Absolight
-rw-r--r--databases/sqlitestudio/Makefile3
-rw-r--r--net-im/toxic/Makefile2
-rw-r--r--security/pam-modules/Makefile3
3 files changed, 5 insertions, 3 deletions
diff --git a/databases/sqlitestudio/Makefile b/databases/sqlitestudio/Makefile
index 0c8aa22d5f1b..28b99178a65b 100644
--- a/databases/sqlitestudio/Makefile
+++ b/databases/sqlitestudio/Makefile
@@ -59,7 +59,8 @@ post-patch:
PLUGIN_DIRS=
PLUGIN_CSV_IMPORT_VARS= PLUGIN_DIRS+=CsvImport
PLUGIN_CSV_EXPORT_VARS= PLUGIN_DIRS+=CsvExport
-PLUGIN_DB_SQLITE_CIPHER_VARS= PLUGIN_DIRS+=DbSqliteCipher USES+=ssl
+PLUGIN_DB_SQLITE_CIPHER_USES= ssl
+PLUGIN_DB_SQLITE_CIPHER_VARS= PLUGIN_DIRS+=DbSqliteCipher
PLUGIN_HTML_EXPORT_VARS= PLUGIN_DIRS+=HtmlExport
PLUGIN_JSON_EXPORT_VARS= PLUGIN_DIRS+=JsonExport
PLUGIN_PDF_EXPORT_VARS= PLUGIN_DIRS+=PdfExport
diff --git a/net-im/toxic/Makefile b/net-im/toxic/Makefile
index f50c233b088c..d9a9b1a5f1cf 100644
--- a/net-im/toxic/Makefile
+++ b/net-im/toxic/Makefile
@@ -35,7 +35,7 @@ X11_USE= GNOME=gdkpixbuf2,glib20 XORG=x11
X11_MAKE_ARGS_OFF= DISABLE_X11=1 DISABLE_DESKTOP_NOTIFY=1
X11_LIB_DEPENDS=libnotify.so:devel/libnotify
-PYTHON_VARS= USES+=python:3.3+
+PYTHON_USES= python:3.3+
PYTHON_MAKE_ARGS= ENABLE_PYTHON=1
MAKE_ENV= USER_CFLAGS="${CFLAGS}" USER_LDFLAGS="${LDFLAGS}"
diff --git a/security/pam-modules/Makefile b/security/pam-modules/Makefile
index 48e9cbb5ad30..9e61510ccc64 100644
--- a/security/pam-modules/Makefile
+++ b/security/pam-modules/Makefile
@@ -31,7 +31,8 @@ MYSQL_USE= MYSQL
PGSQL_CONFIGURE_ENABLE= pgsql
PGSQL_DESC= Build pam_pgsql
-PGSQL_VARS= USES+=pgsql WANT_PGSQL=client
+PGSQL_USES= pgsql
+PGSQL_VARS= WANT_PGSQL=client
SYSLOG_CONFIGURE_ENABLE= log
SYSLOG_DESC= Build pam_log