aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2012-06-05 09:59:27 +0800
committerobrien <obrien@FreeBSD.org>2012-06-05 09:59:27 +0800
commit64b5e25e711f007563bec2925207688c5b8ad0a0 (patch)
tree30b44ea27a0ba93a52af64523ff26105ef64d795
parenteed9e8e4e87a2b6e2695072614d3ba0daada8c25 (diff)
downloadfreebsd-ports-gnome-64b5e25e711f007563bec2925207688c5b8ad0a0.tar.gz
freebsd-ports-gnome-64b5e25e711f007563bec2925207688c5b8ad0a0.tar.zst
freebsd-ports-gnome-64b5e25e711f007563bec2925207688c5b8ad0a0.zip
Fix bug for add_glob:
Do not stop scanning if we see '$' as it does more harm than good. For $HOME/tm we should return $HOME/tm* Set license to BSD (not "public domain" due to sigact.[ch]). Submitted by: Simon Gerraty <sjg@juniper.net> Obtained from: NetBSD Approved by: skreuzer
-rw-r--r--shells/pdksh/Makefile3
-rw-r--r--shells/pdksh/files/patch-edit.c9
2 files changed, 11 insertions, 1 deletions
diff --git a/shells/pdksh/Makefile b/shells/pdksh/Makefile
index ad8dea47737a..71b513d0da00 100644
--- a/shells/pdksh/Makefile
+++ b/shells/pdksh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdksh
PORTVERSION= 5.2.14p2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= shells
MASTER_SITES= http://gd.tuwien.ac.at/utils/shells/pdksh/ \
ftp://ftp.lip6.fr/pub/unix/shells/pdksh/ \
@@ -20,6 +20,7 @@ PATCH_DIST_STRIP= -p2
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= The Public Domain Korn Shell
+LICENSE= BSD
GNU_CONFIGURE= yes
MAN1= ksh.1
diff --git a/shells/pdksh/files/patch-edit.c b/shells/pdksh/files/patch-edit.c
index e4f7b6ecbcc7..b79060e68254 100644
--- a/shells/pdksh/files/patch-edit.c
+++ b/shells/pdksh/files/patch-edit.c
@@ -8,3 +8,12 @@
cp += 2;
}
+@@ -847,7 +847,7 @@ add_glob(str, slen)
+ for (s = toglob; *s; s++) {
+ if (*s == '\\' && s[1])
+ s++;
+- else if (*s == '*' || *s == '[' || *s == '?' || *s == '$'
++ else if (*s == '*' || *s == '[' || *s == '?'
+ || (s[1] == '(' /*)*/ && strchr("*+?@!", *s)))
+ break;
+ else if (ISDIRSEP(*s))