aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-03-21 08:13:07 +0800
committerjgh <jgh@FreeBSD.org>2013-03-21 08:13:07 +0800
commit66cd582b3611ed17a82fbd940d564bf65a6d55da (patch)
treec66c89b0b610e220c03eea1f5f7b1a23cb924edc
parentf5a32588cfef766eba0ecae6d43a4c7c0f7a23c1 (diff)
downloadfreebsd-ports-gnome-66cd582b3611ed17a82fbd940d564bf65a6d55da.tar.gz
freebsd-ports-gnome-66cd582b3611ed17a82fbd940d564bf65a6d55da.tar.zst
freebsd-ports-gnome-66cd582b3611ed17a82fbd940d564bf65a6d55da.zip
- adopt optionsNG
Approved by: portmgr (miwi)
-rw-r--r--textproc/nux/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/textproc/nux/Makefile b/textproc/nux/Makefile
index 0f000a952f18..16db657f99ed 100644
--- a/textproc/nux/Makefile
+++ b/textproc/nux/Makefile
@@ -14,7 +14,9 @@ COMMENT= Small open-source XQuery extension of the XOM library
RUN_DEPENDS= ${JAVALIBDIR}/xom.jar:${PORTSDIR}/textproc/xom \
${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel
-OPTIONS= XQUERY_TOOL "Install the XQuery command-line tool" on
+OPTIONS_DEFINE= XQUERY_TOOL DOCS
+XQUERY_TOOL_DESC= Install the XQuery command-line tool
+OPTIONS_DEFAULT= XQUERY_TOOL
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -22,23 +24,23 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_XQUERY_TOOL)
+.if ${PORT_OPTIONS:MXQUERY_TOOL}
RUN_DEPENDS+= ${JAVALIBDIR}/getopt.jar:${PORTSDIR}/java/java-getopt \
classpath:${PORTSDIR}/java/javavmwrapper
.endif
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
-.if defined(WITH_XQUERY_TOOL)
+.if ${PORT_OPTIONS:MXQUERY_TOOL}
PLIST_FILES+= bin/fire-xquery
.endif
-.if !defined(NOPORTDOCS)
+
PORTDOCS= api changelog.html cvs.html dependencies.html \
gettingstarted.html images index.html license.html licenses \
mailing.html readme.html related.html style.css todo.html
-.endif
-.if defined(WITH_XQUERY_TOOL)
+.if ${PORT_OPTIONS:MXQUERY_TOOL}
SUB_FILES= fire-xquery.sh
.endif
@@ -47,12 +49,12 @@ do-install:
@${MKDIR} ${JAVAJARDIR}
@${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${JAVAJARDIR}/
@${ECHO_MSG} " [ DONE ]"
-.if defined(WITH_XQUERY_TOOL)
+.if ${PORT_OPTIONS:MXQUERY_TOOL}
@${ECHO_MSG} -n ">> Installing XQuery command-line tool as ${PREFIX}/bin/fire-xquery..."
@${INSTALL_SCRIPT} ${WRKDIR}/fire-xquery.sh ${PREFIX}/bin/fire-xquery
@${ECHO_MSG} " [ DONE ]"
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
@cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;