aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-07-04 02:42:54 +0800
committerzi <zi@FreeBSD.org>2013-07-04 02:42:54 +0800
commit6753497c5e366ea48f086a04b6d7b9cdd1711857 (patch)
tree71d2f0dd9f871bd50c6e5a98437f7c928f354635
parent56572b3d26b48b10203643cd93d1eecba21466ce (diff)
downloadfreebsd-ports-gnome-6753497c5e366ea48f086a04b6d7b9cdd1711857.tar.gz
freebsd-ports-gnome-6753497c5e366ea48f086a04b6d7b9cdd1711857.tar.zst
freebsd-ports-gnome-6753497c5e366ea48f086a04b6d7b9cdd1711857.zip
New port: devel/p5-JSON-Path:
search nested hashref/arrayref structures using JSONPath WWW: http://search.cpan.org/dist/JSON-Path/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-JSON-Path/Makefile25
-rw-r--r--devel/p5-JSON-Path/distinfo2
-rw-r--r--devel/p5-JSON-Path/files/patch-META.yml11
-rw-r--r--devel/p5-JSON-Path/files/patch-lib__JSON__Path.pm11
-rw-r--r--devel/p5-JSON-Path/pkg-descr3
-rw-r--r--devel/p5-JSON-Path/pkg-plist7
7 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a98e497d29fd..713a33391516 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2172,6 +2172,7 @@
SUBDIR += p5-Iterator-Util
SUBDIR += p5-JIRA-Client
SUBDIR += p5-JQuery
+ SUBDIR += p5-JSON-Path
SUBDIR += p5-JSON-RPC
SUBDIR += p5-JSON-RPC-Common
SUBDIR += p5-JSON-RPC-Dispatcher
diff --git a/devel/p5-JSON-Path/Makefile b/devel/p5-JSON-Path/Makefile
new file mode 100644
index 000000000000..172a4e7975e5
--- /dev/null
+++ b/devel/p5-JSON-Path/Makefile
@@ -0,0 +1,25 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= JSON-Path
+PORTVERSION= 0.204
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Search nested hashref/arrayref structures using JSONPath
+
+BUILD_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Lvalue>=0:${PORTSDIR}/devel/p5-Lvalue
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= JSON::Path.3
+
+post-patch::
+ @${RM} ${WRKSRC}/lib/JSON/Path.pm.orig
+
+.include <bsd.port.mk>
diff --git a/devel/p5-JSON-Path/distinfo b/devel/p5-JSON-Path/distinfo
new file mode 100644
index 000000000000..a3f4e8e3166e
--- /dev/null
+++ b/devel/p5-JSON-Path/distinfo
@@ -0,0 +1,2 @@
+SHA256 (JSON-Path-0.204.tar.gz) = 0682ffc812e3da608296a9b87fef2da28319a9db324ad172e3994555ca4e5e02
+SIZE (JSON-Path-0.204.tar.gz) = 51190
diff --git a/devel/p5-JSON-Path/files/patch-META.yml b/devel/p5-JSON-Path/files/patch-META.yml
new file mode 100644
index 000000000000..645ebae268a6
--- /dev/null
+++ b/devel/p5-JSON-Path/files/patch-META.yml
@@ -0,0 +1,11 @@
+--- ./META.yml.orig 2013-07-03 13:30:22.000000000 -0400
++++ ./META.yml 2013-07-03 13:30:54.000000000 -0400
+@@ -26,7 +26,7 @@
+ requires:
+ JSON: 2.00
+ Sub::Exporter: 0
+- lvalue: 0
++ Lvalue: 0
+ perl: 5.8.0
+ resources:
+ bugtracker: http://rt.cpan.org/Dist/Display.html?Queue=JSON-Path
diff --git a/devel/p5-JSON-Path/files/patch-lib__JSON__Path.pm b/devel/p5-JSON-Path/files/patch-lib__JSON__Path.pm
new file mode 100644
index 000000000000..212429b8b28f
--- /dev/null
+++ b/devel/p5-JSON-Path/files/patch-lib__JSON__Path.pm
@@ -0,0 +1,11 @@
+--- ./lib/JSON/Path.pm.orig 2013-07-03 13:31:32.000000000 -0400
++++ ./lib/JSON/Path.pm 2013-07-03 13:31:52.000000000 -0400
+@@ -12,7 +12,7 @@
+ use Carp;
+ use JSON qw[from_json];
+ use Scalar::Util qw[blessed];
+-use lvalue ();
++use Lvalue qw/lvalue/;
+
+ use Sub::Exporter -setup => {
+ exports => [qw/ jpath jpath1 jpath_map /],
diff --git a/devel/p5-JSON-Path/pkg-descr b/devel/p5-JSON-Path/pkg-descr
new file mode 100644
index 000000000000..b96aca7c772a
--- /dev/null
+++ b/devel/p5-JSON-Path/pkg-descr
@@ -0,0 +1,3 @@
+search nested hashref/arrayref structures using JSONPath
+
+WWW: http://search.cpan.org/dist/JSON-Path/
diff --git a/devel/p5-JSON-Path/pkg-plist b/devel/p5-JSON-Path/pkg-plist
new file mode 100644
index 000000000000..b3538d017c77
--- /dev/null
+++ b/devel/p5-JSON-Path/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/JSON/Path.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Path/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/Path
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/JSON
+@dirrmtry %%SITE_PERL%%/JSON