aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-10-08 04:27:29 +0800
committermarino <marino@FreeBSD.org>2014-10-08 04:27:29 +0800
commit6771a5942f84b45c90cdc7abc829027983b91113 (patch)
tree58a861a55e3d8319e94617afe1128d1f8f5b67e8
parent0aed8ed3fee1eda0f590e8988fc252bec137d439 (diff)
downloadfreebsd-ports-gnome-6771a5942f84b45c90cdc7abc829027983b91113.tar.gz
freebsd-ports-gnome-6771a5942f84b45c90cdc7abc829027983b91113.tar.zst
freebsd-ports-gnome-6771a5942f84b45c90cdc7abc829027983b91113.zip
emulators/hyperv-is: Use kmod, support non-default prefix
USES= kmod correctly installs the kernel modules at /boot/modules instead of /boot/kernel. Also use the post-install target to support prefixes other than /usr/local. Suggested by: bapt and bdrewery
-rw-r--r--emulators/hyperv-is/Makefile14
-rw-r--r--emulators/hyperv-is/pkg-plist14
2 files changed, 15 insertions, 13 deletions
diff --git a/emulators/hyperv-is/Makefile b/emulators/hyperv-is/Makefile
index 632182156998..cf4278c4de16 100644
--- a/emulators/hyperv-is/Makefile
+++ b/emulators/hyperv-is/Makefile
@@ -2,8 +2,8 @@
PORTNAME= hyperv-is
PORTVERSION= 1.1
-PORTREVISION= 1
-CATEGORIES= emulators kld
+PORTREVISION= 2
+CATEGORIES= emulators
MASTER_SITES= https://github.com/${MSLINK}/
DISTNAME= ${DNAME}
@@ -12,7 +12,7 @@ COMMENT= FreeBSD Integration Service on Hyper-v
ONLY_FOR_ARCHS= amd64 i386
-USES+= uidfix
+USES= kmod uidfix
BIS= ${PORTVERSION}
MSBASE= FreeBSDonHyper-V/Hyperv-Ports/raw/hyperv-is-master
MSLINK= ${MSBASE}/BIS-${BIS}/FreeBSD-${OSREL}/ports
@@ -44,7 +44,7 @@ FILE_100= hv-kvp-${BIS}
DNAME= ${FILE_${OSREL:S/.//}}
.if empty(DNAME)
-IGNORE= OSREL ${OSREL} not supported
+IGNORE?= OSREL ${OSREL} not supported
.endif
post-patch:
@@ -52,13 +52,15 @@ post-patch:
${WRKSRC}/etc/rc.d/hv_kvpd
pre-install:
- @${MKDIR} ${STAGEDIR}/boot/kernel \
+ @${MKDIR} ${STAGEDIR}${PREFIX} \
${STAGEDIR}/etc/rc.d \
${STAGEDIR}/usr/local/hyperv/scripts
post-install:
${RM} ${STAGEDIR}/boot/kernel/linker.hints
${MV} ${STAGEDIR}/etc/rc.d/* ${STAGEDIR}${PREFIX}/etc/rc.d
-
+.if ${PREFIX} != /usr/local
+ ${MV} ${STAGEDIR}/usr/local/* ${STAGEDIR}${PREFIX}
+.endif
.include <bsd.port.post.mk>
diff --git a/emulators/hyperv-is/pkg-plist b/emulators/hyperv-is/pkg-plist
index 8f2620c416a7..4a52178b58af 100644
--- a/emulators/hyperv-is/pkg-plist
+++ b/emulators/hyperv-is/pkg-plist
@@ -1,15 +1,15 @@
hyperv/scripts/hv_get_dhcp_info
hyperv/scripts/hv_get_dns_info
hyperv/scripts/hv_set_ifconfig
-%%A%%/boot/kernel/hv_ata_pci_disengage.ko
-%%A%%/boot/kernel/hv_netvsc.ko
-%%A%%/boot/kernel/hv_storvsc.ko
-%%A%%/boot/kernel/hv_utils.ko
-%%A%%/boot/kernel/hv_vmbus.ko
-%%B%%/boot/kernel/hv_kvp.ko
+%%A%%/boot/modules/hv_ata_pci_disengage.ko
+%%A%%/boot/modules/hv_netvsc.ko
+%%A%%/boot/modules/hv_storvsc.ko
+%%A%%/boot/modules/hv_utils.ko
+%%A%%/boot/modules/hv_vmbus.ko
+%%B%%/boot/modules/hv_kvp.ko
etc/rc.d/hv_kvpd
-%%A%%man/man1/hyperv-is.1.gz
%%B%%sbin/hv_kvp_daemon
+%%A%%man/man1/hyperv-is.1.gz
%%A%%man/man4/hv_ata_pci_disengage.4.gz
man/man4/hv_kvp.4.gz
%%A%%man/man4/hv_netvsc.4.gz