aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-08-02 00:58:58 +0800
committerrakuco <rakuco@FreeBSD.org>2017-08-02 00:58:58 +0800
commit6ae3ea3927cc07d3dbe6de5ddb25a8acb62ab303 (patch)
tree4dae2a380e4cf2ce7e9c0d901e2d75d50bc91fa7
parent03e3cd0c327e82331ab9a03610d1a3435f1ab3ea (diff)
downloadfreebsd-ports-gnome-6ae3ea3927cc07d3dbe6de5ddb25a8acb62ab303.tar.gz
freebsd-ports-gnome-6ae3ea3927cc07d3dbe6de5ddb25a8acb62ab303.tar.zst
freebsd-ports-gnome-6ae3ea3927cc07d3dbe6de5ddb25a8acb62ab303.zip
Explicitly build with -std=gnu++03.
The port fails to build with C++11 and later. GCC 6 uses -std=gnu++14 by default, and fails like this: xmlParser.cpp: In function 'char* stringDup(const char*, int)': xmlParser.cpp:464:36: error: cast from 'std::nullptr_t' to 'char' loses precision [-fpermissive] lpszNew[cbData] = (XMLCHAR)NULL; Since this version of animorph is from 2007 and the code has completely changed upstream (it does not even use C++ anymore), there is little point in fixing the code instead of just making it build like it did before. PR: 219279 Approved by: portmgr (blanket approval)
-rw-r--r--graphics/animorph/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/animorph/Makefile b/graphics/animorph/Makefile
index 0f0ae73a2e48..3f42af44fefc 100644
--- a/graphics/animorph/Makefile
+++ b/graphics/animorph/Makefile
@@ -17,6 +17,7 @@ USES= pkgconfig gmake libtool
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
USE_GCC= any # otherwise graphics/makehuman won't link
+USE_CXXSTD= gnu++03 # The port is not compatible with C++11 and later.
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib