aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-01-15 10:52:30 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-01-15 10:52:30 +0800
commit6cf694faf29d23693d7d7879dcc9cd25a1014923 (patch)
tree9e92dddfee421d3027a7b022e33f8bb311fad329
parente343370a81a96804cfb38786a3f356de0579c713 (diff)
downloadfreebsd-ports-gnome-6cf694faf29d23693d7d7879dcc9cd25a1014923.tar.gz
freebsd-ports-gnome-6cf694faf29d23693d7d7879dcc9cd25a1014923.tar.zst
freebsd-ports-gnome-6cf694faf29d23693d7d7879dcc9cd25a1014923.zip
- Upgrade to 1.8.1.
-rw-r--r--lang/phantomjs/Makefile2
-rw-r--r--lang/phantomjs/distinfo4
-rw-r--r--lang/phantomjs/files/patch-build.sh30
3 files changed, 26 insertions, 10 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index c16ed536f616..065d162651df 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= phantomjs
-PORTVERSION= 1.7.0
+PORTVERSION= 1.8.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
diff --git a/lang/phantomjs/distinfo b/lang/phantomjs/distinfo
index 1579e7854c3b..2d80ec10cda5 100644
--- a/lang/phantomjs/distinfo
+++ b/lang/phantomjs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (phantomjs-1.7.0-source.zip) = 10d595aa8e637c29b491563f8af4333b30266e0cba36277000a560a7f6e53bff
-SIZE (phantomjs-1.7.0-source.zip) = 39573102
+SHA256 (phantomjs-1.8.1-source.zip) = 16e10bd9cde1bd7a6edbeeaa88ee0e91c4f60b236e541676a5328611df4bfa6a
+SIZE (phantomjs-1.8.1-source.zip) = 40626032
diff --git a/lang/phantomjs/files/patch-build.sh b/lang/phantomjs/files/patch-build.sh
index d32247cfd0c2..037058fad7c1 100644
--- a/lang/phantomjs/files/patch-build.sh
+++ b/lang/phantomjs/files/patch-build.sh
@@ -1,18 +1,15 @@
$FreeBSD$
---- build.sh.orig 2012-07-30 01:56:37.113285721 +0900
-+++ build.sh 2012-07-30 06:42:31.502288222 +0900
-@@ -7,27 +7,27 @@
+--- build.sh.orig 2013-01-15 07:48:35.556438142 +0900
++++ build.sh 2013-01-15 07:50:27.581439602 +0900
+@@ -8,27 +8,27 @@
COMPILE_JOBS=1
MAKEFLAGS_JOBS=''
-if [[ "$MAKEFLAGS" != "" ]]; then
- MAKEFLAGS_JOBS=$(echo $MAKEFLAGS | egrep -o '\-j[0-9]+' | egrep -o '[0-9]+')
-fi
-+#if [[ "$MAKEFLAGS" != "" ]]; then
-+# MAKEFLAGS_JOBS=$(echo $MAKEFLAGS | egrep -o '\-j[0-9]+' | egrep -o '[0-9]+')
-+#fi
-
+-
-if [[ "$MAKEFLAGS_JOBS" != "" ]]; then
- # user defined number of jobs in MAKEFLAGS, re-use that number
- COMPILE_JOBS=$MAKEFLAGS_JOBS
@@ -30,6 +27,10 @@ $FreeBSD$
- fi
- fi
-fi
++#if [[ "$MAKEFLAGS" != "" ]]; then
++# MAKEFLAGS_JOBS=$(echo $MAKEFLAGS | egrep -o '\-j[0-9]+' | egrep -o '[0-9]+')
++#fi
++
+#if [[ "$MAKEFLAGS_JOBS" != "" ]]; then
+# # user defined number of jobs in MAKEFLAGS, re-use that number
+# COMPILE_JOBS=$MAKEFLAGS_JOBS
@@ -50,3 +51,18 @@ $FreeBSD$
until [ -z "$1" ]; do
case $1 in
+@@ -78,10 +78,10 @@
+ EOF
+
+ echo "Do you want to continue (y/n)?"
+- read continue
+- if [[ "$continue" != "y" ]]; then
+- exit 1
+- fi
++# read continue
++# if [[ "$continue" != "y" ]]; then
++# exit 1
++# fi
+ echo
+ echo
+ fi