aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2003-05-18 19:38:49 +0800
committerse <se@FreeBSD.org>2003-05-18 19:38:49 +0800
commit6cf6fe6cff13085afdaa3c9ad52e8563e6558677 (patch)
tree75bbe51cec5ee9bf581f0b9bb7795346f59dd44e
parentf6b9980e7f9f6f861a6b0aaf1dded730cb5b4fa5 (diff)
downloadfreebsd-ports-gnome-6cf6fe6cff13085afdaa3c9ad52e8563e6558677.tar.gz
freebsd-ports-gnome-6cf6fe6cff13085afdaa3c9ad52e8563e6558677.tar.zst
freebsd-ports-gnome-6cf6fe6cff13085afdaa3c9ad52e8563e6558677.zip
Fix build on 5.1 (remove port's conflicting definition of float_t)
-rw-r--r--games/acm/Makefile4
-rw-r--r--games/acm/files/patch-0812
2 files changed, 12 insertions, 4 deletions
diff --git a/games/acm/Makefile b/games/acm/Makefile
index be838f5bece4..9d40ee72dcc7 100644
--- a/games/acm/Makefile
+++ b/games/acm/Makefile
@@ -19,10 +19,6 @@ MAN6= acm.6
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
# Include sound support (Use network audio server (nas))
.if defined(WITH_SOUND) || (exists(${PREFIX}/lib/libaudio.a) \
&& !defined(WITHOUT_SOUND))
diff --git a/games/acm/files/patch-08 b/games/acm/files/patch-08
new file mode 100644
index 000000000000..3bc28a5b5a69
--- /dev/null
+++ b/games/acm/files/patch-08
@@ -0,0 +1,12 @@
+--- src/interpolate.h~ Tue May 12 05:43:04 1998
++++ src/interpolate.h Sun May 18 13:25:35 2003
+@@ -31,7 +31,9 @@
+
+ #include <math.h>
+
++#ifndef __FreeBSD__
+ typedef float float_t;
++#endif
+
+ typedef struct {
+ float_t x; /* upper x value for this interval */