aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-04-03 21:38:55 +0800
committertobez <tobez@FreeBSD.org>2007-04-03 21:38:55 +0800
commit730f1a0ad8f309b51ace567410c201a5176eb23a (patch)
tree68eb2e121f0a3e4cb6537390ab567fba51d1baf8
parentaa93915e1210742c1b6abfe9c249fa8b9a1d7772 (diff)
downloadfreebsd-ports-gnome-730f1a0ad8f309b51ace567410c201a5176eb23a.tar.gz
freebsd-ports-gnome-730f1a0ad8f309b51ace567410c201a5176eb23a.tar.zst
freebsd-ports-gnome-730f1a0ad8f309b51ace567410c201a5176eb23a.zip
Add devel/p5-Algorithm-IncludeExclude 0.01, a Perl module to build and
evaluate include/exclude lists.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Algorithm-IncludeExclude/Makefile25
-rw-r--r--devel/p5-Algorithm-IncludeExclude/distinfo3
-rw-r--r--devel/p5-Algorithm-IncludeExclude/pkg-descr4
-rw-r--r--devel/p5-Algorithm-IncludeExclude/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b7b69dd422c3..b40e092a98a2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -815,6 +815,7 @@
SUBDIR += p5-Algorithm-Dependency-Objects
SUBDIR += p5-Algorithm-Diff
SUBDIR += p5-Algorithm-Evolutionary
+ SUBDIR += p5-Algorithm-IncludeExclude
SUBDIR += p5-Algorithm-Interval2Prefix
SUBDIR += p5-Algorithm-LCS
SUBDIR += p5-Algorithm-LUHN
diff --git a/devel/p5-Algorithm-IncludeExclude/Makefile b/devel/p5-Algorithm-IncludeExclude/Makefile
new file mode 100644
index 000000000000..5c18d885521f
--- /dev/null
+++ b/devel/p5-Algorithm-IncludeExclude/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Algorithm-IncludeExclude
+# Date created: 03 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-IncludeExclude
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Build and evaluate include/exclude lists
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::IncludeExclude.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-IncludeExclude/distinfo b/devel/p5-Algorithm-IncludeExclude/distinfo
new file mode 100644
index 000000000000..0b113fe843a9
--- /dev/null
+++ b/devel/p5-Algorithm-IncludeExclude/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-IncludeExclude-0.01.tar.gz) = d8a1f06a5e5ac39db1a5e8750157c270
+SHA256 (Algorithm-IncludeExclude-0.01.tar.gz) = e4ad04dc22049d29a119160e067c9b5e91765624c8f189a312cff1b87414a20d
+SIZE (Algorithm-IncludeExclude-0.01.tar.gz) = 21596
diff --git a/devel/p5-Algorithm-IncludeExclude/pkg-descr b/devel/p5-Algorithm-IncludeExclude/pkg-descr
new file mode 100644
index 000000000000..2fb5d31d488b
--- /dev/null
+++ b/devel/p5-Algorithm-IncludeExclude/pkg-descr
@@ -0,0 +1,4 @@
+Algorithm::IncludeExclude lets you define a tree of include / exclude
+rules and then allows you to determine the best rule for a given path.
+
+WWW: http://search.cpan.org/dist/Algorithm-IncludeExclude/
diff --git a/devel/p5-Algorithm-IncludeExclude/pkg-plist b/devel/p5-Algorithm-IncludeExclude/pkg-plist
new file mode 100644
index 000000000000..2bc8c190d3af
--- /dev/null
+++ b/devel/p5-Algorithm-IncludeExclude/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Algorithm/IncludeExclude.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/IncludeExclude/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/IncludeExclude
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
+@dirrmtry %%SITE_PERL%%/Algorithm