aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-05-15 22:08:38 +0800
committerdanfe <danfe@FreeBSD.org>2005-05-15 22:08:38 +0800
commit7346b6b8135ed6ca968352154469f6b7f3b9e3bd (patch)
treef28a50484758d7b6965b6bd3510c8f6ae77e5ae7
parentdcd0bbf8066a8dcc105355b2fda3b5c1fe4f7e94 (diff)
downloadfreebsd-ports-gnome-7346b6b8135ed6ca968352154469f6b7f3b9e3bd.tar.gz
freebsd-ports-gnome-7346b6b8135ed6ca968352154469f6b7f3b9e3bd.tar.zst
freebsd-ports-gnome-7346b6b8135ed6ca968352154469f6b7f3b9e3bd.zip
Add SoundTouch 1.3.0, an open-source audio processing library for changing
the Tempo, Pitch and Playback Rates of audio streams or files. WWW: http://sky.prohosting.com/oparviai/soundtouch/
-rw-r--r--audio/Makefile1
-rw-r--r--audio/soundtouch/Makefile34
-rw-r--r--audio/soundtouch/distinfo2
-rw-r--r--audio/soundtouch/pkg-descr17
-rw-r--r--audio/soundtouch/pkg-plist15
5 files changed, 69 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ae38136b0960..ee0a43ac865e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -421,6 +421,7 @@
SUBDIR += sonice
SUBDIR += sound-juicer
SUBDIR += soundgrab
+ SUBDIR += soundtouch
SUBDIR += soundtracker
SUBDIR += sox
SUBDIR += speex
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
new file mode 100644
index 000000000000..1d483cd10dcf
--- /dev/null
+++ b/audio/soundtouch/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: SoundTouch
+# Date created: 16 May 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= soundtouch
+DISTVERSION= 1.3.0
+CATEGORIES= audio
+MASTER_SITES= http://sky.prohosting.com/oparviai/soundtouch/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= An open-source audio processing library
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/SoundTouch-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|; s|$$(prefix)/doc|$$(datadir)/doc|' \
+ ${WRKSRC}/source/example/bpm/Makefile.in \
+ ${WRKSRC}/source/example/SoundStretch/Makefile.in \
+ ${WRKSRC}/source/SoundTouch/Makefile.in \
+ ${WRKSRC}/include/Makefile.in ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's/ install-pkgdocDATA$$//' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/soundtouch/distinfo b/audio/soundtouch/distinfo
new file mode 100644
index 000000000000..707f02a0be72
--- /dev/null
+++ b/audio/soundtouch/distinfo
@@ -0,0 +1,2 @@
+MD5 (soundtouch_v1.3.0.zip) = 5c2d3f54320e5197885b3462f5f35a15
+SIZE (soundtouch_v1.3.0.zip) = 436780
diff --git a/audio/soundtouch/pkg-descr b/audio/soundtouch/pkg-descr
new file mode 100644
index 000000000000..635f98642d60
--- /dev/null
+++ b/audio/soundtouch/pkg-descr
@@ -0,0 +1,17 @@
+SoundTouch is an open-source audio processing library for changing the
+Tempo, Pitch and Playback Rates of audio streams or files:
+
+ * Tempo (time-stretch): Changes the sound to play at faster or slower
+ speed than original, without affecting the sound pitch
+ * Pitch (key): Changes the sound pitch or key, without affecting the
+ sound tempo or speed
+ * Playback Rate: Changes both the sound tempo and pitch, as if an LP
+ disc was played at wrong RPM rate
+
+The SoundTouch library is suited for application developers writing sound
+processing tools that require tempo/pitch control functionality, or just for
+playing around with the sound effects. The source kit includes also an
+example utility SoundStretch that allows processing .WAV audio files with
+command-line interface.
+
+WWW: http://sky.prohosting.com/oparviai/soundtouch/
diff --git a/audio/soundtouch/pkg-plist b/audio/soundtouch/pkg-plist
new file mode 100644
index 000000000000..12a0de57cff9
--- /dev/null
+++ b/audio/soundtouch/pkg-plist
@@ -0,0 +1,15 @@
+bin/soundstretch
+include/soundtouch/BPMDetect.h
+include/soundtouch/FIFOSampleBuffer.h
+include/soundtouch/FIFOSamplePipe.h
+include/soundtouch/STTypes.h
+include/soundtouch/SoundTouch.h
+@dirrm include/soundtouch
+lib/libBPM.a
+lib/libBPM.la
+lib/libSoundTouch.a
+lib/libSoundTouch.la
+share/aclocal/soundtouch.m4
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.TXT
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%