aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-03-15 20:44:12 +0800
committerlinimon <linimon@FreeBSD.org>2018-03-15 20:44:12 +0800
commit7570bf7d15be707a3d7e195c79a6103828f34b01 (patch)
treeb2b48ba63955257d874727ae6d41ce759f744117
parentbdb148b5a503b82f930ae04a983ad4ea4188a76f (diff)
downloadfreebsd-ports-gnome-7570bf7d15be707a3d7e195c79a6103828f34b01.tar.gz
freebsd-ports-gnome-7570bf7d15be707a3d7e195c79a6103828f34b01.tar.zst
freebsd-ports-gnome-7570bf7d15be707a3d7e195c79a6103828f34b01.zip
Mark as broken on armvX. Pet portlint.
Approved by: portmgr (tier-2 blanket)
-rw-r--r--devel/llvm35/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/llvm35/Makefile b/devel/llvm35/Makefile
index 2c4d7b6e2eea..383d45f7a812 100644
--- a/devel/llvm35/Makefile
+++ b/devel/llvm35/Makefile
@@ -11,6 +11,10 @@ PKGNAMESUFFIX= ${LLVM_SUFFIX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
+BROKEN_aarch64= fails to build
+BROKEN_armv6= fails to build: llvm-config.cpp:46:10: 'LibraryDependencies.inc' file not found
+BROKEN_armv7= fails to build: llvm-config.cpp:46:10: 'LibraryDependencies.inc' file not found
+
LLVM_SUFFIX= ${PORTVERSION:C/([0-9]\.[0-9]).*/\1/:S/.//g:C/r.//}
LLVM_PREFIX= ${PREFIX}/llvm${LLVM_SUFFIX}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${LLVM_SUFFIX}
@@ -142,10 +146,6 @@ PLIST_FILES+= ${MAN1SRCS:S|^|man/man1/|:S|.1$|${LLVM_SUFFIX}.1.gz|}
BROKEN= CMake support only works with clang
.endif
-.if ${ARCH} == "aarch64"
-BROKEN= Does not compile on aarch64
-.endif
-
.if ${ARCH} == "amd64"
CONFIGURE_ARGS+= --enable-pic --with-pic
.endif