aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-05-08 11:38:34 +0800
committeradamw <adamw@FreeBSD.org>2003-05-08 11:38:34 +0800
commit7662279af224d665440169146cbabd633af09272 (patch)
tree3b4ecb55f35158d515b64c3c9e929f4070012791
parent3271ede00508faa6946a651781841eef978a818a (diff)
downloadfreebsd-ports-gnome-7662279af224d665440169146cbabd633af09272.tar.gz
freebsd-ports-gnome-7662279af224d665440169146cbabd633af09272.tar.zst
freebsd-ports-gnome-7662279af224d665440169146cbabd633af09272.zip
Add missing dependency on devel/trio, and fix build. Might just be me,
but this program still dumps core whenever I run it.
-rw-r--r--misc/terraform/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/misc/terraform/Makefile b/misc/terraform/Makefile
index 495bfdd4be7e..a175fec1cb4c 100644
--- a/misc/terraform/Makefile
+++ b/misc/terraform/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive height field generation and manipulation program
+BUILD_DEPENDS= ${LOCALBASE}/lib/libtrio.a:${PORTSDIR}/devel/trio
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
intl.4:${PORTSDIR}/devel/gettext \
png.5:${PORTSDIR}/graphics/png \
@@ -31,7 +32,8 @@ CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
USE_GMAKE= yes
post-patch:
- @${REINPLACE_CMD} -e "s|Bison |Bison|" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|Bison |Bison|; \
+ s|-ltrio $$LIBS|-ltrio -lm $$LIBS|" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|" ${WRKSRC}/src/xmlsupport.c
.include <bsd.port.mk>