aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2012-06-05 03:11:13 +0800
committermatthew <matthew@FreeBSD.org>2012-06-05 03:11:13 +0800
commit79a2932c0f4e2e4ad1953df2b1b49c2231d16728 (patch)
tree054e5097d93bc8c1ab9756095b281034cc31891c
parent1386a52935de05cbcc42706c8b27c286c196cab9 (diff)
downloadfreebsd-ports-gnome-79a2932c0f4e2e4ad1953df2b1b49c2231d16728.tar.gz
freebsd-ports-gnome-79a2932c0f4e2e4ad1953df2b1b49c2231d16728.tar.zst
freebsd-ports-gnome-79a2932c0f4e2e4ad1953df2b1b49c2231d16728.zip
- Fix USE_APACHE syntax
- Set RUN_DEPENDS from BUILD_DEPENDS - update to new OPTIONS framework Approved by: shaun (mentor) PR: ports/168143 Submitted by: me
-rw-r--r--www/p5-HTML-Mason/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/www/p5-HTML-Mason/Makefile b/www/p5-HTML-Mason/Makefile
index 448c3d434f4e..bc13b2e2383a 100644
--- a/www/p5-HTML-Mason/Makefile
+++ b/www/p5-HTML-Mason/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= p5-Class-Container>=0.7:${PORTSDIR}/devel/p5-Class-Container \
p5-Exception-Class>=1.15:${PORTSDIR}/devel/p5-Exception-Class \
p5-Log-Any>=0.08:${PORTSDIR}/devel/p5-Log-Any \
p5-Cache-Cache>=1:${PORTSDIR}/devel/p5-Cache-Cache
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
PERL_MODBUILD= yes
@@ -56,7 +57,8 @@ MAN3= Bundle::HTML::Mason.3 \
HTML::Mason::Tools.3 \
HTML::Mason::Utils.3
-OPTIONS= MOD_PERL "with mod_perl dependency" off
+OPTIONS_DEFINE= MOD_PERL
+MOD_PERL_DESC= with mod_perl dependency
post-build:
${MV} -f ${WRKSRC}/bin ${WRKSRC}/bin.orig
@@ -65,11 +67,11 @@ post-build:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/blib/script.orig/mason.pl ${PREFIX}/bin
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MOD_PERL)
-USE_APACHE= 2.0+
+.if ${PORT_OPTIONS:MMOD_PERL}
+USE_APACHE= 20+
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>