aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-22 04:16:29 +0800
committerantoine <antoine@FreeBSD.org>2014-01-22 04:16:29 +0800
commit7e155aea41c3466b36429579308cae59207975b8 (patch)
tree1f3077376c05bbba92b7f628de39d5745dad8ef6
parent877a71f062649f1a92551a1bcd01e6d361180b15 (diff)
downloadfreebsd-ports-gnome-7e155aea41c3466b36429579308cae59207975b8.tar.gz
freebsd-ports-gnome-7e155aea41c3466b36429579308cae59207975b8.tar.zst
freebsd-ports-gnome-7e155aea41c3466b36429579308cae59207975b8.zip
Stage support
-rw-r--r--graphics/gimp-focusblur-plugin/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/graphics/gimp-focusblur-plugin/Makefile b/graphics/gimp-focusblur-plugin/Makefile
index 239dace43516..8c5e4fce32b5 100644
--- a/graphics/gimp-focusblur-plugin/Makefile
+++ b/graphics/gimp-focusblur-plugin/Makefile
@@ -12,12 +12,12 @@ PKGNAMESUFFIX= -plugin
MAINTAINER= ports@FreeBSD.org
COMMENT= Gimp realistic focus blur plugin
-LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
- gimp-2.0:${PORTSDIR}/graphics/gimp-app
-
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
+
USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -29,16 +29,11 @@ PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
post-patch:
@${REINPLACE_CMD} -e 's|^bindir = .*|bindir = ${PREFIX}/${PLUGIN_DIR}|g' ${WRKSRC}/src/Makefile.in