aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2013-11-19 02:08:26 +0800
committerdbn <dbn@FreeBSD.org>2013-11-19 02:08:26 +0800
commit7fbefd39e850ab862e00e6df936373b085b0e580 (patch)
tree47ecc54c0426ef486fbfee4871e93dbe1380e90f
parentde681e064d8c41bad0e2064a650458f98f58a37d (diff)
downloadfreebsd-ports-gnome-7fbefd39e850ab862e00e6df936373b085b0e580.tar.gz
freebsd-ports-gnome-7fbefd39e850ab862e00e6df936373b085b0e580.tar.zst
freebsd-ports-gnome-7fbefd39e850ab862e00e6df936373b085b0e580.zip
Add stage support and strip library for achivers/py-liblzma.
Bump PORTREVISION due to the stripped library (package content change).
-rw-r--r--archivers/py-liblzma/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/archivers/py-liblzma/Makefile b/archivers/py-liblzma/Makefile
index afa76a8be8cf..2c96256be306 100644
--- a/archivers/py-liblzma/Makefile
+++ b/archivers/py-liblzma/Makefile
@@ -3,7 +3,7 @@
PORTNAME= liblzma
PORTVERSION= 0.5.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= archivers python
MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
MASTER_SITE_SUBDIR= source/p/py${PORTNAME}
@@ -13,7 +13,6 @@ DISTNAME= ${PYDISTUTILS_PKGNAME}-${PORTVERSION}
MAINTAINER= dbn@FreeBSD.org
COMMENT= Python binding for the LZMA compression library
-NO_STAGE= yes
USES= pkgconfig
USE_BZIP2= yes
USE_PYTHON= 2.6+
@@ -23,11 +22,14 @@ PYDISTUTILS_PKGNAME= py${PORTNAME}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
-LIB_DEPENDS+= lzma.5:${PORTSDIR}/archivers/xz
+LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/xz
.else
post-patch:
@${REINPLACE_CMD} -e 's/pc_cflags = .*/pc_cflags = ""/' \
-e 's/pc_libs = .*/pc_libs = "-llzma"/' ${WRKSRC}/setup.py
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/lzma.so
+
.include <bsd.port.post.mk>