aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-07-23 21:10:12 +0800
committerolgeni <olgeni@FreeBSD.org>2010-07-23 21:10:12 +0800
commit7fca68f6c0506baedb0755f4250fa79e567edc62 (patch)
tree34dd1d51b6459be95a71ef817c295a1fd7b9b990
parent905e95bae61925ab46bc13d2f438fe5c018eaee2 (diff)
downloadfreebsd-ports-gnome-7fca68f6c0506baedb0755f4250fa79e567edc62.tar.gz
freebsd-ports-gnome-7fca68f6c0506baedb0755f4250fa79e567edc62.tar.zst
freebsd-ports-gnome-7fca68f6c0506baedb0755f4250fa79e567edc62.zip
Building textproc/cl-meta-clisp fails with the following message:
;; Compiling file /usr/local/lib/common-lisp/meta/meta.lisp ... *** - SYSTEM::LINE-COMMENT-READER: Invalid byte #xFC in CHARSET:ASCII conversion It turns out that clisp does not like non-ASCII characters, even in comments. textproc/cl-meta contains source code for textproc/cl-meta-clisp: patch a comment line to use "Nuremberg" rather than the actual German spelling, which contains the 0xFC character (U-umlaut). This unbreaks textproc/cl-meta-clisp. Noticed by: QAT via itetcu, pointyhat via pav
-rw-r--r--textproc/cl-meta/Makefile2
-rw-r--r--textproc/cl-meta/files/patch-meta.lisp14
2 files changed, 15 insertions, 1 deletions
diff --git a/textproc/cl-meta/Makefile b/textproc/cl-meta/Makefile
index 776deda75add..ca445d796761 100644
--- a/textproc/cl-meta/Makefile
+++ b/textproc/cl-meta/Makefile
@@ -6,7 +6,7 @@
PORTNAME= meta
PORTVERSION= 0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc lisp
MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
diff --git a/textproc/cl-meta/files/patch-meta.lisp b/textproc/cl-meta/files/patch-meta.lisp
new file mode 100644
index 000000000000..355532573b1a
--- /dev/null
+++ b/textproc/cl-meta/files/patch-meta.lisp
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- meta.lisp.orig
++++ meta.lisp
+@@ -47,7 +47,7 @@
+ ;;;; Proc. 19'th Nat'l. Conf. of the ACM (Aug. 1964),D1.3-1-D1.3-11.
+ ;;;;
+ ;;;;
+-;;;; Nürnberg, 01.Jul.2001 Jochen Schmidt
++;;;; Nuremberg, 01.Jul.2001 Jochen Schmidt
+
+
+ (in-package :meta)