aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlesi <lesi@FreeBSD.org>2005-07-31 01:48:41 +0800
committerlesi <lesi@FreeBSD.org>2005-07-31 01:48:41 +0800
commit812cf9721efb450a39e53840f379a28510e08c40 (patch)
treec0afe5e010450cd97ab8fff97d4fdefcdf1d4b7d
parenta00f50a9945fb46460a023fc391325c0c3f02b82 (diff)
downloadfreebsd-ports-gnome-812cf9721efb450a39e53840f379a28510e08c40.tar.gz
freebsd-ports-gnome-812cf9721efb450a39e53840f379a28510e08c40.tar.zst
freebsd-ports-gnome-812cf9721efb450a39e53840f379a28510e08c40.zip
Fix typo that caused compilation error on ia64 and fix a comment.
Reported by: pointyhat via kris Submitted by: Alejandro Pulver (maintainer)
-rw-r--r--games/exmars/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/exmars/Makefile b/games/exmars/Makefile
index 8f27e09ea025..29e87cfc8ae0 100644
--- a/games/exmars/Makefile
+++ b/games/exmars/Makefile
@@ -36,7 +36,7 @@ do-install:
BADCFLAGS+= -malign-double
.endif
-.if ${ARCH} != "amd64" && ${ARCH} != "ia64"
+.if ${ARCH} != "amd64" && ${ARCH} != "i386"
BADCFLAGS+= -maccumulate-outgoing-args \
-minline-all-stringops \
-mno-align-stringops
@@ -53,8 +53,10 @@ post-patch:
s|\./exmars|exmars|' \
${WRKSRC}/bench.sh
-# Enable/disable compilation optimizations
+# Fix Makefile
@${REINPLACE_CMD} -e 's|\($${OPT}\)|${CFLAGS} \1|' ${WRKSRC}/${MAKEFILE}
+
+# Enable/disable compilation optimizations
.if !defined(WITH_OPTIMIZED_CFLAGS) || ${OSVERSION} < 500035
@${REINPLACE_CMD} -e 's|$${OPT}||' ${WRKSRC}/${MAKEFILE}
.endif