aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2009-07-13 20:48:28 +0800
committergahr <gahr@FreeBSD.org>2009-07-13 20:48:28 +0800
commit837d8be9ce3fb9a1790a3de2ed565774f1463103 (patch)
tree4dcebb939b4c0dd170483ab80f2fe84a7c89431d
parent0c018fd1b8d308a9c033bdae93a0af37ba85058e (diff)
downloadfreebsd-ports-gnome-837d8be9ce3fb9a1790a3de2ed565774f1463103.tar.gz
freebsd-ports-gnome-837d8be9ce3fb9a1790a3de2ed565774f1463103.tar.zst
freebsd-ports-gnome-837d8be9ce3fb9a1790a3de2ed565774f1463103.zip
- New port: x11/ooxcb
ooxcb (the object oriented X C binding) is a new Python binding to the X server using XCB.
-rw-r--r--x11/Makefile1
-rw-r--r--x11/ooxcb/Makefile22
-rw-r--r--x11/ooxcb/distinfo3
-rw-r--r--x11/ooxcb/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index c1247626bdf6..75c0139e9878 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -233,6 +233,7 @@
SUBDIR += nvidia-xconfig
SUBDIR += oooqs
SUBDIR += oooqs2
+ SUBDIR += ooxcb
SUBDIR += p5-Clipboard
SUBDIR += p5-X11-GUITest
SUBDIR += p5-X11-IdleTime
diff --git a/x11/ooxcb/Makefile b/x11/ooxcb/Makefile
new file mode 100644
index 000000000000..0a032d5d44f5
--- /dev/null
+++ b/x11/ooxcb/Makefile
@@ -0,0 +1,22 @@
+# New ports collection Makefile for: ooxcb
+# Date created: 26 June 2009
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= ooxcb
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://samurai-x.org/downloads/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Python binding to the X server using xcb
+
+LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PLIST_FILES= ${PYTHON_SITELIBDIR:S/${LOCALBASE}\///}/${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>
diff --git a/x11/ooxcb/distinfo b/x11/ooxcb/distinfo
new file mode 100644
index 000000000000..e9de7c9ec8cd
--- /dev/null
+++ b/x11/ooxcb/distinfo
@@ -0,0 +1,3 @@
+MD5 (ooxcb-1.0.tar.gz) = 26df9cf051dfae6c49fa37d2c353ce49
+SHA256 (ooxcb-1.0.tar.gz) = 2f97a7fef7625bc6e18059e15bde4ef505cbf2dd2000de5249c416cb0311becf
+SIZE (ooxcb-1.0.tar.gz) = 159583
diff --git a/x11/ooxcb/pkg-descr b/x11/ooxcb/pkg-descr
new file mode 100644
index 000000000000..bf65db82ec02
--- /dev/null
+++ b/x11/ooxcb/pkg-descr
@@ -0,0 +1,6 @@
+ooxcb (the object oriented X C binding is a new Python binding to the X server,
+developed for the samurai-x window manager. xpyb uses a wrapper generator to
+create python modules out of the XML X protocol descriptions of the xcb project.
+It aims to provide with an easy-to-use object-oriented interface to the X server.a
+
+WWW: http://samurai-x.org/