aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-19 00:08:07 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-19 00:08:07 +0800
commit87eecaa444fd44f7696c3e3704fbd5c681694590 (patch)
tree6e79f3d1fd93e2bfe87735c0c20da5463f89d684
parent7055a747b6d4a49370037b0a133d0254dd89e0b5 (diff)
downloadfreebsd-ports-gnome-87eecaa444fd44f7696c3e3704fbd5c681694590.tar.gz
freebsd-ports-gnome-87eecaa444fd44f7696c3e3704fbd5c681694590.tar.zst
freebsd-ports-gnome-87eecaa444fd44f7696c3e3704fbd5c681694590.zip
- Remove the indefinite article from COMMENT
- Add stage support
-rw-r--r--games/ptkei/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/ptkei/Makefile b/games/ptkei/Makefile
index 2b71be6ad4d3..e2d6dc7902f4 100644
--- a/games/ptkei/Makefile
+++ b/games/ptkei/Makefile
@@ -8,25 +8,24 @@ CATEGORIES= games
MASTER_SITES= http://www.lfmm.org/ptkei/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Python/Tk graphical client for Wolfpack Empire servers
+COMMENT= Python/Tk graphical client for Wolfpack Empire servers
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
USE_PYTHON= yes
-NO_STAGE= yes
do-build:
- @${FIND} ${WRKSRC} -name "*.pyc" | ${XARGS} ${RM}
+ @${FIND} ${WRKSRC} -name "*.pyc" -delete
@${FIND} ${WRKSRC} \( -type f -or -type l \) | ${XARGS} ${CHMOD} 644
@${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} 755
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC} 2>/dev/null
do-install:
- ${MKDIR} ${PREFIX}/share/ptkei
- ${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${PREFIX}/share/ptkei --unlink -xf -
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${STAGEDIR}${DATADIR} --unlink -xf -
${SED} -e "s#%%PREFIX%%#${PREFIX}# ; s#%%PYTHON_CMD%%#${PYTHON_CMD}#" \
${FILESDIR}/ptkei > ${WRKDIR}/ptkei.tmp
- ${INSTALL_SCRIPT} ${WRKDIR}/ptkei.tmp ${PREFIX}/bin/ptkei
+ ${INSTALL_SCRIPT} ${WRKDIR}/ptkei.tmp ${STAGEDIR}${PREFIX}/bin/ptkei
.include <bsd.port.mk>