aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-11-18 15:53:06 +0800
committermarino <marino@FreeBSD.org>2013-11-18 15:53:06 +0800
commit894bdea54bb1730226d7c74752b173992e195a90 (patch)
tree2d9915d6f0fb55d18db1415c0c1b3a5a8e5058d6
parent77b1b1b869282e67f3620660f50471ea453ed40b (diff)
downloadfreebsd-ports-gnome-894bdea54bb1730226d7c74752b173992e195a90.tar.gz
freebsd-ports-gnome-894bdea54bb1730226d7c74752b173992e195a90.tar.zst
freebsd-ports-gnome-894bdea54bb1730226d7c74752b173992e195a90.zip
devel/gdb66: Disable -Werror to unbreak build on F10 and DragonFly
Also: * Remove extra whitespace from WWW * Convert USE_GMAKE to USES * Remove ?= from comment; this is not a master port * Align with 2 tabs Approved by: portmgr (bapt, implicit)
-rw-r--r--devel/gdb66/Makefile12
-rw-r--r--devel/gdb66/pkg-descr4
2 files changed, 8 insertions, 8 deletions
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 77d3aabeeaec..e4025ef17f6f 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -11,7 +11,7 @@ MASTER_SITE_SUBDIR=gdb/:gdb
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gdb
MAINTAINER= mi@aldan.algebra.com
-COMMENT?= GNU GDB of newer version than comes with the system
+COMMENT= GNU GDB of newer version than comes with the system
PKGNAMESUFFIX= 66
@@ -21,27 +21,27 @@ INSIGHT_DESC= Tcl/Tk GUI (experimental!)
CONFLICTS?= gdb-[7-9]*
USE_BZIP2= yes
USE_GCC= any
-USE_GMAKE= yes
-USES= gettext iconv
+USES= gettext iconv gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
+ --disable-werror \
--enable-target=all \
--enable-tui ${ICONV_CONFIGURE_ARG}
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect readline sim texinfo intl
EXTRACT_AFTER_ARGS= ${EXCLUDE:S/^/--exclude /}
-VER= ${PORTVERSION:S/.//}
+VER= ${PORTVERSION:S/.//}
PLIST_SUB= VER=${VER}
-MAN1= gdb${VER}.1
+MAN1= gdb${VER}.1
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MINSIGHT}
PKGNAMESUFFIX= -insight
-USE_TK= 84+
+USE_TK= 84+
LIB_DEPENDS= itk:${PORTSDIR}/x11-toolkits/itk
RUN_DEPENDS= ${LOCALBASE}/lib/iwidgets:${PORTSDIR}/x11-toolkits/iwidgets
DISTFILES+= gdbtk-6.6${EXTRACT_SUFX}:gdbtk
diff --git a/devel/gdb66/pkg-descr b/devel/gdb66/pkg-descr
index fccef8873b67..3c2336d7d5ee 100644
--- a/devel/gdb66/pkg-descr
+++ b/devel/gdb66/pkg-descr
@@ -1,4 +1,4 @@
GNU GDB - the version, for which the "Insight" GUI is available.
-WWW: http://sourceware.org/insight/
-WWW: http://www.gnu.org/software/gdb/
+WWW: http://sourceware.org/insight/
+WWW: http://www.gnu.org/software/gdb/