aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1995-10-04 05:19:24 +0800
committerjmz <jmz@FreeBSD.org>1995-10-04 05:19:24 +0800
commit8a7033147a13699ea4e823cca4ab3517599020ac (patch)
treeb4f98d86c147a625d83fb0e258c16b58638ad2c7
parent3b0a0d13baed38ad5c20a1070b273c4d97ded219 (diff)
downloadfreebsd-ports-gnome-8a7033147a13699ea4e823cca4ab3517599020ac.tar.gz
freebsd-ports-gnome-8a7033147a13699ea4e823cca4ab3517599020ac.tar.zst
freebsd-ports-gnome-8a7033147a13699ea4e823cca4ab3517599020ac.zip
Add a pre-fetch target to make ftpget executable. This fixes the message
'ports/print/tex/files/ftpget: not found'
-rw-r--r--print/latex/Makefile5
-rw-r--r--print/tex/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/print/latex/Makefile b/print/latex/Makefile
index 85c85c9fc59a..fa8b1d52e2ef 100644
--- a/print/latex/Makefile
+++ b/print/latex/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 September 1994
# Whom: jmz
#
-# $Id: Makefile,v 1.17 1995/06/27 12:56:00 jmz Exp $
+# $Id: Makefile,v 1.18 1995/09/23 20:23:18 jmz Exp $
#
VERSION= 95.06
DISTNAME= latex
@@ -32,6 +32,9 @@ latex_tfm-${VERSION}.tar.gz:
latex_tools-${VERSION}.tar.gz:
@${FTPGET} ${CTAN} /tex-archive/macros latex/packages/tools.tar.gz ${DISTDIR}/$@
+pre-fetch:
+ @chmod +x ${FTPGET}
+
do-build:
@(cd ${WRKSRC}/base; yes | initex unpack.ins)
@(cd ${WRKSRC}/base; TEXFONTS=${WRKSRC}/tfm:; export TEXFONTS; \
diff --git a/print/tex/Makefile b/print/tex/Makefile
index ef1a4fd6f751..186e35770b0d 100644
--- a/print/tex/Makefile
+++ b/print/tex/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 September 1994
# Whom: jmz
#
-# $Id: Makefile,v 1.15 1995/04/17 20:31:35 asami Exp $
+# $Id: Makefile,v 1.16 1995/04/21 00:21:27 jmz Exp $
#
DISTNAME= web2c-6.1
@@ -44,6 +44,9 @@ modes.mf:
tex_base.tar.gz:
@${FTPGET} ${CTAN} /tex-archive/macros plain/base.tar.gz ${DISTDIR}/$@
+pre-fetch:
+ @chmod +x ${FTPGET}
+
do-build:
@(cd ${WRKSRC}/web2c; make triptrap)
@(cd ${WRKSRC}/web2c; make run-triptrap)